PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > General Forums > General PT Cruiser Discussions

PT Cruiser Forum

Advertisements
Power steering pump pulley ?

 
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 09 Aug 2004, 06:18 pm
JGN JGN is offline
Young Cruiser
 
Join Date: Jul 2004
Location: Mississauga / Toronto, Canada.
Posts: 58
Default Power steering pump pulley ?



Has anyone heard of the Power steering pump pulley causing a noise when the engine is cold ?

Trying endlessly to get it fixed

and help would be welcomed

THANKS
Reply With Quote
  #2 (permalink)  
Old 09 Aug 2004, 06:35 pm
Obsessed Cruiser
 
Join Date: Sep 2001
Posts: 27,744
Default

I had the Power Steering Pump fail completely...but it sure didn't make any noise or give any kind of warning before it blew. That wasn't a fun experience I can tell you! []

I can tell you that on my wife's KIA Sportage, it was making a terrible racket that sounded mechanical to me but the dealer said it was the belts. Finally took it in to replace the belts and sure enough the noise went away. That noise was only when it was cold.
__________________
Rules of the forum have been updated as of *07/07/2019* Please read them over.

- All decisions by the Moderator are semi-permanent, can and may be changed at his discretion but definitely will be the final word. Any action performed by the Administrator or Moderators are not to be discussed on the forum.
Reply With Quote
  #3 (permalink)  
Old 10 Aug 2004, 12:03 am
Cool Cruiser
 
Join Date: May 2003
Location: South Bend, IN.
Posts: 473
Default

There is a current TSB available ONLY from Chrysler STAR hotline for the PS pully alignment.

I spent last Friday afternoon with this situation, and Mopar's STAR line was the only place the answer is written by Chrysler.

(and NO, I don't have a TSB number)
Reply With Quote
  #4 (permalink)  
Old 10 Aug 2004, 12:11 am
Cool Cruiser
 
Join Date: May 2004
Location: Los Alamitos, CA, USA.
Posts: 430
Default

Hmmmmmm, I had a slight growel from the PS pump when I came back from Stage I Quick Learn Procedure. I forgot about today and didn't notice it on the 20 mi to and 20 mi from work today. Any post on the TSB would be appreciated. Thanks, MX-5.

John
__________________
Inferno Red \'04 GT Autostick, Stage I, BTG exhaust, Airforce One intake, V.A.K. Candy Red upper charge pipe, BTG strut bar,Hyperground, chrome side spears and grill accents.
Reply With Quote
  #5 (permalink)  
Old 10 Aug 2004, 07:51 am
quicksilverdon's Avatar
Obsessed Cruiser
 
Join Date: Nov 2003
Location: Felton, Delaware
Posts: 20,501
Default

The reason why noise is pronounced when cold is because rubber is one of the few things that contract when heated - the belt gets tighter when things warm up. Dunno how that helps diagnose, just chiming in...[:I]
__________________
"Anti-intellectualism has been a constant thread winding its way through our political and cultural life,
nurtured by the false notion that democracy means that 'my ignorance is just as good as your knowledge."
Isaac Asimov"

'05 Limited Turbo Lite, (Silver, of course)4-wheel ABS, Sunroof, Spoiler. Mods: E&G Classic grill, K&N FIPK, BTG duals, rear lowered 1.5", LED washer lights, $20 catch can, Aoogah horn, Weatherflectors, Sunroof Deflector, Fuzzy Dice, rear logo flames, rear pinstripe graphic, Gen3 Taillights, rear sway bar, hood struts, Strut bar.
Traded in '02 Silver Touring Edition w/87,000 miles
Reply With Quote
  #6 (permalink)  
Old 10 Aug 2004, 09:52 pm
Cool Cruiser
 
Join Date: Sep 2001
Location: Hammonton, New Jersey, USA.
Posts: 352
Default

Mine started whining and leaking. The dealer replaced it. They had to wait 4 days for a new pump. My son- in law had his crap out the same way and I know of 4 other cruisers that had the same problem.
__________________
Greg Gavencky
The New Jersey Cruisers
www.njcruisers.com
Reply With Quote
  #7 (permalink)  
Old 11 Aug 2004, 07:11 pm
JGN JGN is offline
Young Cruiser
 
Join Date: Jul 2004
Location: Mississauga / Toronto, Canada.
Posts: 58
Default



Well after having the car at the dealership 5 times !!!!!!!!!!!

IT HAS AT LONG LAST BEEN FIXED

What was needed was an after market cog belt supplied by Chrysler...

The noise is now GONE thank god..

If anyone needs the part number I have it

JGN
Reply With Quote
  #8 (permalink)  
Old 12 Aug 2004, 07:27 am
quicksilverdon's Avatar
Obsessed Cruiser
 
Join Date: Nov 2003
Location: Felton, Delaware
Posts: 20,501
Default

Quote:
quote:Originally posted by JGN



What was needed was an after market cog belt supplied by Chrysler...
So it was the belt? Coulda been MUCH worse.

Why not post the part and maker? Sooner or later I'm gonna need belts.
__________________
"Anti-intellectualism has been a constant thread winding its way through our political and cultural life,
nurtured by the false notion that democracy means that 'my ignorance is just as good as your knowledge."
Isaac Asimov"

'05 Limited Turbo Lite, (Silver, of course)4-wheel ABS, Sunroof, Spoiler. Mods: E&G Classic grill, K&N FIPK, BTG duals, rear lowered 1.5", LED washer lights, $20 catch can, Aoogah horn, Weatherflectors, Sunroof Deflector, Fuzzy Dice, rear logo flames, rear pinstripe graphic, Gen3 Taillights, rear sway bar, hood struts, Strut bar.
Traded in '02 Silver Touring Edition w/87,000 miles
Reply With Quote
  #9 (permalink)  
Old 12 Aug 2004, 10:04 am
JGN JGN is offline
Young Cruiser
 
Join Date: Jul 2004
Location: Mississauga / Toronto, Canada.
Posts: 58
Default

OK it was

a OEM BELT with POLYCOG aftermarket belt per Chrysler Engineering

FP NUMBER PO17308 serp belt


Hope that helps

JGN


Quote:
quote:Originally posted by quicksilverdon

Quote:
quote:Originally posted by JGN



What was needed was an after market cog belt supplied by Chrysler...
So it was the belt? Coulda been MUCH worse.

Why not post the part and maker? Sooner or later I'm gonna need belts.
Reply With Quote
  #10 (permalink)  
Old 13 Aug 2004, 09:49 pm
Cool Cruiser
 
Join Date: Oct 2002
Location: Williamsport, Md, USA.
Posts: 257
Default

[:I] Was it the power steering belt?

Good for you it's fixed!
__________________
Hey look guy, The closer you tailgate..the slower I go!
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Power steering issues matt87951 Tech & Performance Forum 18 24 Apr 2009 07:10 am
Power steering whine problem identified sawdust123 General Turbo Discussions 5 10 Dec 2008 07:24 pm
ATF + 4 or 5 for power steering? quicksilverdon General PT Cruiser Discussions 2 21 Feb 2005 05:00 pm
I think I'm having a power steering problem! lumofny Tech & Performance Forum 5 18 Jan 2005 01:12 pm
Exfessive whining from power steering Ripped General PT Cruiser Discussions 7 13 Jul 2004 01:46 pm


All times are GMT -5. The time now is 01:40 am.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors