PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > General Forums > General PT Cruiser Discussions

PT Cruiser Forum

Advertisements
Problems I've had in my 2.5 years of ownership

 
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 15 Aug 2004, 03:45 am
Fresh Cruiser
 
Join Date: Feb 2004
Location: EL CERRITO, CA, USA.
Posts: 32
Send a message via AIM to 2207 of 7500
Default Problems I've had in my 2.5 years of ownership

The 1st problem I encountered was last March,'04.... which was almost 2 years since I purchased the car, and had about 30k miles on it.
The steering started binding when crankin the wheel to the right when pulling out of a parking space or something slow like that. The left strut would emit a noise so I figured the strut went bad.
The night before my scheduled appointment at Chrysler service, my power doorlocks decided it wanted to lock themselves, continuously all night long.(don't worry-I took the batteries out of my remote controls just in case your figuring that the batteries in the remotes were just going dead and was making the remote go crazy), and still-it continued to attempt to lock all the doors, even though they were already locked.
.....So I get to the dealership and tell them what my doorlocks and front-left strut is doing and they check it out. They inform me that the relay in the tailgate latch went bad, and that is what caused it to go crazy..... part ordered- cool. They then tell me that the noise I'm hearing is actually comming from the rear sway bar-and the upper-right bushing is bad. I told them that that was a different noise that's been there since day-one with me and I thought nothing of it.... it was the noise in the front that was bothering me, especially if you went over a speed-bump at low speed and heard the strut compress and decompress.
Turns out I did have a bad bushing since day-one and was pleasantly surprized when they replaced it and the noise was gone. Yet - a couple of days later.....the noise in the front-left strut was back. I took it back in where the suspension specialist took a test drive with me and confirmed something was wrong with the front-end.
Further investigation of the front suspension revieled that the whole rack & pinion had gone bad, and needed replacing... free of charge thank God!!!!
Then, just three days ago, my doorlocks went bizurk again.... it was attempting to do the same thing as before, only it was averaging about 3 attempted locks per second......that's right, in ONE minute, it tried to lock itself approx. 90 times. It drove me so insane that I called the service dept., scheduled another appt., and asked them what I could do about the situation until my appt.,which was scheduled two days later, since in a 12 hr. period, the doorlocks had attempted to lock themselves approx. 500 times.... that's is the honest to god truth!!!! They told me to pull a fuse until the service. Sure enough, the tailgate relay went bad again and had to be replaced-only they had the part in-stock!!! Apparently, Chrysler is having a big problem with these relays going bad and now the dealership has them in their inventory...that's bad!!!!
O.K...... end of story....... what's gone wrong with yours????[xx(]
Reply With Quote
  #2 (permalink)  
Old 15 Aug 2004, 05:40 am
Cool Cruiser
 
Join Date: May 2004
Location: East Islip, NY, USA.
Posts: 494
Send a message via AIM to RallyDRock
Default

Ive had my cruiser for a little longer. Since December 2000, and have replaced many parts. Front wheel bearings and hubs, rear center suspension link bearing, control arm bushings, ball joints and boots, left front axle, had a caliper seize up and wipe out the pads and rotor, small clips fall off of rear brake pads causing a chattering noise over cracks and sharp bumps, clockspring in steering wheel hub, and now my steering is acting up too. It will pull to the left sometimes but if i turn the wheel all the way to the right then back straight it will drive fine. I suspect the inner tie rods but since Chrysler doesn't have the part the dealer would suggest rack replacement. Good thing NAPA has them.

All of these problems are a bit disapointing but I still love my cruiser despite the lack of power and poor economy. As of recent I have decided to toss the economy and go with more power, the turbo is on the way!
__________________
www.cardomain.com/id/rallydrock
Reply With Quote
  #3 (permalink)  
Old 15 Aug 2004, 08:35 am
Obsessed Cruiser
 
Join Date: Sep 2001
Posts: 27,744
Default

I bought mine Sept 2000. Just coming up to 61,000 miles. The only thing that failed was the power steering pump. It went without any warning and almost caused me to crash the car. I was told there was a national back-order for the pump, but my dealer found one at another dealer about 100 miles away and I was back on the road in 3 days.
__________________
Rules of the forum have been updated as of *07/07/2019* Please read them over.

- All decisions by the Moderator are semi-permanent, can and may be changed at his discretion but definitely will be the final word. Any action performed by the Administrator or Moderators are not to be discussed on the forum.
Reply With Quote
  #4 (permalink)  
Old 15 Aug 2004, 10:06 am
quicksilverdon's Avatar
Obsessed Cruiser
 
Join Date: Nov 2003
Location: Felton, Delaware
Posts: 20,501
Default

Just passed 76,000 miles. NEVER been back to dealer. had an ignition miss I cured with Crane wires (platinum plugs didn't cure it). That's it.
Mave Michelins now when Good-for-a-years went, Raybestos ceramic pads I did myself.
Change oil (synthetic) & K&N filter every 5,000 miles - use no oil.

I did have to replace a wheel and tire and get an alignment after hitting a HUGE pothole, and it was in the body shop from a deer collision, but I don't regard those as faults of the car.[?]
__________________
"Anti-intellectualism has been a constant thread winding its way through our political and cultural life,
nurtured by the false notion that democracy means that 'my ignorance is just as good as your knowledge."
Isaac Asimov"

'05 Limited Turbo Lite, (Silver, of course)4-wheel ABS, Sunroof, Spoiler. Mods: E&G Classic grill, K&N FIPK, BTG duals, rear lowered 1.5", LED washer lights, $20 catch can, Aoogah horn, Weatherflectors, Sunroof Deflector, Fuzzy Dice, rear logo flames, rear pinstripe graphic, Gen3 Taillights, rear sway bar, hood struts, Strut bar.
Traded in '02 Silver Touring Edition w/87,000 miles
Reply With Quote
  #5 (permalink)  
Old 15 Aug 2004, 12:19 pm
Cool Cruiser
 
Join Date: May 2003
Location: South Bend, IN.
Posts: 473
Default

2001 PT came home on Nov. 13th, 2000 and has never needed service other than general maintenance.

2002 Dream Cruiser was delivered in March 2002 and has never needed anything other than oil changes.

I service over 2 dozen PTs from local owners. The most popular work is brakes and spark plugs/tune-up.
In 4 years, I have only seen 2 EGR solenoids, 2 peeling chrome wheels, and 1 leaking trans solenoid pack gasket. That's not bad for over 500,000 collective miles.
Reply With Quote
  #6 (permalink)  
Old 16 Aug 2004, 02:52 pm
Cool Cruiser
 
Join Date: Jun 2003
Location: wayne, mi., USA.
Posts: 447
Default

I got my cruiser 3\02 and haven't had any problems so far [ knock on wood] as a matter of fact its been the best car I've owned, so far.[^]
__________________


flames&stripes by \"gator\" 2003 milan dragway \"chrysler classic\" winner
Reply With Quote
  #7 (permalink)  
Old 16 Aug 2004, 03:14 pm
Fresh Cruiser
 
Join Date: Jul 2004
Location: Healdsburg, CA, USA.
Posts: 6
Default

Well, I guess I'll reply and probably jinx myself

I got my 2004 GT in January of '03. About 30K miles since then, all I've done is change the oil every 3K. I've had no problems with my Goodyear Eagle tires. Everything continues to run smoothly and no odd ticks, grunts or squeeks.

I've had a wide variety of cars and SUVs and the Cruiser is one of the best I've had (so far). Worst was a Saab 900s...virtually everything on it broke within the warranty period. Tire problems folks report are not unusual. I've had speed rated tires from several mfgs (including Goodyear) all have had problems...I think it is the nature of them.

Reply With Quote
  #8 (permalink)  
Old 17 Aug 2004, 03:37 am
Fresh Cruiser
 
Join Date: Feb 2004
Location: EL CERRITO, CA, USA.
Posts: 32
Send a message via AIM to 2207 of 7500
Default

Thanks to all who replied .... I'm still very happy to own my Cruiser, but it's good to hear other people share their problems or no problems so to look out for things and don't feel like your the only owner who experiences problems .... Thanks[^]
__________________

<b>\'02 Dream Cruiser #2207 of 7500</b> ~ <i>El Cerrito, CA.</i>
Reply With Quote
  #9 (permalink)  
Old 17 Aug 2004, 01:38 pm
Fresh Cruiser
 
Join Date: Jul 2004
Location: Kentucky, USA.
Posts: 15
Default

I had to replace the passenger side ball joint after previous owner ramped a curb, explained the noise upfront and luckily that was under warranty, the water pump was not... argh. That and some work on my power steering ran up $700 or so in charges, then the AC went out, a high pressure switch or something. If I buy used again, I'm going to think hard about that extended warranty...
__________________
\'01 Patriot Blue, 5 speed, K&N drop in, 16 inch, 5 spoke wheels, custom hail damage to roof and hood!
Reply With Quote
  #10 (permalink)  
Old 17 Aug 2004, 02:58 pm
Fanatic Cruiser
 
Join Date: Jan 2004
Location: McDonough (Atlanta), Georgia, USA.
Posts: 600
Default

I've got two PT Cruisers, the first, a 2001 LE, 45K on it, and the only problem has been one of the front rotors going bad. I also have a 2003 TE, and have had to replace the window switches (lights didn't work on them), and now have a leak detection pump failure, BUT I can still drive the car with the bad ldp until the dealer gets the part in. These are awesome cars, consumer reports rate them one of the best used car buys, and, of course, a good pick as a new car.
__________________
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
problems with lower control arm bushings ValAir Turbo Wheels/Suspension/Handling 37 10 Aug 2015 06:59 am
PLASTIC GT MANIFOLD PROBLEMS? littleblueGT Turbo Performance 45 25 Nov 2011 12:10 pm
So much problems before inspection Ctown General PT Cruiser Discussions 3 12 Apr 2005 07:45 pm
Any problems from "Lighting up the tires"? crazie.eddie Tech & Performance Forum 6 19 Oct 2004 06:43 pm
Problems Oddcouple General PT Cruiser Discussions 1 17 Nov 2002 01:58 pm


All times are GMT -5. The time now is 08:29 am.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors