PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > 2.4L Turbo Forums > General Turbo Discussions

PT Cruiser Forum

Advertisements
Help from gear heads

 
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 24 May 2003, 08:37 pm
Dedicated Cruiser
 
Join Date: Oct 2002
Location: Chicago, IL.
Posts: 2,667
Default Help from gear heads

I just noticed lately that when I'm sitting in idle, my engine/rpms's will increase then drop down on its own. My foot NOT on the gas. any idea why? should I be concerned about it? Thanks
Reply With Quote
  #2 (permalink)  
Old 24 May 2003, 09:08 pm
Fanatic Cruiser
 
Join Date: Mar 2003
Location: Toronto.
Posts: 601
Default

i don't think there's anything to be concerned about, i know in the winter this happens to heat up the engine faster. Are you talking about when you come to a stop and the rpm holds just around 2,000 then drops???
__________________
My Cruiser is slow. I love the law.
Reply With Quote
  #3 (permalink)  
Old 24 May 2003, 09:25 pm
Regular Cruiser
 
Join Date: Dec 2002
Location: Half Moon Bay, CA, USA.
Posts: 114
Default

As long as it's not oscillating up and down, should not be an issue. If it is, likely something in the smog system leaking, like the EGR valve.
__________________
Jumpin\' Joe
\'04 Porsche 911 GT3
\'01 Audi S8
\'05 Chevy 2500HD TurboDiesel
\'05 Suzuki SV650
Reply With Quote
  #4 (permalink)  
Old 25 May 2003, 08:55 pm
Cool Cruiser
 
Join Date: Apr 2003
Location: Ft.Lauderdale, FL.
Posts: 217
Send a message via AIM to Exhaust Depot
Default

Engine loads are constently changine. Fans kick on, A/C kicks on etc. Puts a heavier load on the Alternator which inturns puts a load on the engine. A/C as we all knwo puts a load on the engine.
__________________

E.D. 3\" Turbo Back, , HKS SSBOV, GReddy-e01 Boost controller, Greddy E-manage fuel management, Blitz Turbo Timer, JE pistons, Ported Head, E.D. Large Frontmount Intercooler, E.D. Tubular manifold with t3/t4 (prototype), IPP coilovers, Limited Slip.
Reply With Quote
  #5 (permalink)  
Old 25 May 2003, 09:12 pm
Dedicated Cruiser
 
Join Date: Oct 2002
Location: Chicago, IL.
Posts: 2,667
Default

its more like when I'm at a light or idle and it doesn't drop, it goes up, or revs higher, just a few seconds , then comes back down. I didn't have air or changed any functions while this occured either. I will watch it closer/ Thanks guys
__________________
2003 Turbo GT 5-speed/ www.perfectautofinish.com
Founder/ Chicagoland PT Cruiser Club
Contributing Editor, PTCruiserLinks.com
www.ptcruiserlinks.com/garys-cleaning-tips
Reply With Quote
  #6 (permalink)  
Old 26 May 2003, 01:19 am
Cool Cruiser
 
Join Date: Jan 2003
Location: NJ, USA.
Posts: 362
Default

My 01 did this and my 03 does it also..
__________________
http://www.imagestation.com/album/?id=4290145623
It\'s gone but not forgotten. Still love the Cruiser but my heart got stolen buy a Ruby Red 05 Legacy GT!
Reply With Quote
  #7 (permalink)  
Old 26 May 2003, 02:23 pm
Senior Cruiser
 
Join Date: Jan 2003
Location: Huntington Beach, CA, USA.
Posts: 1,799
Default

That is what they call a "hunting idle" in the Mustang community. Usually a bad or dirty sensor somewhere in the fuel injection. Most often a dirty MAF sensor, but we use a Speed Density FI system not a Mass Air system at least on the GT). I would see if you have any codes indicating problems. Could be an O2 sensor.
__________________
'03 Inferno Red GT, 5 speed, STAGE 1, Mopar BOV, Plastic Intake, Modified Upper and Lower Airbox, Custom Airbox-to-turbo pipe, Borla dual exhaust, Maddog Short Shifter, Drilled/Slotter Rotors, Ceramic Pads, chrome wheels, chrome door spears, AMP chrome fuel door, PT Cruiser 3rd light diffuser, H&R Springs, Rear Sway Bar added, MGW chrome door lock pulls, Blane's hood struts, Custom license plate mount, some interior dress up stuff...more to come
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
p0733 Gear 3 Incorrect ratio p0733 Gear 3 Incorr RobGT General Turbo Discussions 12 04 Nov 2004 02:02 pm
Blown Gear box after Turbo Charging Kboom General Turbo Discussions 4 27 Oct 2004 05:38 am
and so it begins 026TB4U General Turbo Discussions 3 13 Jan 2004 07:04 pm
Gear heads turbomangt Midwest PT Forum 2 31 Aug 2003 08:57 pm


All times are GMT -5. The time now is 03:32 am.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors