PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > 2.4L Turbo Forums > General Turbo Discussions

PT Cruiser Forum

Advertisements
HELP !!!!!!

 
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 27 May 2003, 11:23 pm
Fresh Cruiser
 
Join Date: May 2003
Location: richmond, va, USA.
Posts: 28
Default HELP !!!!!!

i know this is a bit unusual for this forum but i was installing a k&n air filter in my turbo and one of the clips that holds the air cleaner halfs together went bye bye to never be found again...so if anybody has any spare clips just wasting space let me know DC says you must buy the lower half to get the clips.....everybody[xx(]
Reply With Quote
  #2 (permalink)  
Old 27 May 2003, 11:33 pm
Fanatic Cruiser
 
Join Date: Apr 2003
Location: Brunswick, Georgia, USA.
Posts: 518
Default

Try on the non-turbo forums. Some of the 01 and 02 model owners that have put cold air intake systems on may have hardware from their airboxes (removed in the process) that they can send you...
Reply With Quote
  #3 (permalink)  
Old 28 May 2003, 11:47 pm
Fresh Cruiser
 
Join Date: May 2003
Location: richmond, va, USA.
Posts: 28
Default

[|)]THANKS THE PT CRUISER PEOPLE ARE THE BEST I ALREADY HAVE ONE ON THE WAY FROM ANOTHER FORUM.....HAPPYTURBOCRUSIN[8)][|)]
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -5. The time now is 03:32 am.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors