PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > 2.4L Turbo Forums > General Turbo Discussions

PT Cruiser Forum

Advertisements
Upper charge pipe SENSOR BLOW OUT!!!!

 
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 14 Jul 2007, 12:09 pm
Gold GT's Avatar
Young Cruiser
 
Join Date: Mar 2007
Location: Cheyenne, WY
Posts: 54
Default Upper charge pipe SENSOR BLOW OUT!!!!

Just wanted to know if this has ever happened to any of you. A few days ago I noticed my GT was stumbling alittle if I let if fall from a high rpm to idle. I usually drive pretty conservatively as I live close to where I work so it wasn't really a problem at the time. That night I took it out for a drive to figure out what was going on. As I started to build boost it leveled off at 10psi I usually run 15 or 16 psi so I figured no biggie just a boost leak find where it is and fix it. When I opened the hood the sensor in the upper charge pipe the one with a blue end I believe is a MAF or air temp sensor had blow out and was sitting on top of my intake manifold!! I had just replaced my intake manifold a month ago and had to remove that during the install so I thought maybe I just didn't get it in tight enough. So I put it back in and went on my way again however the next day I was pushing it hard again and it came out again!! I haven't had any problems since but both of those days it was REALLY hot is it possible that this had something to do with it as I noticed that it didn't want stay when it was hot and on cold days it's practically sealed in! I was thinking about putting a very very small amount of silicon on the outside of the rubber grommet for warm days. Has this happened to anyone else and if it has what did you do??
__________________
'04 Gold GT 5spd (there is no other way)
Mopar Stage 1 upgrade, Mopar BOV Conversion, AEM CAI, High Flow Haynes Plastic Intake Manifold, MSD High Voltage Ignition Coil Pack, MagnaCore Spark Plug Wires, AutoMeter Boost Gauge, Greddy Oil Catch Can, Hurst STS... Plus a much longer wish list




I DO ALL MY OWN WORK!!
Reply With Quote
  #2 (permalink)  
Old 14 Jul 2007, 12:21 pm
Senior Cruiser
 
Join Date: Jan 2003
Location: Huntington Beach, CA, USA.
Posts: 1,799
Default Re: Upper charge pipe SENSOR BLOW OUT!!!!

Quote:
Originally Posted by Gold GT View Post
Just wanted to know if this has ever happened to any of you. A few days ago I noticed my GT was stumbling alittle if I let if fall from a high rpm to idle. I usually drive pretty conservatively as I live close to where I work so it wasn't really a problem at the time. That night I took it out for a drive to figure out what was going on. As I started to build boost it leveled off at 10psi I usually run 15 or 16 psi so I figured no biggie just a boost leak find where it is and fix it. When I opened the hood the sensor in the upper charge pipe the one with a blue end I believe is a MAF or air temp sensor had blow out and was sitting on top of my intake manifold!! I had just replaced my intake manifold a month ago and had to remove that during the install so I thought maybe I just didn't get it in tight enough. So I put it back in and went on my way again however the next day I was pushing it hard again and it came out again!! I haven't had any problems since but both of those days it was REALLY hot is it possible that this had something to do with it as I noticed that it didn't want stay when it was hot and on cold days it's practically sealed in! I was thinking about putting a very very small amount of silicon on the outside of the rubber grommet for warm days. Has this happened to anyone else and if it has what did you do??
No MAF (Mass Air Flow) sensor on our cars, we use a Speed Density fuel injection that uses a MAP (Manifold Absolute Pressure) sensor. You are probably working with the IAT sensor ( Intake Air Temp).

I wouldn't use anything on it but clean the connector and the rubber really well with alcohol to see if that holds it. If you do decide to use some sealant on it get it at an auto parts store and make sure you get one that says "Sensor Safe" on it. Use very sparingly.
__________________
'03 Inferno Red GT, 5 speed, STAGE 1, Mopar BOV, Plastic Intake, Modified Upper and Lower Airbox, Custom Airbox-to-turbo pipe, Borla dual exhaust, Maddog Short Shifter, Drilled/Slotter Rotors, Ceramic Pads, chrome wheels, chrome door spears, AMP chrome fuel door, PT Cruiser 3rd light diffuser, H&R Springs, Rear Sway Bar added, MGW chrome door lock pulls, Blane's hood struts, Custom license plate mount, some interior dress up stuff...more to come

Last edited by Cal Cruzer; 23 Jul 2007 at 05:48 pm. Reason: reread post
Reply With Quote
  #3 (permalink)  
Old 14 Jul 2007, 12:44 pm
apexanimal's Avatar
Young Cruiser
 
Join Date: Apr 2007
Location: Princeton, NJ
Posts: 59
Send a message via AIM to apexanimal
Default Re: Upper charge pipe SENSOR BLOW OUT!!!!

put the grommet in upside down = large side in the pipe, not out of it. this will hold.
__________________
'03 GT 5spd: Stage 1+
http://www.cardomain.com/ride/2272425
http://www.ptboutique.com
Reply With Quote
  #4 (permalink)  
Old 14 Jul 2007, 12:52 pm
Veteran Cruiser
 
Join Date: Mar 2003
Location: Oregon.
Posts: 3,521
Default Re: Upper charge pipe SENSOR BLOW OUT!!!!

Quote:
Originally Posted by apexanimal View Post
put the grommet in upside down = large side in the pipe, not out of it. this will hold.
Wow, I thought I was the only one who knew this little trick. It works great, especially on an aftermarket ucp.
__________________
\'05 Stone White SRT4

\'04 Graphite PT Automatic
Reply With Quote
  #5 (permalink)  
Old 14 Jul 2007, 09:15 pm
Gold GT's Avatar
Young Cruiser
 
Join Date: Mar 2007
Location: Cheyenne, WY
Posts: 54
Default Re: Upper charge pipe SENSOR BLOW OUT!!!!

Thanks for the info esp. the sensor name good to know still kinda learning my PT, had Japanese for way to long. I knew you guys would have the answer headed out right now to fix. THANKS AGAIN!!!!!
__________________
'04 Gold GT 5spd (there is no other way)
Mopar Stage 1 upgrade, Mopar BOV Conversion, AEM CAI, High Flow Haynes Plastic Intake Manifold, MSD High Voltage Ignition Coil Pack, MagnaCore Spark Plug Wires, AutoMeter Boost Gauge, Greddy Oil Catch Can, Hurst STS... Plus a much longer wish list




I DO ALL MY OWN WORK!!
Reply With Quote
  #6 (permalink)  
Old 19 Jul 2007, 02:29 pm
apexanimal's Avatar
Young Cruiser
 
Join Date: Apr 2007
Location: Princeton, NJ
Posts: 59
Send a message via AIM to apexanimal
Default Re: Upper charge pipe SENSOR BLOW OUT!!!!

Quote:
Originally Posted by Mean Green View Post
Wow, I thought I was the only one who knew this little trick. It works great, especially on an aftermarket ucp.
indeed
__________________
'03 GT 5spd: Stage 1+
http://www.cardomain.com/ride/2272425
http://www.ptboutique.com
Reply With Quote
  #7 (permalink)  
Old 19 Jul 2007, 06:47 pm
Veteran Cruiser
 
Join Date: Mar 2003
Location: Oregon.
Posts: 3,521
Default Re: Upper charge pipe SENSOR BLOW OUT!!!!

Quote:
Originally Posted by apexanimal View Post
indeed
Leave it to the Crew folks to know what's what.
__________________
\'05 Stone White SRT4

\'04 Graphite PT Automatic
Reply With Quote
  #8 (permalink)  
Old 02 Aug 2007, 04:49 pm
Senior Cruiser
 
Join Date: Sep 2002
Location: Just south of the Mason/Dixon line
Posts: 1,715
Default Re: Upper charge pipe SENSOR BLOW OUT!!!!

Quote:
Originally Posted by Mean Green View Post
Leave it to the Crew folks to know what's what.
WoW, back in the day, that was part of a dirty word
__________________
.....................................
'03 GT base w/175k and a 2 speed autostick (read: trans is shot) and powered by a hybrid MOPAR S3 with DSP untuned
1st Forward Motion E1 powered PTGT w/Psi-Fi Power pack fuel tuner back in '07
FS: '03 GT Elec Blue w/rear suicide doors or '03 auto PCM, S3 turbofold, WGA, 3.5" o2 & 3" DP - make offer
Reply With Quote
  #9 (permalink)  
Old 04 Sep 2007, 07:12 pm
Fresh Cruiser
 
Join Date: Sep 2007
Location: connecticut
Posts: 1
Default Re: Upper charge pipe SENSOR BLOW OUT!!!!

i used a dab of superglue on the gromet...issue solved
Reply With Quote
  #10 (permalink)  
Old 04 Sep 2007, 11:18 pm
Gold GT's Avatar
Young Cruiser
 
Join Date: Mar 2007
Location: Cheyenne, WY
Posts: 54
Default Re: Upper charge pipe SENSOR BLOW OUT!!!!

Just an update flipping the sensor over worked perfectly!
__________________
'04 Gold GT 5spd (there is no other way)
Mopar Stage 1 upgrade, Mopar BOV Conversion, AEM CAI, High Flow Haynes Plastic Intake Manifold, MSD High Voltage Ignition Coil Pack, MagnaCore Spark Plug Wires, AutoMeter Boost Gauge, Greddy Oil Catch Can, Hurst STS... Plus a much longer wish list




I DO ALL MY OWN WORK!!
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
AGP PT Upper Hard Pipe - NEW PRODUCT RELEASE! Ben@AGP Vendors & Buyers Forum 2 17 Sep 2012 09:41 am
intake pipe for air and throttle ValAir General Turbo Discussions 4 14 Apr 2007 04:30 pm
NEW INTAKE, UPPER CHARGE PIPING 03baggedturbo Vendors & Buyers Forum 71 25 Jun 2004 08:25 pm
Adam's Intake & Upper Charge Pipe - Dyno'd! Mike-in-Orange Vendors & Buyers Forum 39 29 Mar 2004 12:29 am
Turbo Up Pipe Mean Green Turbo Performance 5 04 Jan 2004 05:11 pm


All times are GMT -5. The time now is 03:17 am.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors