PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > 2.4L Turbo Forums > General Turbo Discussions

PT Cruiser Forum

Advertisements
HELP!!! Car cuts out at 2500 RPMS!!!!

 
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 12 Aug 2009, 07:12 pm
Fresh Cruiser
 
Join Date: Jun 2008
Posts: 17
Exclamation HELP!!! Car cuts out at 2500 RPMS!!!!

Hey guys i am new here so bare with me, you guys are a great help.

anyway i have a 2005 pt cruiser limited turbo lite. i have replaced the spark plugs and wires about a month ago, car has 48000 miles on it. so when i drive the car hard after about a mile of just cruising the check engine light comes on, and then the car is limited to 2500 rpms. now i pulled over and check the code which comes out to be 340 cam shaft error. as soon as i clear the code the car runs wonder full again with no problems what so ever. this has been happening for a week now. it wont come on at all until u drive it hard. thanks anything will help, i am thinking the computer might need to be flash. and MAYBE it needs better spark plugs. i don't think its the cam shaft sensor because would the car not start!!!. thanks.
__________________
2005 PT cruiser Limited Turbo Lite Auto, SCTflashed
Reply With Quote
  #2 (permalink)  
Old 12 Aug 2009, 07:25 pm
quicksilverdon's Avatar
Obsessed Cruiser
 
Join Date: Nov 2003
Location: Felton, Delaware
Posts: 20,501
Default Re: HELP!!! Car cuts out at 2500 RPMS!!!!

It still might be the sensor - starting to go and being temperature sensitive.
Also check the wiring to the sensor.

Here's where to find it:
Help! My Car Cut off while i was driving it
__________________
"Anti-intellectualism has been a constant thread winding its way through our political and cultural life,
nurtured by the false notion that democracy means that 'my ignorance is just as good as your knowledge."
Isaac Asimov"

'05 Limited Turbo Lite, (Silver, of course)4-wheel ABS, Sunroof, Spoiler. Mods: E&G Classic grill, K&N FIPK, BTG duals, rear lowered 1.5", LED washer lights, $20 catch can, Aoogah horn, Weatherflectors, Sunroof Deflector, Fuzzy Dice, rear logo flames, rear pinstripe graphic, Gen3 Taillights, rear sway bar, hood struts, Strut bar.
Traded in '02 Silver Touring Edition w/87,000 miles
Reply With Quote
  #3 (permalink)  
Old 13 Aug 2009, 05:37 am
ChefTank's Avatar
Cool Cruiser
 
Join Date: Jul 2008
Location: huntsvegas AL
Posts: 262
Default Re: HELP!!! Car cuts out at 2500 RPMS!!!!

Your in limp mode... It automatically does this to keep from blowing the motor.




Josh
__________________
This is my turbo History:
Stock turbo (1 year)
Big Wheel Stocker (3 Months)
50trim (2 Weeks)
Stage 3 (3 months)
Big Wheel Stage 3 (6 months) my Fav
Holset HX35 (6 months) 700whp turbo
Stock turbo its a daily driver now

I've done this once or twice before...
Reply With Quote
  #4 (permalink)  
Old 17 Mar 2011, 10:49 pm
Fresh Cruiser
 
Join Date: Mar 2011
Posts: 1
Question Re: HELP!!! Car cuts out at 2500 RPMS!!!!

I have the same problem. My PT is a 2006 GT convertible. My car started it about 50,000 miles. I replaced the cam position sensor and it lasted about 11 months. I then replaced the sensor again (lifetime warranty @ Oreillys), spark plugs and wires. This time it lasted about 90 days. Is there anyone else with this issue or had this issue? If so, what did you do to correct it?
Thanks, Tom
Reply With Quote
  #5 (permalink)  
Old 17 Mar 2011, 11:22 pm
Cool Cruiser
 
Join Date: Dec 2005
Location: stockton, ca., USA.
Posts: 242
Default Re: HELP!!! Car cuts out at 2500 RPMS!!!!

I have a 03 gt. I had the same problem,went to the dealer ship and replaced the cam sensor. Problem solved. Get a cam sensor from the dealer. After market sensors don't last long.
Reply With Quote
  #6 (permalink)  
Old 18 Mar 2011, 03:23 am
Kawizx9r's Avatar
Senior Cruiser
 
Join Date: Aug 2010
Location: Salinas, CA
Posts: 1,575
Default Re: HELP!!! Car cuts out at 2500 RPMS!!!!

Quote:
Originally Posted by chromer don View Post
I have a 03 gt. I had the same problem,went to the dealer ship and replaced the cam sensor. Problem solved. Get a cam sensor from the dealer. After market sensors don't last long.
Quoted for truth.

Aftermarket sensors just don't play nicely with our cars
__________________
Quote:
Originally Posted by Chromenut View Post
Kawi is a friggin genius!
Reply With Quote
  #7 (permalink)  
Old 18 Mar 2011, 08:10 am
Obsessed Cruiser
 
Join Date: Nov 2007
Location: Mooresville, NC
Posts: 5,324
Default Re: HELP!!! Car cuts out at 2500 RPMS!!!!

Quote:
Originally Posted by Kawizx9r View Post
Quoted for truth.

Aftermarket sensors just don't play nicely with our cars
WHAT HE SAID! Do NOT use aftermarket sensors!
Reply With Quote
  #8 (permalink)  
Old 18 Mar 2011, 08:56 am
Obsessed Cruiser
 
Join Date: Sep 2001
Posts: 27,744
Default Re: HELP!!! Car cuts out at 2500 RPMS!!!!

Quote:
Originally Posted by Chromenut View Post
WHAT HE SAID! Do NOT use aftermarket sensors!

Wish I had a dime for every time we told someone that.
__________________
Rules of the forum have been updated as of *07/07/2019* Please read them over.

- All decisions by the Moderator are semi-permanent, can and may be changed at his discretion but definitely will be the final word. Any action performed by the Administrator or Moderators are not to be discussed on the forum.
Reply With Quote
  #9 (permalink)  
Old 18 Mar 2011, 10:41 am
Senior Cruiser
 
Join Date: Jan 2003
Location: Huntington Beach, CA, USA.
Posts: 1,799
Default Re: HELP!!! Car cuts out at 2500 RPMS!!!!

Wow, hate to be the voice of dissent here but I have had a cam sensor and crank sensor in mine from Auto Zone for about 40K miles and have had no issues... and they were half the price the stealership wanted. Seeing as how my OEM sensors only went about 50K miles I would say that so far they have stacked up pretty well. Chrysler does not build cam sensors or any other, they have other companies supply them and most also market the same sensor under other names. They would be foolish not to.
__________________
'03 Inferno Red GT, 5 speed, STAGE 1, Mopar BOV, Plastic Intake, Modified Upper and Lower Airbox, Custom Airbox-to-turbo pipe, Borla dual exhaust, Maddog Short Shifter, Drilled/Slotter Rotors, Ceramic Pads, chrome wheels, chrome door spears, AMP chrome fuel door, PT Cruiser 3rd light diffuser, H&R Springs, Rear Sway Bar added, MGW chrome door lock pulls, Blane's hood struts, Custom license plate mount, some interior dress up stuff...more to come
Reply With Quote
  #10 (permalink)  
Old 18 Mar 2011, 12:47 pm
Obsessed Cruiser
 
Join Date: Sep 2001
Posts: 27,744
Default Re: HELP!!! Car cuts out at 2500 RPMS!!!!

Consider yourself lucky. Your the exception to the rule.
__________________
Rules of the forum have been updated as of *07/07/2019* Please read them over.

- All decisions by the Moderator are semi-permanent, can and may be changed at his discretion but definitely will be the final word. Any action performed by the Administrator or Moderators are not to be discussed on the forum.
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
radio/cd player cuts out gonzomania Sound and Security Forum 35 29 Aug 2013 11:42 pm
Help Rough Low Idle almost cuts off.. lockupman1 General PT Cruiser Discussions 14 05 Jan 2011 01:28 pm
Engine cuts in and out at 2200 RPM tomrinsb Tech & Performance Forum 21 13 Oct 2008 04:50 pm
GT PT will not go over 2500 RPM jerrys Turbo Performance 6 20 Aug 2008 09:35 am
Stumble at 4k rpms in neutral 05CruisergtHO General Turbo Discussions 1 24 Apr 2008 03:26 pm


All times are GMT -5. The time now is 06:24 pm.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors