PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > 2.4L Turbo Forums > General Turbo Discussions

PT Cruiser Forum

Advertisements
SYNTHETIC OIL

 
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 24 Sep 2003, 01:27 pm
AJ AJ is offline
Fresh Cruiser
 
Join Date: May 2003
Location: WANTAGH, NY, USA.
Posts: 17
Send a message via AIM to AJ
Default SYNTHETIC OIL

WANT TO SWITCH to synthetic

any suggestions as to type and from where?
Reply With Quote
  #2 (permalink)  
Old 24 Sep 2003, 01:34 pm
Cool Cruiser
 
Join Date: Mar 2003
Location: .
Posts: 270
Default

I switched to Mobil-1 5W30 synthetic at 5730 miles. I get it at WalMart in 5 Quart jugs for $18.88 + tax.

If you don't have a WalMart in your area (yea, right) I have found 6 Quart boxes (6 single quarts vs. 1 5 quart jug) for <$24 at BJs warehouse.

I use the K&N HP-2009 oil filter.

This is for the 2.4L turbo motor.
__________________
2003 PT Turbo Deep Cranberry \'R\' Package Stock + AutoStick
Came off assembly line 1/14/03 (Tuesday) between 2200 and 2300.
Reply With Quote
  #3 (permalink)  
Old 24 Sep 2003, 07:07 pm
Cool Cruiser
 
Join Date: Jul 2003
Location: Toronto, Ontario, Canada.
Posts: 225
Default

Costco - Castrol Syntec 5W50, $29.99Cdn for 6 litres.
__________________
Marc
2003 PT Cruiser GT Turbo, Silver
1985 Dodge Omni GLH Turbo 16V, Black
http://connect.to/YBT
Reply With Quote
  #4 (permalink)  
Old 24 Sep 2003, 07:11 pm
Fresh Cruiser
 
Join Date: Mar 2003
Location: Knoxville, TN, USA.
Posts: 44
Default

I switched to Mobil 1 fully synthetic 5W-30 < http://www.mobil1.com/products/trisynth/oil_5w30.jsp > at 2550 miles, with a Mobil 1 M1-209 filter. Bought both at AutoZone, and don't remember what the oil cost, but the filter alone was ~$10.

I then changed to 10W-30 (still Mobil 1 fully synthetic, and Mobil 1 M1-209 filter) at 8840 miles for summer driving.

In the '91 Eagle Talon Turbo AWD I used to have, I ran Mobil 1 no problems, and only changed my oil and filter every 9-10k miles or so. I plan on doing the same with my '03 GT.


__________________
JC Moore, \'03 Cranberry GT, a.k.a. \"Zippy\"
http://www.mooresmopars.com/GT-Cruiser/index-gt.html
Stage1, BTG Strut Bar, Sun Hyperground system, Prototype Power CAI, no silencers, Eibach ProKit, Borla 2.5\" SSTL single w/dual tip, APC 2G Carbon Fiber Taillights, Chrome Fuel door, \'02 foldaway heated mirrors, OEM-style rear spoiler, Progress 22mm rear sway bar, TYC backup lights, Magnecor 8.5mm, stock plugs, MB Design \"Shifter\" 17x7.5 wheels, Goodyear Eagle F1 GS-D3 235/45/ZR17 tires
Reply With Quote
  #5 (permalink)  
Old 24 Sep 2003, 08:05 pm
Fanatic Cruiser
 
Join Date: Apr 2003
Location: San Diego, Ca, USA.
Posts: 630
Send a message via AIM to macster
Default

im4gzs


hmmm

The guy at AZone told me that the Mobile filter no was **3600. I wrote the number down but it's at home. But I do remember going over and opening up the box and giving it a visual and it "looked" like the right one. Can you confirm the pn?


TIA

macster


__________________
Don\'t help me
Help the bear

Patriot Blue PTGT, Stage1, K&N Typhoon, 2.5\" Cat back exhaust, Sun Hyperground, Sun HOT INZAMA Hyper Voltage system, Adams Uppipe
Reply With Quote
  #6 (permalink)  
Old 24 Sep 2003, 11:17 pm
Cool Cruiser
 
Join Date: Jan 2003
Location: .
Posts: 344
Default



Mobil-1 High Efficiency Oil Filter M1-209 from Auto Zone, and a 5 qt. jug Mobil-1 10W30 from Wal-Mart for $18.88 is the right stuff for the 2.4L Turbo.
__________________
\'03 PT Turbo 2CN
Auto/Stick
Lt. Almond/cloth
Blanes HoodStruts
etc.
Reply With Quote
  #7 (permalink)  
Old 24 Sep 2003, 11:57 pm
Young Cruiser
 
Join Date: May 2003
Location: Boston, MA, USA.
Posts: 86
Default

I had an issue two oil changes ago with the Mobil filter. For some reason, it didn't stay on as tight as it should have, and as a result, was leaking. I did some research and found NO where does Mobil suggest using the M1-209 with the PT Cruiser. (I'm not sure if it recommends the filter for the SRT?) So, I went with the K&N HP2900, which is designed for the PT. I haven't had any problems with it. (Same price roughly as the Mobil filter.)
Reply With Quote
  #8 (permalink)  
Old 25 Sep 2003, 12:24 am
AJ AJ is offline
Fresh Cruiser
 
Join Date: May 2003
Location: WANTAGH, NY, USA.
Posts: 17
Send a message via AIM to AJ
Default

ok, so which is it 5W30 or 10W30?

Bear in mind New york winter coming.

Is it 5 for winter, 10 for summer?
Reply With Quote
  #9 (permalink)  
Old 25 Sep 2003, 12:36 am
Cool Cruiser
 
Join Date: Mar 2003
Location: Pittsburgh, PA.
Posts: 320
Default

onedivinehammer,

The Mobil-1 M1-209 filter is correct for the PT Turbo. This was confirmed by the AutoZone computer cross-reference. I have used the M1-209 filter with NO problems on my PT Turbo for the past 3 oil changes.

My 2 cents,

Scott
__________________
\"If you choose not to decide, you still have made a choice.\"
Reply With Quote
  #10 (permalink)  
Old 25 Sep 2003, 09:52 am
Cool Cruiser
 
Join Date: Mar 2003
Location: .
Posts: 270
Default

AJ,

5W30 for temps. <100 degrees F
10W30 for temps. >100 degrees F

So yes, 5 for Winter, 10 for Summer, if it gets above 100 degrees.
__________________
2003 PT Turbo Deep Cranberry \'R\' Package Stock + AutoStick
Came off assembly line 1/14/03 (Tuesday) between 2200 and 2300.
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Wal-Mart Synthetic Blend Oil Change? amazingarthur General Turbo Discussions 21 13 Mar 2010 05:12 pm
Synthetic oil deederz Tech & Performance Forum 24 05 Feb 2005 03:46 am
Synthetic oil turbomangt General Turbo Discussions 21 11 Nov 2004 05:39 pm
Synthetic Oil ? BS or true Jimbo Tech & Performance Forum 16 25 Mar 2004 06:08 am
Swiching from Synthetic oil to normal OK? iggman Tech & Performance Forum 6 16 Oct 2002 04:40 pm


All times are GMT -5. The time now is 08:39 pm.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors