PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > 2.4L Turbo Forums > General Turbo Discussions

PT Cruiser Forum

Advertisements
CK engine light after moderate acceleration

 
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 17 Oct 2009, 10:57 am
Fresh Cruiser
 
Join Date: Oct 2009
Location: Orlando, FL
Posts: 4
Default CK engine light after moderate acceleration

2003 PT Cruiser GT (turbo): The engine runs great but the check engine light comes on about a minute after I accelerate from 40-70 mph or from 50-75 mph, either going on an on-ramp or while passing. Lots of acceleration, but then the light comes on about a minute later (maybe less). I can clear the light by disconnecting the negative battery terminal, but the next time I punch the throttle on the highway, the light comes on again. The engine temp gauge usually reads just below 50%. Any ideas?
Reply With Quote
  #2 (permalink)  
Old 17 Oct 2009, 11:43 am
Fresh Cruiser
 
Join Date: Oct 2009
Location: Orlando, FL
Posts: 4
Default Re: CK engine light after moderate acceleration

Just got back from Advance Discount Auto. The error code is P0551 "Power Steering Pressure Sensor". Any ideas why?
Reply With Quote
  #3 (permalink)  
Old 17 Oct 2009, 03:33 pm
Obsessed Cruiser
 
Join Date: Sep 2001
Posts: 27,744
Default Re: CK engine light after moderate acceleration

Can't tell you why, actually it sounds odd, but if you decide to swap it out this might help.

__________________
Rules of the forum have been updated as of *07/07/2019* Please read them over.

- All decisions by the Moderator are semi-permanent, can and may be changed at his discretion but definitely will be the final word. Any action performed by the Administrator or Moderators are not to be discussed on the forum.
Reply With Quote
  #4 (permalink)  
Old 18 Oct 2009, 08:22 pm
quicksilverdon's Avatar
Obsessed Cruiser
 
Join Date: Nov 2003
Location: Felton, Delaware
Posts: 20,501
Default Re: CK engine light after moderate acceleration

Check the Power Steering fluid level.
It takes ATF + 4.
__________________
"Anti-intellectualism has been a constant thread winding its way through our political and cultural life,
nurtured by the false notion that democracy means that 'my ignorance is just as good as your knowledge."
Isaac Asimov"

'05 Limited Turbo Lite, (Silver, of course)4-wheel ABS, Sunroof, Spoiler. Mods: E&G Classic grill, K&N FIPK, BTG duals, rear lowered 1.5", LED washer lights, $20 catch can, Aoogah horn, Weatherflectors, Sunroof Deflector, Fuzzy Dice, rear logo flames, rear pinstripe graphic, Gen3 Taillights, rear sway bar, hood struts, Strut bar.
Traded in '02 Silver Touring Edition w/87,000 miles
Reply With Quote
  #5 (permalink)  
Old 19 Oct 2009, 09:14 am
Fresh Cruiser
 
Join Date: Oct 2009
Location: Orlando, FL
Posts: 4
Default Re: CK engine light after moderate acceleration

Thanks to both of you for your responses. When I bought the vehicle, the power steering fluid was low, so I topped it off with Prestone power steering fluid with stop leak. I'll try draining that out and replacing with ATF +4 before replacing the pressure sensor switch.
Reply With Quote
  #6 (permalink)  
Old 27 Jul 2010, 02:50 pm
Fresh Cruiser
 
Join Date: Jul 2008
Posts: 47
Default Re: CK engine light after moderate acceleration

did you ever find the real cause to this code? I just got the same code on my 05GTHO? Was it just low on PS Fluid? any info would be great!
Reply With Quote
Reply

Tags
acceleration, ck engine light


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Engine Revs in Pulses with Full Acceleration - PT Cruiser ralpharino567 Tech & Performance Forum 5 23 Sep 2009 08:05 pm
Engine Light ON AkiraCruiser Tech & Performance Forum 9 09 Apr 2009 09:54 pm
Car Sometimes won't start (oil pressure light & Engine Light) gerardio Tech & Performance Forum 6 18 Jul 2008 08:22 am
Parking Brake Light upon Acceleration JohnM Tech & Performance Forum 5 27 Jan 2006 09:07 am
Warning light at acceleration PT-ERA Tech & Performance Forum 8 22 Nov 2005 05:54 pm


All times are GMT -5. The time now is 07:32 am.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors