PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > 2.4L Turbo Forums > General Turbo Discussions

PT Cruiser Forum

Advertisements
Idle vibration...

 
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 05 Nov 2009, 07:30 am
Cool Cruiser
 
Join Date: Jan 2009
Location: Augusta, GA
Posts: 234
Default Idle vibration...

I've asked before and headed the advice: I've checked all the hoses, changed the plugs and wires, even zipped all the hoses with no change in the idle vibration. It's enough to be annoying and can see the back of the hood bounce (I installed a rubber grommet to hold it more secure, just 'cause).

The motor mount looks good, other than that...

Any other suggestions???
__________________
2005 Limited Turbo-Lite, auto in Cool Vanilla
Reply With Quote
  #2 (permalink)  
Old 05 Nov 2009, 06:03 pm
quicksilverdon's Avatar
Obsessed Cruiser
 
Join Date: Nov 2003
Location: Felton, Delaware
Posts: 20,501
Default Re: Idle vibration...

Clean the idle air controller - right behindthe throttle body - do a search on IAC.
__________________
"Anti-intellectualism has been a constant thread winding its way through our political and cultural life,
nurtured by the false notion that democracy means that 'my ignorance is just as good as your knowledge."
Isaac Asimov"

'05 Limited Turbo Lite, (Silver, of course)4-wheel ABS, Sunroof, Spoiler. Mods: E&G Classic grill, K&N FIPK, BTG duals, rear lowered 1.5", LED washer lights, $20 catch can, Aoogah horn, Weatherflectors, Sunroof Deflector, Fuzzy Dice, rear logo flames, rear pinstripe graphic, Gen3 Taillights, rear sway bar, hood struts, Strut bar.
Traded in '02 Silver Touring Edition w/87,000 miles
Reply With Quote
  #3 (permalink)  
Old 05 Nov 2009, 10:32 pm
soonercruiser's Avatar
Obsessed Cruiser
 
Join Date: Jun 2007
Location: Oklahoma City
Posts: 7,896
Cool Re: Idle vibration...

When's the last time you changed plugs & wires?
(Lack of information makes our guesses bad)
__________________
Frank, aka SOONERCRUISER,

2011 GWE Dodge Challenger SRT8 as Show Car
2003 PT Cruiser GT Panel Van Conversion as new day driver.

Have now owned 6 PT Cruisers = Me PT Crazy!
Reply With Quote
  #4 (permalink)  
Old 06 Nov 2009, 11:24 am
Hooligan's Avatar
Obsessed Cruiser
 
Join Date: Aug 2003
Posts: 6,023
Default Re: Idle vibration...

Quote:
Originally Posted by soonercruiser View Post
When's the last time you changed plugs & wires?
(Lack of information makes our guesses bad)
He said he just replaced them, but I wonder if they were gapped @ .040?
__________________

2008 Silver Steel Metallic, Touring, NA, Sirius; Chromed door handles; lower grille; fog light surrounds; chrome front & rear bumpers strips; Airaid air filter; Bassani duals; Modesty Cover; Autolite AP5263 Platinum Plugs (.040); Crane Plug Wires; NAPA Ceramic pads; Blane hood struts; PTeazer Gas, Brake & Foot Rest Pedals, '05 Rear Step Pad, Stainless Door Sills, Llumar tint, "A" Piller chrome; APC Strut Bar
Reply With Quote
  #5 (permalink)  
Old 06 Nov 2009, 11:27 am
Cool Cruiser
 
Join Date: Jan 2009
Location: Augusta, GA
Posts: 234
Default Re: Idle vibration...

Plugs and wires within 3-months, pulled them and re-gaped to .035 a week ago. Yes, I've cleaned out the throttle body, intake and the manifold when I re-gaped - wasn't that bad. Air filter is good.

It seems to run fine, just the idle is rough.
__________________
2005 Limited Turbo-Lite, auto in Cool Vanilla
Reply With Quote
  #6 (permalink)  
Old 17 Nov 2009, 04:51 pm
Senior Cruiser
 
Join Date: Jan 2003
Location: Huntington Beach, CA, USA.
Posts: 1,799
Default Re: Idle vibration...

you might take a look at your torque struts. I found both of mine broken and when I replaced them it stopped.
__________________
'03 Inferno Red GT, 5 speed, STAGE 1, Mopar BOV, Plastic Intake, Modified Upper and Lower Airbox, Custom Airbox-to-turbo pipe, Borla dual exhaust, Maddog Short Shifter, Drilled/Slotter Rotors, Ceramic Pads, chrome wheels, chrome door spears, AMP chrome fuel door, PT Cruiser 3rd light diffuser, H&R Springs, Rear Sway Bar added, MGW chrome door lock pulls, Blane's hood struts, Custom license plate mount, some interior dress up stuff...more to come
Reply With Quote
  #7 (permalink)  
Old 17 Nov 2009, 06:40 pm
quicksilverdon's Avatar
Obsessed Cruiser
 
Join Date: Nov 2003
Location: Felton, Delaware
Posts: 20,501
Default Re: Idle vibration...

And, there's more than 1 mortor mount, isn't there? He said he checked "motor mount".
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Idle vibration garner49 General Turbo Discussions 14 07 Apr 2013 09:48 pm
ruff idle at idle only? KRNFIRE General PT Cruiser Discussions 16 23 Jan 2009 09:08 pm
vibration ? 2004PTCruiser Tech & Performance Forum 16 05 Jul 2008 09:40 am
Vibration between 40 & 60 mph???? anyone had this? gtbright General Turbo Discussions 10 16 Jul 2005 03:06 pm
Vibration!!!! 2003ptcrusierbrusier Tech & Performance Forum 8 05 Jan 2004 08:45 pm


All times are GMT -5. The time now is 02:04 am.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors