PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > 2.4L Turbo Forums > General Turbo Discussions

PT Cruiser Forum

Advertisements
Camshaft pos.sensor replaced ....and???

 
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 11 Jan 2010, 10:53 am
Banned
 
Join Date: Oct 2005
Location: KINGSTON, PA.
Posts: 30
Send a message via AIM to mtnbktrek
Default Camshaft pos.sensor replaced ....and???

Ive got an03 gt w65 k miles it threw a cam pos sen code and went into limp mode so I replaced the sensor then the car started and a mile down the rd the code andimp mode came on. Is there 2 pcs with the cam or one? I only got the cover with the o ring . Is it supposed to have the part that bolts to the cam?
Reply With Quote
  #2 (permalink)  
Old 11 Jan 2010, 09:10 pm
quicksilverdon's Avatar
Obsessed Cruiser
 
Join Date: Nov 2003
Location: Felton, Delaware
Posts: 20,501
Default Re: Camshaft pos.sensor replaced ....and???

There have been bad replacement sensors. Did you get it from dealer? They seem better...
Also check the wires/connectors.
__________________
"Anti-intellectualism has been a constant thread winding its way through our political and cultural life,
nurtured by the false notion that democracy means that 'my ignorance is just as good as your knowledge."
Isaac Asimov"

'05 Limited Turbo Lite, (Silver, of course)4-wheel ABS, Sunroof, Spoiler. Mods: E&G Classic grill, K&N FIPK, BTG duals, rear lowered 1.5", LED washer lights, $20 catch can, Aoogah horn, Weatherflectors, Sunroof Deflector, Fuzzy Dice, rear logo flames, rear pinstripe graphic, Gen3 Taillights, rear sway bar, hood struts, Strut bar.
Traded in '02 Silver Touring Edition w/87,000 miles
Reply With Quote
  #3 (permalink)  
Old 21 Jan 2010, 12:34 pm
Fresh Cruiser
 
Join Date: Jan 2010
Location: San Antonio TX
Posts: 3
Default Re: Camshaft pos.sensor replaced ....and???

Hello to all. I am new to this site but am having major issues with my 2005 pt cruiser's camshaft position sensor. Let me begin. Last january I was driving down the road and the check engine light came on and car got all jerky on me. Took it to Adv. Auto parts. They did Diagnostic on it and said camshaft position sensor was bad. Took it to shop and had it replaced(under warranty). 7 months later same thing happened, camshaft position sensor bad again. Took it to repair shop and they said it could be the computer. They replaced sensor and reflashed computer(partially under warranty). Now its 6 months later and the same thing has happened again. Now I have no warranty and shop wants to charge me to replace sensor plus 100.00 to do diagnostic fee for something they have already replaced twice. I am going to purchase sensor and replace myself, but why would this thing keep faulting on me? Is there a way to check wiring? Also shop said some of my sensors were not getting proper voltage. Huh? Please any advise would be much appreciated. Thanks, Scott
Reply With Quote
  #4 (permalink)  
Old 21 Jan 2010, 01:50 pm
Hooligan's Avatar
Obsessed Cruiser
 
Join Date: Aug 2003
Posts: 6,023
Default Re: Camshaft pos.sensor replaced ....and???

If you look at the posting after yours you will see that QSD mentioned you can get a bad sensor. When it was replaced under warranty was this at a dealer, (not clear on this), anyway there should be a year warranty on this part. Good Luck!!!
__________________

2008 Silver Steel Metallic, Touring, NA, Sirius; Chromed door handles; lower grille; fog light surrounds; chrome front & rear bumpers strips; Airaid air filter; Bassani duals; Modesty Cover; Autolite AP5263 Platinum Plugs (.040); Crane Plug Wires; NAPA Ceramic pads; Blane hood struts; PTeazer Gas, Brake & Foot Rest Pedals, '05 Rear Step Pad, Stainless Door Sills, Llumar tint, "A" Piller chrome; APC Strut Bar
Reply With Quote
  #5 (permalink)  
Old 21 Jan 2010, 02:43 pm
Fresh Cruiser
 
Join Date: Jan 2010
Location: San Antonio TX
Posts: 3
Default Re: Camshaft pos.sensor replaced ....and???

Sensor was not replaced at dealer. Done at carx. Only had 12000 mile/12mo. Warranty. Since I use car for work I am 1200 miles over warranty. I just don't see why sensor poops out 3 times in one year.
Reply With Quote
  #6 (permalink)  
Old 21 Jan 2010, 03:17 pm
Obsessed Cruiser
 
Join Date: Sep 2001
Posts: 27,744
Default Re: Camshaft pos.sensor replaced ....and???

mtnbktrek,

This is for you:

Chrysler PT Cruiser cam sensor replacement: standard and turbo

sdmguinness,

As QSD noted, we've had numerous owners come back to the forum after buying aftermarket parts (especially sensors) where the part didn't work right. When they went with a Chrysler/Mopar part (more expensive) the problem was fixed.
__________________
Rules of the forum have been updated as of *07/07/2019* Please read them over.

- All decisions by the Moderator are semi-permanent, can and may be changed at his discretion but definitely will be the final word. Any action performed by the Administrator or Moderators are not to be discussed on the forum.
Reply With Quote
  #7 (permalink)  
Old 21 Jan 2010, 07:56 pm
Fresh Cruiser
 
Join Date: Jan 2010
Location: San Antonio TX
Posts: 3
Default Re: Camshaft pos.sensor replaced ....and???

I don't think that replacements were factory parts. I called dealer and will pick up another sensor on Sat. Thank you for the link of how to change sensor. I am going to tackle it this weekend. Wires seemed ok. The plastic housing covering wires seemed brittle and missing in places, but wires seemed to look fine. Thanks guys. Scott
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
camshaft position sensor (CMP) hobbyman Tech & Performance Forum 62 01 Aug 2015 12:43 pm
Camshaft sensor (again!) ABrown Tech & Performance Forum 21 29 Mar 2012 03:31 pm
Camshaft Position Sensor ejschultz Tech & Performance Forum 6 22 Sep 2010 09:58 pm
Replaced Camshaft sensor and car still wont start john1561 Tech & Performance Forum 3 29 Jun 2008 06:49 pm
Camshaft Sensor ABrown General PT Cruiser Discussions 2 18 Jun 2008 07:36 am


All times are GMT -5. The time now is 04:35 pm.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors