PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > 2.4L Turbo Forums > General Turbo Discussions

PT Cruiser Forum

Advertisements
'06 HO runs a bit rough at idle

 
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 19 Mar 2010, 02:34 pm
Regular Cruiser
 
Join Date: Jul 2009
Posts: 109
Wink '06 HO runs a bit rough at idle

Our 24k original mile '06 PT GT HO Turbo still runs a bit rough and even surges faintly at idle in gear (automatic) after replacing the plugs and wires with performance stuff.
we were using Sunoco 93 octane fuel, switched to Chevron 93 octane and that helpped quite a bit-(all our fuel here is 10% ethenol) and it ran fine before the switch to 10% ethenol.
I believe I read somewhere that some folks have turned up the idle about 50 rpm to help smooth this out......is this OK to do? and if so how do I do it?
Any other suggestions??? Thanks!
Reply With Quote
  #2 (permalink)  
Old 21 Mar 2010, 11:28 am
Regular Cruiser
 
Join Date: Jul 2009
Posts: 109
Wink Re: '06 HO runs a bit rough at idle

May be I should clairify: At 11k miles the engine began to run a bit rough at idle in gear, I had read about this and what to do, so I bought a set of aftermarket oem style replacement wires and new plugs, installed them and all was fine until 22k mile mark, same situation, so I bought the MSD wires, and more new (Autolite) plugs, installed them and all was better but not as good as before-(mind you we are now running gasoline with 10% ethinol so I think this has something to do with it-no way around the gas thats available-execpt on the other end of our town there is a station still selling ethinol-free gas-so I might try it.
So aside from that does anyone know to turn up the idle just a tad on an '06 GT HO Turbo engine? I'd like to try that.....it can't hurt, and I can always go back if I need to. Thanks!
Reply With Quote
  #3 (permalink)  
Old 23 Mar 2010, 10:30 am
quicksilverdon's Avatar
Obsessed Cruiser
 
Join Date: Nov 2003
Location: Felton, Delaware
Posts: 20,501
Default Re: '06 HO runs a bit rough at idle

Do you have Air or defrost on? when compressor kicks it, it alters idle.
I know of no way to alter idle speed.
__________________
"Anti-intellectualism has been a constant thread winding its way through our political and cultural life,
nurtured by the false notion that democracy means that 'my ignorance is just as good as your knowledge."
Isaac Asimov"

'05 Limited Turbo Lite, (Silver, of course)4-wheel ABS, Sunroof, Spoiler. Mods: E&G Classic grill, K&N FIPK, BTG duals, rear lowered 1.5", LED washer lights, $20 catch can, Aoogah horn, Weatherflectors, Sunroof Deflector, Fuzzy Dice, rear logo flames, rear pinstripe graphic, Gen3 Taillights, rear sway bar, hood struts, Strut bar.
Traded in '02 Silver Touring Edition w/87,000 miles
Reply With Quote
  #4 (permalink)  
Old 23 Mar 2010, 10:38 am
Dino's Avatar
Senior Cruiser
 
Join Date: Feb 2010
Location: NY
Posts: 1,839
Default Re: '06 HO runs a bit rough at idle

Were the autolite plugs the platinum plugs? They have issues with turbo's. I heard Chevron was one of the last to switch over.
Reply With Quote
  #5 (permalink)  
Old 23 Mar 2010, 11:20 am
Senior Cruiser
 
Join Date: Jan 2003
Location: Huntington Beach, CA, USA.
Posts: 1,799
Default Re: '06 HO runs a bit rough at idle

You really can't adjust the idle unless you have a tuner system. I would check your vacuum for small leaks or some other cause. Have you checked for codes?
__________________
'03 Inferno Red GT, 5 speed, STAGE 1, Mopar BOV, Plastic Intake, Modified Upper and Lower Airbox, Custom Airbox-to-turbo pipe, Borla dual exhaust, Maddog Short Shifter, Drilled/Slotter Rotors, Ceramic Pads, chrome wheels, chrome door spears, AMP chrome fuel door, PT Cruiser 3rd light diffuser, H&R Springs, Rear Sway Bar added, MGW chrome door lock pulls, Blane's hood struts, Custom license plate mount, some interior dress up stuff...more to come
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Rough Idle badkarma76 Tech & Performance Forum 30 21 Jul 2009 07:47 pm
Rough idle 03 GT elmeyer Tech & Performance Forum 2 03 Jul 2009 09:44 pm
Rough Idle, Rough @60, check engine light NEW Dystroy Tech & Performance Forum 8 12 Jan 2009 09:07 pm
Rough Idle BlueBlurCruiser General PT Cruiser Discussions 15 07 May 2004 09:50 am
Rough idle PTPaul Tech & Performance Forum 1 17 Oct 2001 05:34 pm


All times are GMT -5. The time now is 07:52 am.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors