PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > 2.4L Turbo Forums > General Turbo Discussions

PT Cruiser Forum

Advertisements
found my boost problem

 
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 27 May 2010, 02:39 pm
Regular Cruiser
 
Join Date: Dec 2008
Location: Ajax ontario canada
Posts: 105
Default found my boost problem

a wile back i posted about only geting 3psi of boost after 2years of swoping parts changing the turbo i took the cat off and took it for a rip hit 12psi wow i have had the car for 2 years at allways had been at 3psi 12 was awsome lol now to change the clutch lol and wile im in there gona do the timing belt and water pump.



__________________
http://www.ptcruiserlinks.com/forum/image.php?type=sigpic&userid=10114&dateline=124268  4992
Reply With Quote
  #2 (permalink)  
Old 27 May 2010, 02:59 pm
Veteran Cruiser
 
Join Date: Mar 2003
Location: Oregon.
Posts: 3,521
Default Re: found my boost problem

Must of had a plugged cat. Interesting because when the cat went bad on our '01 it threw a CEL. Glad you are running right again.
__________________
\'05 Stone White SRT4

\'04 Graphite PT Automatic
Reply With Quote
  #3 (permalink)  
Old 27 May 2010, 07:08 pm
Regular Cruiser
 
Join Date: Dec 2008
Location: Ajax ontario canada
Posts: 105
Default Re: found my boost problem

thanks ya just gota fix the clutch now got the car 18k ago it was sliping then at 3 psi man oh man was it ever sliping at 12 psi but i think there may still be a problem cuz i had the vac line off the wastgate and still only got 12psi i thought it would of overbosted. but i dunno
__________________
http://www.ptcruiserlinks.com/forum/image.php?type=sigpic&userid=10114&dateline=124268  4992
Reply With Quote
  #4 (permalink)  
Old 29 May 2010, 08:14 pm
Fresh Cruiser
 
Join Date: May 2010
Posts: 2
Default Re: found my boost problem

Quote:
Originally Posted by neon95 View Post
a wile back i posted about only geting 3psi of boost after 2years of swoping parts changing the turbo i took the cat off and took it for a rip hit 12psi wow i have had the car for 2 years at allways had been at 3psi 12 was awsome lol now to change the clutch lol and wile im in there gona do the timing belt and water pump.



My problem has been with the surge valve. It releases air as fast as I try to pressurize. I can't get up to 5 lbs. of pressure. (Yes, I have my switch on). Any other suggestions?
Reply With Quote
  #5 (permalink)  
Old 29 May 2010, 08:19 pm
Regular Cruiser
 
Join Date: Dec 2008
Location: Ajax ontario canada
Posts: 105
Default Re: found my boost problem

hard to say really i could not get to 5 for the longest time was stuck at 3 1/2 then took the hose off the wastgate got it to 6 then took the cat off the got to 12
__________________
http://www.ptcruiserlinks.com/forum/image.php?type=sigpic&userid=10114&dateline=124268  4992
Reply With Quote
  #6 (permalink)  
Old 08 Jul 2010, 08:05 pm
Fresh Cruiser
 
Join Date: Jul 2010
Posts: 13
Default Re: found my boost problem

What's a cat??
Reply With Quote
  #7 (permalink)  
Old 08 Jul 2010, 08:28 pm
Obsessed Cruiser
 
Join Date: Sep 2001
Posts: 27,744
Default Re: found my boost problem

Quote:
Originally Posted by dbcruiser View Post
What's a cat??
CATalytic Converter .......is a device used to reduce the toxicity of emissions from an internal combustion engine. First widely introduced on series-production automobiles in the U.S. market for the 1975 model year to comply with tightening EPA regulations on auto exhaust, catalytic converters are still most commonly used in motor vehicle exhaust systems.
__________________
Rules of the forum have been updated as of *07/07/2019* Please read them over.

- All decisions by the Moderator are semi-permanent, can and may be changed at his discretion but definitely will be the final word. Any action performed by the Administrator or Moderators are not to be discussed on the forum.

Last edited by CREWZIN; 08 Jul 2010 at 08:30 pm.
Reply With Quote
  #8 (permalink)  
Old 08 Jul 2010, 08:37 pm
Regular Cruiser
 
Join Date: Dec 2008
Location: Ajax ontario canada
Posts: 105
Default Re: found my boost problem

lol i forgot about this post (update) it was not the cat when i cut the cat off the wastgate plunger was in it so i ended up needing a new turbofold got a new turbofold and bam 18psi yes!!!! lol
__________________
http://www.ptcruiserlinks.com/forum/image.php?type=sigpic&userid=10114&dateline=124268  4992
Reply With Quote
  #9 (permalink)  
Old 09 Jul 2010, 08:17 pm
VNT's Avatar
VNT VNT is offline
Senior Cruiser
 
Join Date: Jun 2009
Location: NE
Posts: 1,468
Default Re: found my boost problem

Quote:
Originally Posted by neon95 View Post
lol i forgot about this post (update) it was not the cat when i cut the cat off the wastgate plunger was in it so i ended up needing a new turbofold got a new turbofold and bam 18psi yes!!!! lol
How much for the new Turbo? What do you think the other owner abused it??
__________________
VNT

86 TurboZ CS 2.2 T2 +20's A555
00 Durango SLT+ 5.9 4x4
02 Grand Cherokee 4.7 4x4
03 PT GT Black 5 sp Stg 1 sold
05 PT GT Silver 5 Spd Conv
06 PT GT Cool Vanilla 5 spd Conv
06 PT Base Marine Blue 40TE Conv
15 Grand Cherokee Overland 5.7 QD2
17 Challenger SRT A8 GoMango
18 JL Wrangler Sahara Punkn
20 JL Wrangler Rubicon Ocean Blue
Reply With Quote
  #10 (permalink)  
Old 09 Jul 2010, 11:21 pm
Regular Cruiser
 
Join Date: Dec 2008
Location: Ajax ontario canada
Posts: 105
Default Re: found my boost problem

hard to say really could of been from some 1 hard on it and didnt let it cool could of been crack and the plunger could of binded and broke hard to say tho. but i got a srt-4 turbofold low km with a bunch of other parts for $400can
__________________
http://www.ptcruiserlinks.com/forum/image.php?type=sigpic&userid=10114&dateline=124268  4992
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Look what I found.... countrywi Tech & Performance Forum 25 21 May 2016 01:26 pm
Found another potential dehcho General PT Cruiser Discussions 2 29 Dec 2009 08:30 pm
Help! found out the problem.... owensbigheart Tech & Performance Forum 3 06 Jul 2009 08:18 pm
Part Throttle boost with boost controller forcedinduction Turbo Performance 2 18 Feb 2006 01:48 pm
Found you out Mr. Replicar skripo Stage Turbo Kits 3 12 Aug 2005 05:54 pm


All times are GMT -5. The time now is 02:19 pm.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors