PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > 2.4L Turbo Forums > General Turbo Discussions

PT Cruiser Forum

Advertisements
oil light problem HELP

 
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 29 Jun 2010, 05:49 pm
Fresh Cruiser
 
Join Date: Feb 2010
Posts: 34
Default oil light problem HELP

Hi guys and gals, I drive on the highway about an hour and a half to work. When I get off the highway and come to the first stop light my oil light comes on for a second and I get a "ding". Then It go's off. It will do this at every stop light until i get to work. It WILL NOT do it while i'm driving. WILL NOT. I'm thinking oil pressure? Bad oil pump? I changed the Oil sensor as it was making the oil light stay on until i would restarted it. (i guess this is a common problem with the sensors). Any thoughts?
Reply With Quote
  #2 (permalink)  
Old 30 Jun 2010, 02:22 pm
Cool Cruiser
 
Join Date: Mar 2008
Location: Orlando Florida
Posts: 414
Send a message via Yahoo to partyd
Default Re: oil light problem HELP

How many quarts of oil you are using when doing oil change ?
__________________
2008 Pt cruiser Touring
2004 Pt Cruiser GT
2004 Chrysler 300M
2008 Chrysler Pacifica awd
Reply With Quote
  #3 (permalink)  
Old 30 Jun 2010, 03:07 pm
Senior Cruiser
 
Join Date: Jan 2003
Location: Huntington Beach, CA, USA.
Posts: 1,799
Default Re: oil light problem HELP

I assume you checked the oil level, yes?
__________________
'03 Inferno Red GT, 5 speed, STAGE 1, Mopar BOV, Plastic Intake, Modified Upper and Lower Airbox, Custom Airbox-to-turbo pipe, Borla dual exhaust, Maddog Short Shifter, Drilled/Slotter Rotors, Ceramic Pads, chrome wheels, chrome door spears, AMP chrome fuel door, PT Cruiser 3rd light diffuser, H&R Springs, Rear Sway Bar added, MGW chrome door lock pulls, Blane's hood struts, Custom license plate mount, some interior dress up stuff...more to come
Reply With Quote
  #4 (permalink)  
Old 30 Jun 2010, 05:42 pm
Fresh Cruiser
 
Join Date: Feb 2010
Posts: 34
Default Re: oil light problem HELP

I have done 2 oil changes while this problem has been happening. i have the proper amount of oil in the car. Should i try a thicker oil or is that just masking the problem. if it was an oil pump would i get these symptoms or would the light be on all the time? This is making me nuts.
Reply With Quote
  #5 (permalink)  
Old 30 Jun 2010, 07:09 pm
Hooligan's Avatar
Obsessed Cruiser
 
Join Date: Aug 2003
Posts: 6,023
Default Re: oil light problem HELP

What year? How many miles on it?
__________________

2008 Silver Steel Metallic, Touring, NA, Sirius; Chromed door handles; lower grille; fog light surrounds; chrome front & rear bumpers strips; Airaid air filter; Bassani duals; Modesty Cover; Autolite AP5263 Platinum Plugs (.040); Crane Plug Wires; NAPA Ceramic pads; Blane hood struts; PTeazer Gas, Brake & Foot Rest Pedals, '05 Rear Step Pad, Stainless Door Sills, Llumar tint, "A" Piller chrome; APC Strut Bar
Reply With Quote
  #6 (permalink)  
Old 30 Jun 2010, 10:37 pm
Cool Cruiser
 
Join Date: Mar 2008
Location: Orlando Florida
Posts: 414
Send a message via Yahoo to partyd
Default Re: oil light problem HELP

what is the the proper amount of oil ?
__________________
2008 Pt cruiser Touring
2004 Pt Cruiser GT
2004 Chrysler 300M
2008 Chrysler Pacifica awd
Reply With Quote
  #7 (permalink)  
Old 01 Jul 2010, 09:11 am
Fresh Cruiser
 
Join Date: Feb 2010
Posts: 34
Default Re: oil light problem HELP

about 5 qrts of oil. It's a 2003 with about 125000. 5_ speed. ias far as I know it dosent brn any oil ( no white smoke). Dosent really leak any oil. Just ths light. I just comes on after a highway drive of about an hour. Thanks
Reply With Quote
  #8 (permalink)  
Old 01 Jul 2010, 09:29 am
Cool Cruiser
 
Join Date: Mar 2008
Location: Orlando Florida
Posts: 414
Send a message via Yahoo to partyd
Default Re: oil light problem HELP

a lot of owners believe it only takes 4 qt that is why i ask, yes it needs 5
i own a 2001 limited 5 speed same problem it happends when i take a hard turn and when the engine is hot or been driving for 30 minutes or more,
so i get the light for a second and the litle warning noise

it looks like the oil pump is getting tired and old , and the oil pressure going down when the engine is hot
also when turning the oil moves to the side of the engine
when the engine is cold nothing like this happends

so i am using better oil and nothing bad happends to the engine is been like that for a year most likely it just needs a new oil pump
__________________
2008 Pt cruiser Touring
2004 Pt Cruiser GT
2004 Chrysler 300M
2008 Chrysler Pacifica awd

Last edited by partyd; 02 Jul 2010 at 09:15 am.
Reply With Quote
  #9 (permalink)  
Old 02 Jul 2010, 09:10 am
Fresh Cruiser
 
Join Date: Feb 2010
Posts: 34
Default Re: oil light problem HELP

that's what I was thinking. I'm gonna switch to a thicker oil for the summer. I will post back how it works out. Thanks
Reply With Quote
  #10 (permalink)  
Old 03 Jul 2010, 11:21 pm
Taggert_LOA's Avatar
Cool Cruiser
 
Join Date: Feb 2006
Location: Myrtle Beach SC
Posts: 422
Send a message via AIM to Taggert_LOA
Default Re: oil light problem HELP

your oil pressure sending unit is bad. replace. problem solved.
__________________
"Every civilization finds it necessary to negotiate comprimises with it's own Values"
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Instrument Cluster Light Problem skretz General PT Cruiser Discussions 21 28 Feb 2015 11:25 pm
Brake light switch problem??? Afitch628 General PT Cruiser Discussions 1 28 Apr 2010 08:34 am
Map light problem + new lights slayerdarkcross Interior Accessories Forum 5 11 Dec 2008 12:04 am
Dome Light Problem Johns Steel Blue General PT Cruiser Discussions 2 21 Aug 2007 07:51 am
Update on my engine light problem jsp70 General Turbo Discussions 1 11 Aug 2004 08:15 am


All times are GMT -5. The time now is 12:33 pm.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors