PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > 2.4L Turbo Forums > General Turbo Discussions

PT Cruiser Forum

Advertisements
F@#$%^ MAP Sensor!!!

 
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 11 Nov 2003, 02:26 pm
Cool Cruiser
 
Join Date: Sep 2003
Location: Farmington, MI, USA.
Posts: 330
Default F@#$%^ MAP Sensor!!!

SO, I went to do my first maintenance of my new (used) '03 PT GT today, I changed the oil and figured while I was at it I would change the plugs. Bad idea!!! While pulling out the one of the plugs, I bashed the MAP sensor and broke the sensor part of the connection. All the pins and stuff are busted.

I am so pissed.

Not to mention I had to use a hammer on my ratchet to get the oil drain plug out, and a strap wrench to get the oil filter off. Wouldn't want any of that oil leaking out, would we?

Thankfully, my dad works at the Tech Center, so he has found a new MAP sensor for me (I should have told him to get me one of the 3 BAR sensors, heh), and I'll get it this afternoon and put on the new one.

But dang, that's a silly place for that thing. It's just asking to be broken off. It sure is cramped under that hood.
Reply With Quote
  #2 (permalink)  
Old 11 Nov 2003, 02:44 pm
Cool Cruiser
 
Join Date: Jul 2003
Location: ON, Canada.
Posts: 467
Default

Bummer, you're right it's tight under there. I'll have to watch for that next time. Many have mentioned the tight oil drain and filter, that's why I took it in for the first change.
__________________
PianT

Reply With Quote
  #3 (permalink)  
Old 11 Nov 2003, 08:59 pm
Cool Cruiser
 
Join Date: Sep 2003
Location: Farmington, MI, USA.
Posts: 330
Default

Mine has definitely had an oil change before. Or at least I hope the hell it has, it's got 23,400 miles on it. So someone apparently thought that's how tight they are supposed to be.
__________________
\"If I had a diesel rig, with a big ol\' blade, courtesy would reign, arguments abate, cuz everyone would know, I\'d SQUASH \'EM LIKE A GRAAAAAPE!\" -- Heywood Banks, \"If I Had a Bulldozer\"
Reply With Quote
  #4 (permalink)  
Old 12 Nov 2003, 11:24 am
Cool Cruiser
 
Join Date: Mar 2003
Location: Robins, Georgia, USA.
Posts: 311
Send a message via AIM to PK Cruiser
Default

Mine was tight too when I Changed mine myself for the first time. & I took it to the dealership three times before I change mine (at 18,000 miles). Most Mechanics believe (aircraft too) that tighter is better....
__________________


\'03 Black Turbo, Autostick, Removed Intake Silencers, K&N Drop in Filter, MOPAR BOV, Eibach Springs, Kenwood CD/MP3 Player & amp, 12 inch Sub...soon to be a member of the Stage I club...
Reply With Quote
  #5 (permalink)  
Old 13 Nov 2003, 10:01 pm
Obsessed Cruiser
 
Join Date: Dec 2002
Posts: 6,787
Default

i hate when the filter is that tight!! no reason to be like that!!
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Check Engine Light came on - code 1188? coolvirus General Turbo Discussions 38 25 May 2011 09:01 am
Error Codes skylight Tech & Performance Forum 7 28 Apr 2011 03:34 pm
Error Codes thegoldpt Turbo Performance 6 07 Apr 2007 02:26 pm
Error Code List skylight General Turbo Discussions 6 07 Apr 2007 02:11 pm
Tranny She is a no-good! scottscars Stage Turbo Kits 15 16 Oct 2004 11:11 am


All times are GMT -5. The time now is 08:57 pm.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors