PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > 2.4L Turbo Forums > General Turbo Discussions

PT Cruiser Forum

Advertisements
no squirt

 
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 13 Oct 2010, 08:56 am
superpug666's Avatar
Regular Cruiser
 
Join Date: Aug 2008
Location: quebec
Posts: 163
Default no squirt

hi guys....im about to replace the windsheild washers squirters for the 3rd time in 3 or years....... anybody had to chnge them that much?

thanks!
__________________
I drive an hybrid, it burns both gas and rubber!!!!!

To hell with all religions!

Yes my baby is stock, for now!
Reply With Quote
  #2 (permalink)  
Old 13 Oct 2010, 12:52 pm
Regular Cruiser
 
Join Date: Jul 2010
Posts: 185
Default Re: no squirt

my driver side broke 2 times in 2 months...
Reply With Quote
  #3 (permalink)  
Old 13 Oct 2010, 02:04 pm
garyerrol's Avatar
Cool Cruiser
 
Join Date: Nov 2007
Location: Indianapolis, IN
Posts: 288
Default Re: no squirt

Are you replacing with OEM or cheap non-OEM ones? I brought my 2001 used three years ago and haven't had any problems so far, nor I ever had problems with them in any vehicle I've owned in the last 45 years. Do you have excessivly hard water in your area that could be plugging them up? I use nothing but premium washer fluid in my vehicles with no diluting with tap water.
__________________
2001 LE, Shale Green, Aftermarket Wheels, Shorty Antenna, AirRaid Cold Air Intake, Whelen Talons (amber/white) in front windshield, Whelen Talons (amber) in rear side windows, Tomar RECT25's (amber) and Whelen Slimlighter(amber) in back window. Kenwood TK-880H 45 Watt Mobile Radio, Antenex 3db antenna w/ NMO mount.

http://smg.photobucket.com/albums/v7...0PT%20Cruiser/

Ham: N9PTC
GMRS: WPQS324
Reply With Quote
  #4 (permalink)  
Old 13 Oct 2010, 09:08 pm
superpug666's Avatar
Regular Cruiser
 
Join Date: Aug 2008
Location: quebec
Posts: 163
Default Re: no squirt

Quote:
Originally Posted by garyerrol View Post
Are you replacing with OEM or cheap non-OEM ones? I brought my 2001 used three years ago and haven't had any problems so far, nor I ever had problems with them in any vehicle I've owned in the last 45 years. Do you have excessivly hard water in your area that could be plugging them up? I use nothing but premium washer fluid in my vehicles with no diluting with tap water.
ALWAYS the stuff from ma mopar....no diluting....i think my turbo generates too much heat....i changed both squirters twice, (and now the passenger side) and once all the tubing..... at 24.60$ cdn each squirters it getting expansive
__________________
I drive an hybrid, it burns both gas and rubber!!!!!

To hell with all religions!

Yes my baby is stock, for now!
Reply With Quote
  #5 (permalink)  
Old 14 Oct 2010, 04:47 pm
xwing777's Avatar
Senior Cruiser
 
Join Date: Jan 2009
Location: Taylorsville NC
Posts: 1,102
Default Re: no squirt

Washer hose breaking = TSB?

and be done with them for a long time
__________________
.
2004 Almond GT, autostick - Only car shows, some weekends but with Stage1!
2003 cranberry 5 speed GT - Fishing with a sleeper Stage3 setup!
Reply With Quote
  #6 (permalink)  
Old 14 Oct 2010, 06:59 pm
superpug666's Avatar
Regular Cruiser
 
Join Date: Aug 2008
Location: quebec
Posts: 163
Default Re: no squirt

Quote:
Originally Posted by xwing777 View Post
Washer hose breaking = TSB?

and be done with them for a long time
THANKS FREAKING MUXH°°
__________________
I drive an hybrid, it burns both gas and rubber!!!!!

To hell with all religions!

Yes my baby is stock, for now!
Reply With Quote
  #7 (permalink)  
Old 13 Aug 2011, 09:08 am
Fresh Cruiser
 
Join Date: Aug 2011
Posts: 1
Default Re: no squirt

Quote:
Originally Posted by superpug666 View Post
THANKS FREAKING MUXH°°
The clip ons look promising, are they still holding up for you? My 2006 GT was going through nozzles in about 3 months (I think it is the heat). So, I found aftermarket metal nozzles they are U-G-L-Y but have lasted for about a year so far. I used fuel line under the hood.
Reply With Quote
  #8 (permalink)  
Old 13 Aug 2011, 10:25 am
xwing777's Avatar
Senior Cruiser
 
Join Date: Jan 2009
Location: Taylorsville NC
Posts: 1,102
Default Re: no squirt

Both of our cars are still working fine. The only thing that has happened, sometimes when we flip the arms out for washing the car, the tubing gets tucked under the spring to tightly and the squirters wont work as it pinches the line to tightly.

Easy to fix but im gonna try to run the tubing through the spring like on my work van (chevy 3/4 ton) was done factory. Just looking at them it seems the springs are to tightly wound for it to fit but i won't know until i pull the arms off and try it.
__________________
.
2004 Almond GT, autostick - Only car shows, some weekends but with Stage1!
2003 cranberry 5 speed GT - Fishing with a sleeper Stage3 setup!
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Winshield washers wont squirt fluid crabbymaddy Tech & Performance Forum 4 24 Aug 2008 06:06 pm


All times are GMT -5. The time now is 09:02 pm.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors