PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > 2.4L Turbo Forums > General Turbo Discussions

PT Cruiser Forum

Advertisements
Weird engine drivetrain problem I need help with...

 
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 09 Jan 2011, 09:03 pm
Fresh Cruiser
 
Join Date: Apr 2009
Posts: 6
Default Weird engine drivetrain problem I need help with...

I have a odd problem with my wifes PT it's a turbo, non GT with automatic 2004 model

She drove it fine Friday then when we started to head out again it backed up just fine but trying to drive forward it was like it had square wheels or that we were trying to drive over 4x4's

we backed it fine up the block and back into our driveway,
I assumed the worse that it was tranny related.

So I go out there sat and try it again, it runs and drives fine besides a very slightly ratty idle.

I really need to have peace of mind that the PT with be reliable anyone have any clue what that issue could be?

Many thanks,
Cheers,
P.
Reply With Quote
  #2 (permalink)  
Old 10 Jan 2011, 09:20 pm
Senior Cruiser
 
Join Date: Jan 2003
Location: Huntington Beach, CA, USA.
Posts: 1,799
Default Re: Weird engine drivetrain problem I need help with...

Was the steeing wheel jerking back and forth?
__________________
'03 Inferno Red GT, 5 speed, STAGE 1, Mopar BOV, Plastic Intake, Modified Upper and Lower Airbox, Custom Airbox-to-turbo pipe, Borla dual exhaust, Maddog Short Shifter, Drilled/Slotter Rotors, Ceramic Pads, chrome wheels, chrome door spears, AMP chrome fuel door, PT Cruiser 3rd light diffuser, H&R Springs, Rear Sway Bar added, MGW chrome door lock pulls, Blane's hood struts, Custom license plate mount, some interior dress up stuff...more to come
Reply With Quote
  #3 (permalink)  
Old 11 Jan 2011, 08:27 am
quicksilverdon's Avatar
Obsessed Cruiser
 
Join Date: Nov 2003
Location: Felton, Delaware
Posts: 20,501
Default Re: Weird engine drivetrain problem I need help with...

How many miles? Were spark plugs and wires ever changed?
__________________
"Anti-intellectualism has been a constant thread winding its way through our political and cultural life,
nurtured by the false notion that democracy means that 'my ignorance is just as good as your knowledge."
Isaac Asimov"

'05 Limited Turbo Lite, (Silver, of course)4-wheel ABS, Sunroof, Spoiler. Mods: E&G Classic grill, K&N FIPK, BTG duals, rear lowered 1.5", LED washer lights, $20 catch can, Aoogah horn, Weatherflectors, Sunroof Deflector, Fuzzy Dice, rear logo flames, rear pinstripe graphic, Gen3 Taillights, rear sway bar, hood struts, Strut bar.
Traded in '02 Silver Touring Edition w/87,000 miles
Reply With Quote
  #4 (permalink)  
Old 11 Jan 2011, 08:50 am
Obsessed Cruiser
 
Join Date: Sep 2001
Posts: 27,744
Default Re: Weird engine drivetrain problem I need help with...

Maybe a stupid question, but did you have the emergency brake on? With it on, you can back up but when you try to go forward (depending on how hard the EB is on) you won't be able to move or it will shudder.

P.S. Do it all the time with the wife's car. She uses the EB all the time and I forget to take it off when taking her car. I back it out of the driveway and when I try to go forward it won't or starts shuddering/hopping till I release the brake.
__________________
Rules of the forum have been updated as of *07/07/2019* Please read them over.

- All decisions by the Moderator are semi-permanent, can and may be changed at his discretion but definitely will be the final word. Any action performed by the Administrator or Moderators are not to be discussed on the forum.
Reply With Quote
  #5 (permalink)  
Old 11 Jan 2011, 07:16 pm
Fresh Cruiser
 
Join Date: Apr 2009
Posts: 6
Default Re: Weird engine drivetrain problem I need help with...

My tech said it appears to be a compression issue, so I took it back to the fellow who overhauled the engine and he will check it in the next couple days and see what he thinks,

I have owned lots of cars some better than others but this PT is sadly rating up there with the biggest POS and I hate to say that because I do love this car if it wasnt always having some issue or another,

In addition to the compression issue,
The starter is bad,
The ball joints tie ends,
AC leaking at evaporator...I was told this is a huge task to fix
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Newbie Question on Engine/Drivetrain Vibrations crave4speed Tech & Performance Forum 10 06 Feb 2013 09:57 pm
2001 pt has weird won't start problem monitor51 Tech & Performance Forum 13 17 May 2010 09:05 am
Weird sound from engine? Scrathy Tech & Performance Forum 1 01 Sep 2009 12:34 pm
Weird Electrical Problem da12ask General PT Cruiser Discussions 6 21 May 2009 12:09 pm
Weird Problem JoeyC33 General PT Cruiser Discussions 5 06 Aug 2008 05:21 pm


All times are GMT -5. The time now is 08:54 pm.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors