PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > 2.4L Turbo Forums > General Turbo Discussions

PT Cruiser Forum

Advertisements
Bad turbo! technical help needed

 
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 05 Mar 2011, 02:37 pm
Young Cruiser
 
Join Date: Dec 2008
Location: Regina
Posts: 51
Default Bad turbo! technical help needed

OK....I'll try to provide as much info as I can.....Have this in another section....but belongs here I think...


It's an 2003 GT
122,000kms
Engine was replaced at 104,00kms with one having 49,000kms (blew the timing belt)
Both engines in MY care always ran synthetic.
Just in the last month I have replaced the valve cover gasket and lower intake gasket and PCV valve....The valve had frozen open and sprayed oil everywhere....or so we thought. The other was preventive and had small leaks.

Car has the Mopar Stage 1 and blow off valve. It is driven kinda aggressively when I drive

Yesterday I heard a ticking under normal acceleration and also noticed that the car lacked power when I "stepped" on it....it does accelerate...but not as usual....like it only has half the guts....immediately when to my mechanic....I was 2 minutes away...He discovered the car was low in oil and we added 3.5L (on the dipstick) before it reached full....There is NO oil in the engine bay, and i can't see if there is blue smoke and IT Doesn't seem to smell.....NOW he says it's a bad turbo....NO other way to explain the oil consumption.....

My question is.....WHERE IS THAT OIL GOING? And what about the lack of power?

I just now look into the cold up pipe and there is oil in the throttle body ...pooled on the lower part.....I then took off the air intake...I have an open element one and I cannot see evidence of oil in the tube....have not taken it off at the turbo yet...car was too warm. I also just noticed that the blow off valve ....blows as soon as I step off the gas...even under very gentle acceleration.

Bad turbo or what? Thanks for the help guys.


Sylvain
Reply With Quote
  #2 (permalink)  
Old 05 Mar 2011, 04:57 pm
Young Cruiser
 
Join Date: Dec 2008
Location: Regina
Posts: 51
Default Re: Bad turbo! technical help needed

OK...more info for you guys....

Took the air breather hose off.....there was significant amounts of oil in there....not dripping but really wet....didn't notice any blow by out of that tube from the valve cover....didn't really check to be honnest

Checked the shaft...spins freely, and no play....

The up pipe....that connects to the throttle body was oily...enough..there was a pool of oil in the throttle body.....

There doesn't appear to be any loose hoses, clamps, holes in any of the tubing to and from the inter-cooler.....

I am soooooo confused now? Can the turbo be letting oil in/out even if it "appears" to be ok?

Could it be bad rings? PCV valve again? I ran the car in the garage and there was NO burnt oil smell at all.......rev'ed it up a few times....nothing outta the exhaust.....

No oil leakage anywhere to explain the loss of oil?

Help please....Have scheduled a compression test...to be safe ...I want them to "eliminate" other possibilities before I drop 700 bones on remaned turbo

Sylvain
Reply With Quote
  #3 (permalink)  
Old 05 Mar 2011, 05:45 pm
Senior Cruiser
 
Join Date: Jan 2003
Location: Huntington Beach, CA, USA.
Posts: 1,799
Default Re: Bad turbo! technical help needed

With a turbo my first thought on loss of power is always a boost leak. You need either a boost guage or a leak tester to test this. Yes your turbo very well could be bad but I would narrow it down first. A free spinning impeller shaft is a good thing as it no smoke. Go over to PTCREW.com and find the instructions for making a boost leak tester. It may be posted here too but know it is there for sure.
__________________
'03 Inferno Red GT, 5 speed, STAGE 1, Mopar BOV, Plastic Intake, Modified Upper and Lower Airbox, Custom Airbox-to-turbo pipe, Borla dual exhaust, Maddog Short Shifter, Drilled/Slotter Rotors, Ceramic Pads, chrome wheels, chrome door spears, AMP chrome fuel door, PT Cruiser 3rd light diffuser, H&R Springs, Rear Sway Bar added, MGW chrome door lock pulls, Blane's hood struts, Custom license plate mount, some interior dress up stuff...more to come
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Expertise needed...Replacing Turbo mfbharmal General Turbo Discussions 5 24 Sep 2009 06:50 pm
Turbo needed!! raydar65 Classifieds: Want To Buy 0 30 Jan 2009 02:09 pm
HELP!!! TURBO NEEDED raydar65 Tech & Performance Forum 1 27 Jan 2009 04:52 pm
Turbo/nonturbo help needed... careyk General PT Cruiser Discussions 2 11 May 2008 10:28 pm
Any Special Treatment Needed for the GT Turbo? bnbhoward Turbo Performance 9 17 Apr 2003 02:20 am


All times are GMT -5. The time now is 03:54 pm.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors