PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > 2.4L Turbo Forums > General Turbo Discussions

PT Cruiser Forum

Advertisements
Installed mopar bov plate but it dosnt work ?

 
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 11 Apr 2011, 07:24 pm
Fresh Cruiser
 
Join Date: Apr 2011
Location: WAYNESBORO PA
Posts: 21
Question Installed mopar bov plate but it dosnt work ?

I installed the mopar bov plate but its not blowing off 2 the atmosphere its still blows off though the intake also I put on an air intake not sure if that's the problem or not I put the plate on like the directions said can anyone give me an idea wat I did wrong


O3 pt cruiser dream cruiser 2.4 turbo
Reply With Quote
  #2 (permalink)  
Old 11 Apr 2011, 07:27 pm
Kawizx9r's Avatar
Senior Cruiser
 
Join Date: Aug 2010
Location: Salinas, CA
Posts: 1,575
Default Re: Installed mopar bov plate but it dosnt work ?

Did you install the plate facing in the correct direction? Also did you ensure that when you put things back together, you double checked to make sure all vacuum lines were still connected?

FYI Even with the included gasket, it always helps to use some RTV sealant to make sure you cover any possible leakage.
__________________
Quote:
Originally Posted by Chromenut View Post
Kawi is a friggin genius!
Reply With Quote
  #3 (permalink)  
Old 11 Apr 2011, 08:24 pm
Senior Cruiser
 
Join Date: Jan 2003
Location: Huntington Beach, CA, USA.
Posts: 1,799
Default Re: Installed mopar bov plate but it dosnt work ?

If you are getting no blow off you have the plate rotated in the wrong position. Drive carefully until you get it in right
__________________
'03 Inferno Red GT, 5 speed, STAGE 1, Mopar BOV, Plastic Intake, Modified Upper and Lower Airbox, Custom Airbox-to-turbo pipe, Borla dual exhaust, Maddog Short Shifter, Drilled/Slotter Rotors, Ceramic Pads, chrome wheels, chrome door spears, AMP chrome fuel door, PT Cruiser 3rd light diffuser, H&R Springs, Rear Sway Bar added, MGW chrome door lock pulls, Blane's hood struts, Custom license plate mount, some interior dress up stuff...more to come
Reply With Quote
  #4 (permalink)  
Old 12 Apr 2011, 12:01 am
Cool Cruiser
 
Join Date: Feb 2011
Posts: 403
Send a message via MSN to niel
Default Re: Installed mopar bov plate but it dosnt work ?

Damn... All points that you have one of two...

One.. You have the U shaped opening in the wrong position
Two... you have the plate facing backwards

Whatever of this two you have please drive slow and don't push it to hard till you fix it

Daniel
__________________
"I AM THE DIGITAL SIGNAL PROSESSOR"
Reply With Quote
  #5 (permalink)  
Old 12 Apr 2011, 01:57 am
Obsessed Cruiser
 
Join Date: Nov 2007
Location: Mooresville, NC
Posts: 5,324
Default Re: Installed mopar bov plate but it dosnt work ?

Did you mark your original install to insure when you put it back together you had all pieces facing correctly? Before assembly, did you test fit and mark to make sure that you lined up the BOV correctly?

Here's a before and after shot, but you really need to make sure you've not got the BOV plate upside down!





Second picture, notice my red lines used to properly line up the BOV plate? You really need to make sure you do a mock-up before bolting it down.
Reply With Quote
  #6 (permalink)  
Old 12 Apr 2011, 02:50 pm
Fresh Cruiser
 
Join Date: Apr 2011
Location: WAYNESBORO PA
Posts: 21
Default Re: Installed mopar bov plate but it dosnt work ?

I'm going 2take it back a part and check it I might have it backwards ill let u all knw wat I come up with thanks I'm driving it no more than needed
Reply With Quote
  #7 (permalink)  
Old 12 Apr 2011, 04:45 pm
Banned
 
Join Date: Sep 2009
Location: south of Tampa, Florida
Posts: 3,037
Default Re: Installed mopar bov plate but it dosnt work ?

One of your problems is "punctuation lackisity".

Jerry
Reply With Quote
  #8 (permalink)  
Old 12 Apr 2011, 06:32 pm
Obsessed Cruiser
 
Join Date: Nov 2007
Location: Mooresville, NC
Posts: 5,324
Default Re: Installed mopar bov plate but it dosnt work ?

Quote:
Originally Posted by wwpptc View Post
lackisity
huh? LMAO

Believe me, you can very easily have it flipped upside down. And don't worry, you're not hurting anything with it in there wrong, but you'll bleed off boost and lose power.
Reply With Quote
  #9 (permalink)  
Old 15 Apr 2011, 04:38 pm
Fresh Cruiser
 
Join Date: Apr 2011
Location: WAYNESBORO PA
Posts: 21
Default Re: Installed mopar bov plate but it dosnt work ?

Ok so I pull my mopar bov off and I had it installed in the correct position but it still not blowing off I installed my boost gauge it reads 20 on the vac side wen idling wen I give it gas it only goes up to 0 wen I'm driving the boost gauge don't go above 10 on the vac side and 5 psi onthe boost side if I floor the gas peddle will driving this is the first turbocar I've owned I've always built drag cars looking for help on this.
Reply With Quote
  #10 (permalink)  
Old 15 Apr 2011, 10:17 pm
Cool Cruiser
 
Join Date: Feb 2011
Posts: 403
Send a message via MSN to niel
Default Re: Installed mopar bov plate but it dosnt work ?

Quote:
Originally Posted by Dillinger10 View Post
Ok so I pull my mopar bov off and I had it installed in the correct position but it still not blowing off I installed my boost gauge it reads 20 on the vac side wen idling wen I give it gas it only goes up to 0 wen I'm driving the boost gauge don't go above 10 on the vac side and 5 psi onthe boost side if I floor the gas peddle will driving this is the first turbocar I've owned I've always built drag cars looking for help on this.
Ok this points that you have a major BOOST LEAK!... you should do a boost leak tester, its so easy! Ill post some pics of what mine looks like, you do need an air compressor, to put some presure to the system, but first thing you can do its yo tight all the clams, the one that was failing me was the one that goes from the turbo to the intercooler, that pipe was all lose, so try to tight everything you can...
__________________
"I AM THE DIGITAL SIGNAL PROSESSOR"
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Mopar Performance Blow off plate IMIEIW Turbo Performance 7 13 May 2010 06:06 pm
what does the mopar BOV PLATE sound like-does it bypass the purge valve completly ? mino Turbo Performance 1 15 Oct 2007 02:21 pm
Mopar Work on Automatic? Axearmor Tech & Performance Forum 1 06 Jul 2007 06:47 pm
Mopar BOV vs plate hoopdiewagon General Turbo Discussions 3 06 Aug 2004 02:40 am
Mopar BOV installed. Dragula General Turbo Discussions 5 18 May 2004 02:53 pm


All times are GMT -5. The time now is 09:44 am.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors