PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > 2.4L Turbo Forums > General Turbo Discussions

PT Cruiser Forum

Advertisements
Engine Coughing

 
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 02 Feb 2004, 11:05 pm
Regular Cruiser
 
Join Date: Apr 2003
Location: Raleigh, NC, USA.
Posts: 153
Send a message via AIM to ZZCruzr
Default Engine Coughing

A while ago I wrote that I had developed a cough, or stutter in my otherwise trouble free turbo. The car would idle fine, but at part throttle, and lower RPM's the engine would skip and cough. At full throttle, the car was "fine". This started happening right after a fill-up. At the time, I blammed it on "bad gas". (I have always used 93 octane...all 8800 miles). After a few more fill-ups, the problem seemed to be getting better...but the car still wasn't 100%. I took it to my "Five Star" dealership, where I had purchased the car. They said the computer showed nothing, and that it probably was the gas thing. (They never took it for a ride). The car continued to run inconsistent...one day great, another so-so. Finally, last Friday, on the way to work, I thought I wouldn't make it all the way there! The car was horrible, missing really badly, even backfiring! The check engine light came on. I called another dealer, right up the street from where I work, and they agreed to look at it, even though they were booked solid. They called later in the day to tell me the number 1 plug was bad and they had replaced it under warranty. When I picked-up the car, they told me how much they loved the mods...NOT how I could have affected the warranty. Even though they're not a "Five Star" dealer...they'll have my business forever! The car runs better than ever! When I got in to the car, they had even made copies of the Mopar Performance Parts sheets and left them on the passenger's seat! (Many of which are already on my wish list!) Great job! ! ! ! ! NOT ALL DEALERS ARE BAD!
Reply With Quote
  #2 (permalink)  
Old 03 Feb 2004, 12:53 am
Cool Cruiser
 
Join Date: Jul 2003
Location: CA., USA.
Posts: 473
Default

What is the name of the dealer? Thanks.
Reply With Quote
  #3 (permalink)  
Old 09 Feb 2004, 01:54 am
Regular Cruiser
 
Join Date: Apr 2003
Location: Raleigh, NC, USA.
Posts: 153
Send a message via AIM to ZZCruzr
Default

ptgtcb...the dealer I bought the car from is AutoPark Chrysler-Jeep. The guys that fixed the problem are Westgate Chrysler-Jeep. They have even followed up with me about warranty coverage of the wish-list performance mods I want to make.
__________________
[IMg]
http://fototime.com/{5590095C-9F94-449F-A156-7F9FD8C700EB}/picture.JPG[/IMG]
Black Clearcoat 2003 Turbo GT w/gray leather interior...rear splash guards, stainless door sills, air bag decals, red painted brake calipers, BTG duals, AMX cold air intake, Blaine hood struts, ZZcruZr third brake light diffuser, AutoVation pedals, MoMo F16 Evo red gearshift.
Reply With Quote
  #4 (permalink)  
Old 09 Feb 2004, 11:47 am
Cool Cruiser
 
Join Date: May 2003
Location: Philadelphia, PA, USA.
Posts: 374
Send a message via AIM to yobiebs
Default

ZZ,

I had a similar problem with my cruiser a while back. Took it to the dealer on two seperate occassions, and they couldn't come up with anything. Then, one day, the car just stopped in my driveway, and wouldn't go anywhere. Had it towed to another dealer, and the transmission was totally shot. (and this was with only 11K on the car!).

Anyway, I don't know if it helps, but they said the tranny fluid was charred and burnt. Perhaps you want to have them check to make sure this isn't the problem.

Good luck!

B
__________________
2003 Electric Blue GT

The Philadelphia Flyer
Reply With Quote
  #5 (permalink)  
Old 09 Feb 2004, 04:38 pm
Senior Cruiser
 
Join Date: Jan 2003
Location: Huntington Beach, CA, USA.
Posts: 1,799
Default

Every time I see a great report on a dealership like this I look to see where the poster is registered from. Never seems to be any in So Cal...dang. Glad you found a good one!
__________________
'03 Inferno Red GT, 5 speed, STAGE 1, Mopar BOV, Plastic Intake, Modified Upper and Lower Airbox, Custom Airbox-to-turbo pipe, Borla dual exhaust, Maddog Short Shifter, Drilled/Slotter Rotors, Ceramic Pads, chrome wheels, chrome door spears, AMP chrome fuel door, PT Cruiser 3rd light diffuser, H&R Springs, Rear Sway Bar added, MGW chrome door lock pulls, Blane's hood struts, Custom license plate mount, some interior dress up stuff...more to come
Reply With Quote
  #6 (permalink)  
Old 10 Feb 2004, 09:03 pm
Fresh Cruiser
 
Join Date: Jan 2004
Location: thousand oaks, ca.
Posts: 6
Default

hey Cal Cruzer...you are so right...I had written in the forum very recently, about some minor motor problems...surging,inconsistent acceleration,etc...
Took the ride to Buerge Chyrsler in Santa Monica....3 times, never found anything..I asked them if they took a test drive...always....oh yes, all driving conditions, even though the odometer had a .8 change from when I brought it in....finally on the 3rd visit....they replaced a throttle sensor to the transmission...which I had suggested originally....seems to be running fine now.....and of course...they brought up the whole...your mods may be voiding your warranty.....which I ended with explaining the mods had nothing to do with this problem.....and the service advisor(moron) was pointing out things that were factory installed.....genius...Let me know about any SoCal friendly dealers...cheers..Mo
__________________
03 silver pt gt
BTG GT-Turbo intake
BTG GT-Turbo Stage 1 exhaust
BTG Turbo Performance Springs
Polished alloy shock tower brace
XM radio
and enough chrome to keep my sons out of college...
Reply With Quote
  #7 (permalink)  
Old 15 Feb 2004, 10:25 am
Regular Cruiser
 
Join Date: Apr 2003
Location: Raleigh, NC, USA.
Posts: 153
Send a message via AIM to ZZCruzr
Default


yobiebs...NOPE...just the plug! I have a strong feeling the plug was not right from the day I got the car. It had plenty of power then, but since the new plug was put in, I can't believe how much torque I have at WOT. I guess I have been "missing" a lot of fun! I can't wait for a Stage 2 (?) upgrade!




__________________
[IMg]
http://fototime.com/{5590095C-9F94-449F-A156-7F9FD8C700EB}/picture.JPG[/IMG]
Black Clearcoat 2003 Turbo GT w/gray leather interior...rear splash guards, stainless door sills, air bag decals, red painted brake calipers, BTG duals, AMX cold air intake, Blaine hood struts, ZZcruZr third brake light diffuser, AutoVation pedals, MoMo F16 Evo red gearshift.
Reply With Quote
  #8 (permalink)  
Old 16 Feb 2004, 03:09 am
Fresh Cruiser
 
Join Date: Jun 2003
Location: VENTURA, CA.
Posts: 19
Default

i just changed my plugs after reading the symptoms. i was thinking like bad bov, busted b\c, clogged cat, partially busted boost hoses
you know all the big stuff. nope just bad plugs. i had the factory
losers in there and changed them with fresh ones for ease of install.
and presto....torque and hp back tons of it (13 lbs) only on ebc.
thanks all
__________________
03 GT
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Engine problem BORICUA Tech & Performance Forum 50 23 Jun 2012 03:40 pm
"Mysterious" turbo engine noise...??? Gary04GT Turbo Performance 76 21 Aug 2006 08:28 am
Review: $2200 for a NA replacement engine PT Ctown General PT Cruiser Discussions 8 24 Jul 2006 01:08 pm
Turbo Engine Replacement Bigphil3232 General Turbo Discussions 9 17 Nov 2004 05:43 am
TSB 1802903: Engine Misfire PTskilla General Turbo Discussions 0 18 Aug 2003 12:13 am


All times are GMT -5. The time now is 01:44 am.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors