PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > 2.4L Turbo Forums > General Turbo Discussions

PT Cruiser Forum

Advertisements
Fault code

 
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 19 Mar 2004, 02:34 am
Fresh Cruiser
 
Join Date: Mar 2004
Location: Russellville, Alabama.
Posts: 16
Default Fault code

Hi. I'm new to the forum and have a quick question. I was driving home today and my check engine light came on. When I got home I checked the fault codes and the code P0129 came up. I cannot find this code listed anywhere. Can someone help me with this problem?

Thanks
Reply With Quote
  #2 (permalink)  
Old 19 Mar 2004, 02:49 am
Fanatic Cruiser
 
Join Date: May 2003
Location: Rhode Island.
Posts: 950
Default

You can use search function but here's your answer:

http://www.ptcruiserlinks.com/forum/...?TOPIC_ID=5834
__________________

2003 GT Inferno Red,5-spd,Eibach Springs,Koni Sport Adjustables, Eibach front and rear Sway Bars, Mopar Stage 1,Mopar BOV,Custom 2.5\" Dual Tip Exhaust (Magnaflow),Hurst Short Throw Shifter, Pioneer DEH6500 Headunit, RF Punch 300 and 301 Amps,RF 12\" Sub and MB Quart Reference and Premium Speakers,Ronal RT 17x7.5\'s with Michelin Pilot Sport 225/45ZR17s, Koni Adjustible shocks, Keystone single scoop, GT Airraid Intake, Mopar Ground Effects
Homepage:
http://www.cardomain.com/id/ptgtredman

http://blueman.ptenthusiasts.net/index.html
Reply With Quote
  #3 (permalink)  
Old 19 Mar 2004, 03:13 am
Fresh Cruiser
 
Join Date: Mar 2004
Location: Russellville, Alabama.
Posts: 16
Default

Thanks for the info. I remembered that I accidentially dropped the key when I started the car. I have an appointment for an oil change next week and will tell the dealer that code and that the computer needs to be reflashed. Thanks again for the help!
Reply With Quote
  #4 (permalink)  
Old 19 Mar 2004, 09:13 am
Dedicated Cruiser
 
Join Date: Oct 2003
Location: Jacksonville, NC, USA.
Posts: 2,612
Default

RossiePT, welcome to the forum!
__________________

2002 Inferno Red PT Limited
Photos and more at: http://www.randgraphics.org/PT_Cruiser/demos/index.htm
Mercedes Wiki
Reply With Quote
  #5 (permalink)  
Old 26 Mar 2004, 06:45 pm
Paw Paw is offline
Regular Cruiser
 
Join Date: May 2003
Location: Upper Sunshine Coast, British Colimbia, Canada.
Posts: 105
Default

Since we are on the fault code, has anyone encouter a P0121 and P1188 at the sametime. I'm use to the P1188 since the car was new but the P0121 is an interesting one. It causes the engine to surge when in idle (750 to 1500+) and the engine to maintain a higher than normal rpm even when you release the gas pedal. As for the vehicle, it is as original as it can be other than the K&N drop in filter. Any idea?

Paw[:I]
Reply With Quote
  #6 (permalink)  
Old 27 Mar 2004, 12:14 am
Fanatic Cruiser
 
Join Date: Apr 2003
Location: Brunswick, Georgia, USA.
Posts: 518
Default

P0121 is a TPS sensor performance code. (Throttle Position Sensor #1)

When Monitored: With engine running and no MAP sensor or TP sensor DTC's set.

Set Condition: The PCM determines a valid range in which the TP sensor should be, at a given RPM/Load. The actual TP sensor voltage is then compared to this value. If the TP sensor voltage does not fall within the expected range within a predetermined time an error will be detected. One trip Fault.

My Commentary (random musings) - With the history of the P1188 that you have had - with no modifications, and the term LOAD used in the above Set Condition description I am betting the 2 are related, and it has to do with the vacuum harness going to the solenoid pack on the passenger frewall or it's associated wiring.

I believe that the PCM uses vacuum as data to determine load. The P1188 error always seems to occur at the point that the TIP sensor is switched from measuring vacuum or pressure to determine or confirm the the state of the turbo. I would wager a guess that the ground integrity of the wiring to one of the solenoids or to the TIP signal at the PCM is compromised. If there is any difference between ground potential at the solenoid and where the data is referenced to ground, then a timing issue arises. If the data is delayed, then the corresponding action called by the PCM is occuring too late and sets the dominos in motion.
Reply With Quote
  #7 (permalink)  
Old 27 Mar 2004, 04:06 am
Paw Paw is offline
Regular Cruiser
 
Join Date: May 2003
Location: Upper Sunshine Coast, British Colimbia, Canada.
Posts: 105
Default

thanks Dalite, for you quick response. I am trying to book a week off work to go the big city to have to car look at. In the mean time I guess I just have to live with the cycling of the rpm. Hopefully it won't wear out the brake pads. By the way, is it my vehicle or very turbos have the P1188 trouble code popping up all the time?

Paul
Reply With Quote
  #8 (permalink)  
Old 27 Mar 2004, 10:46 am
Regular Cruiser
 
Join Date: Nov 2003
Location: Antelope Valley, Ca, USA.
Posts: 110
Default

Paw;
My car was doing the same thing. DC replaced my vehicle. Have your dealer check Recall / Customer Satisfaction Notice C30. If corrosion is found make sure they replace the harness and the PCM. Search this forum for C30 and my past posts for more info.
__________________
RD CHILI -- PHUN Time Cruisers Club
04 GT Inferno Red Loaded, Mopar Dual Exhaust, K&N Air Filter, Mopar Cabin Air Filter, Mopar BOV Kit, Blane Hood Struts, Strut Tower Brace, Kaiser Custom 17\" Wheels, Nankang Sport NS-1 225/45R17 Tires, Custom Decals, TYC Back-up Lights, LED Glow Lights in and out, Red Fuzzy Dice, Yet To Go; Mopar Stage-2 Turbo Kit, Mopar Stage-2 Suspension, Custom Paint.
Reply With Quote
  #9 (permalink)  
Old 28 Mar 2004, 10:52 pm
Paw Paw is offline
Regular Cruiser
 
Join Date: May 2003
Location: Upper Sunshine Coast, British Colimbia, Canada.
Posts: 105
Default

RD Chili, thanks for the info but unfortunely in the great white north (Canada) we have no lemon law. So, I guess I have live with these minor inconveniences. Will check the C30 info before heading to the dealership.

paw
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Mopar radio security code. Ian-PT-GT Sound and Security Forum 15 15 May 2016 08:40 pm
P0440 fault resets and comes backin PT cruiser2003 sonny General Turbo Discussions 8 09 Jan 2014 08:34 am
PO121 fault code forcedinduction Turbo Performance 3 14 Feb 2006 12:14 pm
Need diag. code info RIvey Tech & Performance Forum 1 01 Oct 2005 12:05 pm
P 2302 Fault Code unable to find Turbo Red General PT Cruiser Discussions 2 08 Feb 2004 12:37 am


All times are GMT -5. The time now is 10:35 pm.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors