PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > 2.4L Turbo Forums > General Turbo Discussions

PT Cruiser Forum

Advertisements
Wow have not been on here for awhile

 
Like Tree2Likes

Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 16 Dec 2013, 12:49 am
Sparkypt's Avatar
Fresh Cruiser
 
Join Date: Dec 2008
Location: Prescott AZ
Posts: 49
Default Wow have not been on here for awhile

Now driving a 03 gt with 113000 . auto .

Having some problems with the fan . Low speed seems to have burnt out on me and its the rare bosch mercedes motor . Anyone have a fix yet for this ? Also what would be a good aftermarket kit to add on rather than listen to the jet plane motor all the time ..

Also picked up a srt 4 exhaust . Mid pipe will not fit around rear suspension .
Ive read a few time of owners installing this swap .
I know the rear tire has to be removed . But dose anyone have any good pics of the install and what route they took?

Thanks!!!
__________________

2003 Pt GT. Black , Dumped exhaust after cat , Mopar BOV , 12 IN air intake , Tinted taillights , Debadged , Sumitomo racing tires .
Reply With Quote
  #2 (permalink)  
Old 16 Dec 2013, 05:41 am
CREWZIN's Avatar
Obsessed Cruiser
 
Join Date: Sep 2001
Location: West Central Florida
Posts: 27,703
Default Re: Wow have not been on here for awhile

Welcome back to the forum.
Your doesn't have two speeds. The Turbo models (if I'm correct) don't have the high and low speed relays. It's a variable speed fan run by the PCM and yes, very un-common because it was the first year Turbo and pretty expensive to replace.

If your good with messing around with electrics, you can try pulling the motor apart and it should have the same brushes (that wear out) in it that the Non-Turbo model has. These can be replaced. Several owners on non-turbo PT's have done the swap but most just replace the whole fan because it's pretty cheap ($100) with the shroud.



__________________
........
...just CREWZIN along! . . . PT Cruiser Links Moderator
2000 PT. Original Owner, 123,000 miles
MY technical suggestions are given in GOOD FAITH without total guarantee, if in doubt go to a garage.
Cruiser Of The Month (COTM) May, 2015.
Visit My Home Page www.CREWZIN.com
I find it ironic that the colors red, white, and blue stand for freedom until they are flashing behind you.

Last edited by CREWZIN; 16 Dec 2013 at 05:43 am.
Reply With Quote
  #3 (permalink)  
Old 16 Dec 2013, 12:10 pm
2step's Avatar
Senior Cruiser
 
Join Date: Oct 2004
Location: New Braunfels, Texas.
Posts: 1,672
Default Re: Wow have not been on here for awhile

Cool photos! That example looks like the brushes wore very unevenly. Great suggestion but I'm wondering where just the brushes alone could be bought?? I don't have a lot of faith in the dealer or Chrysler stocking them.

I vaguely recall possible PCM problems causing fan speed problems. I don't remember if there is a suggested fix like a simple battery disconnect or not. Maybe a search could turn up some details???
Reply With Quote
  #4 (permalink)  
Old 16 Dec 2013, 12:29 pm
Dedicated Cruiser
 
Join Date: Sep 2009
Location: south of Tampa, Florida
Posts: 2,888
Default Re: Wow have not been on here for awhile

I sited this post quite awhile back as being the best long term, highest quality fix when the 2003 turbo radiator fan fails. The 2003 turbo fan is the only year with a constantly variable speed fan. It's speed is controlled entirely by the PCM. The highest quality fix is to purchase a new motor that is listed in the post below and install it on your old fan assembly. If you want to go searching through the salvage yards you can probably find a good used fan motor.

The post below is clear on the whole process. Please read the thread before asking any questions.


PT GT 03 Radiator Fan Solution

Jerry
__________________

Last edited by wwpptc; 16 Dec 2013 at 12:52 pm.
Reply With Quote
  #5 (permalink)  
Old 16 Dec 2013, 01:08 pm
Sparkypt's Avatar
Fresh Cruiser
 
Join Date: Dec 2008
Location: Prescott AZ
Posts: 49
Default Re: Wow have not been on here for awhile

Yeah finding a 211 fan motor ive found to be almost im possible .
As fars as gt cruiser .... Im like one of the only ive seen in a loong time. Rest are turbo lites and na's.
__________________

2003 Pt GT. Black , Dumped exhaust after cat , Mopar BOV , 12 IN air intake , Tinted taillights , Debadged , Sumitomo racing tires .
Reply With Quote
  #6 (permalink)  
Old 16 Dec 2013, 01:13 pm
Sparkypt's Avatar
Fresh Cruiser
 
Join Date: Dec 2008
Location: Prescott AZ
Posts: 49
Default Re: Wow have not been on here for awhile

Oh one more thing on the fan issue.
I get code p0480.
Could this Help any with telling why the fan is acting up?
Or is that just telling me somthing is wrong with my fan but nenernener your chrysler wont tell ?
__________________

2003 Pt GT. Black , Dumped exhaust after cat , Mopar BOV , 12 IN air intake , Tinted taillights , Debadged , Sumitomo racing tires .
Reply With Quote
  #7 (permalink)  
Old 16 Dec 2013, 01:24 pm
Sparkypt's Avatar
Fresh Cruiser
 
Join Date: Dec 2008
Location: Prescott AZ
Posts: 49
Default Re: Wow have not been on here for awhile

Oh wow , i was not aware i could replace the internal components.
As for a w211 fan motor , im in arizona and you would think i could find the mercedes part ... nope !
And yes i ment varible speed .
Anyone have anything for the exhaust problems
__________________

2003 Pt GT. Black , Dumped exhaust after cat , Mopar BOV , 12 IN air intake , Tinted taillights , Debadged , Sumitomo racing tires .
Reply With Quote
  #8 (permalink)  
Old 16 Dec 2013, 02:13 pm
Dedicated Cruiser
 
Join Date: Sep 2009
Location: south of Tampa, Florida
Posts: 2,888
Default Re: Wow have not been on here for awhile

Quote:
Originally Posted by Sparkypt View Post
Now driving a 03 gt with 113000 . auto .

Having some problems with the fan . Low speed seems to have burnt out on me and its the rare bosch mercedes motor . Anyone have a fix yet for this ? Also what would be a good aftermarket kit to add on rather than listen to the jet plane motor all the time ..

Also picked up a srt 4 exhaust . Mid pipe will not fit around rear suspension .
Ive read a few time of owners installing this swap .
I know the rear tire has to be removed . But dose anyone have any good pics of the install and what route they took?

Thanks!!!

I've seen several pics of installs over the years and they all simply used ONLY the axle-back portion of the SRT-4 exhaust on their PTs. They removed their existing muffler and had a good exhaust shop weld in the axle-back portion of the SRT duals onto the origional PT pipe. It joins over the top of rear axle. To me the SRT goes through to many contortions to make it viable as a choice for my own PT. To much unneeded weight and flow restrictions (direction changes) to suit my taste. I simply made up my own system from the axle back out of stock pipe and a couple resonators.


STOCK SRT-4 SYSTEM and A SIDE EXIT STYLE
[IMG][/IMG]

[IMG][/IMG]

[IMG][/IMG]

[IMG][/IMG]

Resonators and re-customized custom TYC back-up lights. Red in back-up lights changed to match the shape of the resonated exhaust tips.
[IMG][/IMG]

[IMG][/IMG]

Four inch retro turndowns
[IMG][/IMG]


Jerry
ROCKETMAN8060 likes this.
__________________

Last edited by wwpptc; 17 Dec 2013 at 04:04 pm.
Reply With Quote
  #9 (permalink)  
Old 16 Dec 2013, 05:43 pm
Sparkypt's Avatar
Fresh Cruiser
 
Join Date: Dec 2008
Location: Prescott AZ
Posts: 49
Default Re: Wow have not been on here for awhile

First : Nice pt jerry , thing is sweet and unique !
Yeah never thought about using the factory mid pipe ..... kinda got rid of mine !
Welp looks like im just going to sell this to some one with a srt4 or neon i suppose .
Might as well just do a 3inch turbo back !
wwpptc likes this.
__________________

2003 Pt GT. Black , Dumped exhaust after cat , Mopar BOV , 12 IN air intake , Tinted taillights , Debadged , Sumitomo racing tires .
Reply With Quote
  #10 (permalink)  
Old 16 Dec 2013, 06:45 pm
Dedicated Cruiser
 
Join Date: Sep 2009
Location: south of Tampa, Florida
Posts: 2,888
Default Re: Wow have not been on here for awhile

Quote:
Originally Posted by Sparkypt View Post
First : Nice pt jerry , thing is sweet and unique !
Yeah never thought about using the factory mid pipe ..... kinda got rid of mine !
Welp looks like im just going to sell this to some one with a srt4 or neon i suppose .
Might as well just do a 3inch turbo back !
Sparky, thanks for the kind words! Members here like Crewzin and Busted, know that it has taken a LONG time to get it to this point.

Sorry you got rid of the stock system, but I would have probably done the same thing if I was in your place and had expected the SRT system to just bolt in place.

Jerry
__________________

Last edited by wwpptc; 16 Dec 2013 at 06:50 pm.
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Been gone awhile sonocativo Testing 170 04 Jan 2015 09:52 am
Hope that is it for awhile$$$$$$$$ careyk General PT Cruiser Discussions 5 20 May 2010 06:37 pm


All times are GMT -5. The time now is 06:48 am.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors