PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > 2.4L Turbo Forums > General Turbo Discussions

PT Cruiser Forum

Advertisements
I NEED HELP!! PLEASE! ANYONE!

 
Like Tree3Likes

Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 08 Jun 2014, 12:30 pm
Fresh Cruiser
 
Join Date: Jun 2014
Posts: 2
Exclamation I NEED HELP!! PLEASE! ANYONE!

I HAVE A PT CRUISER THAT STARTED TO SMOKE BIG CLOUDS OF WHITE SMOKE! I LOOKED UNDERNEATH AND FOUND OIL IN MY EXHAUST. I OPENED EVERYTHING UP AND THERE WAS OIL EVERYWHERE IN MY VALVE COVER, VACUUM HOSES, AIR FILTER LIKE LITERALLY EVERY! I HEARD IT CAN BE MY TURBO BUT I TOOK OUT SPARK PLUGS AND 3 OUT 4 SPARKS PLUGS WERE DRENCHED IN OIL ON THE BOTTOM OF THE PLUGS WHERE THEY SCREW IN NOT ON TOP WHERE PORCELAIN IS BUT THEY SPARKED AND CAR STARTED AND RAN FINE FOR MOST PART. RAN COMPRESSION TEST AND THEY WERE ALL PRETTY CLOSE. I"M WONDERING IF TURBO CAN CAUSE ALL OF THIS??? PLEASE HELP ANYONE! ANY TIP CAN HELP RIGHT NOW! THANK YOU!
Reply With Quote
  #2 (permalink)  
Old 08 Jun 2014, 12:51 pm
boonie2's Avatar
Fanatic Cruiser
 
Join Date: Mar 2014
Location: South Florida
Posts: 535
Default Re: I NEED HELP!! PLEASE! ANYONE!

Year , Make , Model ???
__________________
2004 Pt Cruiser 2.4 L {non turbo} 113K miles , Electric Blue pearl {PICTURES in my Profile Album}
Full Synthetic Oil 10w30 K&N Filter
Full Synthetic Trans Fluid / filter Change :bolt-away
Reply With Quote
  #3 (permalink)  
Old 08 Jun 2014, 01:11 pm
Fresh Cruiser
 
Join Date: Jun 2014
Posts: 2
Default Re: I NEED HELP!! PLEASE! ANYONE!

Its a 03 Chysler Pt cruiser 2.4L turbo
Reply With Quote
  #4 (permalink)  
Old 14 Jul 2014, 04:56 pm
Fanatic Cruiser
 
Join Date: May 2014
Location: Pasadena TX
Posts: 713
Default Re: I NEED HELP!! PLEASE! ANYONE!

Dream Cruiser, GT, or Limited? Just curious.
Reply With Quote
  #5 (permalink)  
Old 14 Jul 2014, 05:20 pm
cruserdad1976's Avatar
Obsessed Cruiser
 
Join Date: Sep 2009
Location: st james mo
Posts: 8,217
Default Re: I NEED HELP!! PLEASE! ANYONE!

no the turbo can not cause oil to be covering the entire engin yes it can cause smoke

first check your PCV valvue to make sure it is intack and working

if your plugs are oily on the threads on one the electrode im not sure what is up
i cant even think of anything that would cover the motor in oil
maybe power wash the engin and then start it and let it run while checking it out??? dont knwo is it drippijng oil onto the ground??? was it low on oil?????
Reply With Quote
  #6 (permalink)  
Old 14 Jul 2014, 08:15 pm
chris15's Avatar
Senior Cruiser
 
Join Date: Jan 2008
Location: Tampa, Florida
Posts: 1,035
Default Re: I NEED HELP!! PLEASE! ANYONE!

Not sure why the year, make or model matter since in the OP's first post he references a PT Cruiser and mentions having a turbo. The trim doesn't matter either.

OP:
- As Cruiserdad mentioned, I would replace the PCV valve.
- You can wind up with oil in the intercooler pipes, throttle body and intake manifold if you have a blown seal in the turbo.
- You mention having oil "in" the valve cover. Well, there needs to be oil in the valve cover to lubricate the cams..
- Oil can exit the system through the hose on the driver's side of the block that leads to the airbox. There's a little sponge-like filter in the airbox that's intended to "catch" this stuff. Replace that (typically found in the Help section of most parts stores), and your regular air filter.
- If your spark plugs have oil on them, you need to replace the valve cover gasket.. specifically the 4 spark plug o-rings that are included in the set. Honestly unsure of how you could end up with oil in the exhaust as it would burn out in the combustion chambers and exit the system as blue smoke.

Start there and see if your issues resolve themselves.
__________________
2003 GT (6262, the works)
2001 PT MTX-Swapped/Turbo

Reply With Quote
  #7 (permalink)  
Old 14 Jul 2014, 09:12 pm
randyincctx's Avatar
Veteran Cruiser
 
Join Date: Jun 2013
Location: Corpus Christi,Tx.
Posts: 3,485
Cool Re: I NEED HELP!! PLEASE! ANYONE!

Quote:
Originally Posted by chris15 View Post
If your spark plugs have oil on them, you need to replace the valve cover gasket.. specifically the 4 spark plug o-rings that are included in the set.
What he said....
__________________
2003 PT Cruiser (Base-N/A) Patriot Blue Pearl Purchased @ Police Impound Auction for $1,000.
Aka:~KILLER~
Reply With Quote
  #8 (permalink)  
Old 15 Jul 2014, 09:28 am
cruserdad1976's Avatar
Obsessed Cruiser
 
Join Date: Sep 2009
Location: st james mo
Posts: 8,217
Default Re: I NEED HELP!! PLEASE! ANYONE!

but the op said the oil was NOT on the porclin part of the plugs Ok so I really have no idea if the plugs were soaked in oil on the electrode they would not fire or fire reallyl baddly
Reply With Quote
  #9 (permalink)  
Old 15 Jul 2014, 09:47 am
Busted_PT's Avatar
Obsessed Cruiser
 
Join Date: Jan 2012
Location: Beckley, W.V.
Posts: 13,883
Default Re: I NEED HELP!! PLEASE! ANYONE!

Quote:
Originally Posted by cruserdad1976 View Post
but the op said the oil was NOT on the porclin part of the plugs Ok so I really have no idea if the plugs were soaked in oil on the electrode they would not fire or fire reallyl baddly
The oil doesn't have to be all the way u on the porcelain of the plugs for the I rings being bad. But still can run down the threads as you take them out. If you bounce them around the hole you could get oil on the electrode. Hard to tell really. Whatever is putting oil all over the engine has nothing to do with oil in the exhaust. The op hasn't been back since the first 2 posts?
__________________

03 Dream stock___________________________ 04 Touring turbo lite stock_________ 02 Touring stock_____________________ The "Three Amigos"
__________________________________________________ __________________________________________________ ___________Performance, Body and Service, OEM

This Is my project page.
http://www.ptcruiserlinks.com/forum/...oject-1-a.html

This is a great read from one of our own! Badglas
badglas.blogspot.com
Reply With Quote
  #10 (permalink)  
Old 15 Jul 2014, 11:06 am
cruserdad1976's Avatar
Obsessed Cruiser
 
Join Date: Sep 2009
Location: st james mo
Posts: 8,217
Default Re: I NEED HELP!! PLEASE! ANYONE!

i noitced that
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -5. The time now is 01:58 am.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors