PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > 2.4L Turbo Forums > General Turbo Discussions

PT Cruiser Forum

Advertisements
my gt gets 15mpg after stage 1 install????? please help

 
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 28 Jul 2014, 09:00 pm
Fresh Cruiser
 
Join Date: Jul 2014
Posts: 8
Default my gt gets 15mpg after stage 1 install????? please help

I recently had a 06 atx mopar stage 1 installed in my 06 autostick gt cruiser, since then it has dropped my gas mileage down to as low as 8mpg, and 15 max!?!?! I took it back to the dealer that flashed my Vin and installed it to get it checked out, they told me it was normal..... I know it's not normal and want to fix what ever they did wrong???? Can anyone help me please?????

I bought the pcm from eBay used, had them register my Vin and install it, is there anything I should know about this process, I was told the quick learn will learn it's self, I do not drive it aggressively, I got 205 miles from my last full tank being conservative on the highway, please help

Last edited by CREWZIN; 29 Jul 2014 at 05:03 am. Reason: correction
Reply With Quote
  #2 (permalink)  
Old 28 Jul 2014, 11:59 pm
Cool Cruiser
 
Join Date: Jan 2014
Posts: 264
Default Re: my gt gets 15mpg after stage 1 install????? please help

That horrible. That is like SRT-10 RAM territory lol. There are many things that can affect gas mileage. So the ONLY thing that was changed was the PCM and you went with Mopar S1? After that was installed you have gotten horrible gas mileage, or did the bad gas mileage happen prior to install? How many tanks have you ran on the S1? Still sounds very wrong. No CEL? Do you have a wideband?
__________________
1999 Dodge Neon Coupe. DOHC 5 speed
2005 Crossfire SRT-6
2005 PT Cruiser GT 5 speed. 1 of 21 (SOLD)
Reply With Quote
  #3 (permalink)  
Old 29 Jul 2014, 12:14 pm
Veteran Cruiser
 
Join Date: Mar 2012
Location: darien il
Posts: 4,592
Default Re: my gt gets 15mpg after stage 1 install????? please help

is this with good quality premium fuel?
Reply With Quote
  #4 (permalink)  
Old 29 Jul 2014, 06:03 pm
cruserdad1976's Avatar
Obsessed Cruiser
 
Join Date: Sep 2009
Location: st james mo
Posts: 8,217
Default Re: my gt gets 15mpg after stage 1 install????? please help

do you have a HEAVY foot
Reply With Quote
  #5 (permalink)  
Old 29 Jul 2014, 06:28 pm
NitroPT's Avatar
Obsessed Cruiser
 
Join Date: Jun 2012
Location: USA kalyfornia
Posts: 15,660
Default Re: my gt gets 15mpg after stage 1 install????? please help

The member has not returned.

This MPG dropped I can not imagine it from a the STAG 1 PCM itself. Something else is wrong. The fueling maps are not changed enough to cause that large a reduction in MPG.
__________________
To view larger pictures simply "click " on the picture!

Dalai Lama
"Share you knowledge. It's the best way to achieve immortality."
ASE MASTER TECHNICIAN
Reply With Quote
  #6 (permalink)  
Old 31 Jul 2014, 01:15 am
Fresh Cruiser
 
Join Date: Jul 2014
Posts: 8
Default Re: my gt gets 15mpg after stage 1 install????? please help

Yea it started after the stage 1 was installled, I've been driving very conservative, went thru make 4 tanks so far. Could the spark plugs be bad because the fuel ratio is different?? I'm so lost on what to do, I just put a cold air intake in and now I get 17mpg, could spark plugs be the problem??
Reply With Quote
  #7 (permalink)  
Old 31 Jul 2014, 01:21 am
Fresh Cruiser
 
Join Date: Jul 2014
Posts: 8
Default Re: my gt gets 15mpg after stage 1 install????? please help

Yea always have premium gas, I notice a small loss of power, bad gas mileage, I'm guessing it's spark plugs but I don't know why it would happen right after my pcm was installed!?!?!

I ha d them register my Vin to it, I bought the pcm used, can it have the last guys setting in it still,?? His car wasn't a gt version, it was a turbo lite??? I read something about abs and no abs, would this milage problem happen because of this if they weren't compatible?
Reply With Quote
  #8 (permalink)  
Old 31 Jul 2014, 07:59 am
quicksilverdon's Avatar
Obsessed Cruiser
 
Join Date: Nov 2003
Location: Felton, Delaware
Posts: 20,501
Default Re: my gt gets 15mpg after stage 1 install????? please help

Plugs and wires cannot hurt - gap at 0.040.
The fact that prior use was on a turbo lite doesn't matter - stage 1 is the same.
__________________
"Anti-intellectualism has been a constant thread winding its way through our political and cultural life,
nurtured by the false notion that democracy means that 'my ignorance is just as good as your knowledge."
Isaac Asimov"

'05 Limited Turbo Lite, (Silver, of course)4-wheel ABS, Sunroof, Spoiler. Mods: E&G Classic grill, K&N FIPK, BTG duals, rear lowered 1.5", LED washer lights, $20 catch can, Aoogah horn, Weatherflectors, Sunroof Deflector, Fuzzy Dice, rear logo flames, rear pinstripe graphic, Gen3 Taillights, rear sway bar, hood struts, Strut bar.
Traded in '02 Silver Touring Edition w/87,000 miles
Reply With Quote
  #9 (permalink)  
Old 31 Jul 2014, 08:16 am
NitroPT's Avatar
Obsessed Cruiser
 
Join Date: Jun 2012
Location: USA kalyfornia
Posts: 15,660
Default Re: my gt gets 15mpg after stage 1 install????? please help

This is more than a plug and wire issue! and what is needed from the OP who has not return is yet for more Q&A about the MPH dropped right after the PCM upgrade. So normal tune up parts is not going to rude the "bigger" problem". Do some put a ban-aid on a cut that needs to be stitched?

BTW the recommended spark plug gap should be using a single ground electrode spark plug between .035-.042 not just a .040 !
I realize that it may seem to be the "in the middle gap recommendation but the reason for the wider variance is for gap tool usage, compensating for how ones technique in gaping a spark plug is and naturally the 95% of people who install them straight out of the box. The coil will fire the spark plug without cause for concern within those gap ranges. Going to plus .010+ from a starting gap of .035-.042 is time to be more aware of engine performance. I keep seeing this .040 being posted as if it were the standard of accuracy, which it is not!
__________________
To view larger pictures simply "click " on the picture!

Dalai Lama
"Share you knowledge. It's the best way to achieve immortality."
ASE MASTER TECHNICIAN

Last edited by NitroPT; 31 Jul 2014 at 08:25 am.
Reply With Quote
  #10 (permalink)  
Old 31 Jul 2014, 08:32 pm
soonercruiser's Avatar
Obsessed Cruiser
 
Join Date: Jun 2007
Location: Oklahoma City
Posts: 7,465
Cool Re: my gt gets 15mpg after stage 1 install????? please help

I'm running a gap of .038.....runs wild!
__________________
Frank, aka SOONERCRUISER,

2011 GWE Dodge Challenger SRT8 as Show Car
2003 PT Cruiser GT Panel Van Conversion as new day driver.

Have now owned 6 PT Cruisers = Me PT Crazy!
Reply With Quote
Reply

Tags
mpg issues, please help, pt cruiser gt, stage 1 install issues


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Stage 1 install tomorrow! PeteyGT Stage Turbo Kits 19 09 Jun 2012 11:56 am
I want to install my stage 1,But BOB RENNINGER Stage Turbo Kits 2 22 Jun 2005 11:43 am
Another Stage I Install Bob Tallman Stage Turbo Kits 10 05 Jan 2005 11:50 pm
Stage 1 Install in California mike Stage Turbo Kits 4 27 Aug 2003 12:52 pm
Macster's Stage 1 Install macster Stage Turbo Kits 9 23 Aug 2003 11:46 pm


All times are GMT -5. The time now is 11:53 pm.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors