PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > 2.4L Turbo Forums > General Turbo Discussions

PT Cruiser Forum

Advertisements
Clutch Problems?

 
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 22 Apr 2004, 11:44 pm
Cool Cruiser
 
Join Date: Jul 2003
Location: CA., USA.
Posts: 473
Default Clutch Problems?

Has anyone had any clutch problems besides the recall problem. After our hyw 49 run last weekend I started to hear a subtle growl when releasing the clutch and now I have a slight chatter that is in time with a metallic clicking, this is all pretty subtle but it is there!. This only happens when starting out in 1st gear and the clutch seems to hold fine. The clutch pedal effort does feel a little stiffer.
The dealer that I purchased the GT from supposedly replaced the clutch assembly under the recall before I purchased it. Chrysler tells me it has been replaced by their records, but I could not find a witness mark on one bellhousing bolt, Only 6000k miles on the GT and they had better warranty the clutch assembly!
Reply With Quote
  #2 (permalink)  
Old 23 Apr 2004, 04:16 pm
Young Cruiser
 
Join Date: Sep 2003
Location: Sacramento, CA, USA.
Posts: 60
Default

Supposedly my vehicle was not part of that recall, however I had my clutch replaced before 2000 miles....

It started with an ocassional rattle noise that appeared right after I purchased the car, however that went away as quickly as it started until the same symptom appeared about a month later. Fortunately the service manager at the dealer was able to get it to make its noise when I dropped it off later, and agreed the clutch was suspect.

After disassembly, I was told that one of the rivets holding the clutch material onto the clutch disk had come apart, which destroyed the clutch and flywheel. The whole assembly was replaced, and I haven't had an issue since. I now have 3300 miles.

HYW 49? As in California Gold Country area? I live relatively near there...
Reply With Quote
  #3 (permalink)  
Old 24 Apr 2004, 12:11 am
Cool Cruiser
 
Join Date: Jul 2003
Location: CA., USA.
Posts: 473
Default

Quote:
quote:Originally posted by Big Al


HYW 49? As in California Gold Country area? I live relatively near there...
Yep! We cruised up 49 to Sutter Creek and spent the night. Then we cruised 49 to Columbia and made our final stop in Jamestown before we headed home. Excellent cruise!
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
New Clutch went bad after 2 weeks??? Ctown Tech & Performance Forum 7 25 Sep 2009 03:40 pm
Review- New performance clutch install for the GT FastNJPT Turbo Performance 2 26 Sep 2006 10:13 am
Clutch release delay sca037 General Turbo Discussions 5 28 Nov 2005 09:58 am
Is any one having clutch problems? Richsard D. Tech & Performance Forum 4 06 Aug 2005 10:10 pm
Clutch Replacement CruiserDan Tech & Performance Forum 4 08 May 2004 01:14 am


All times are GMT -5. The time now is 09:39 pm.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors