PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > 2.4L Turbo Forums > General Turbo Discussions

PT Cruiser Forum

Advertisements
need a little help

 
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 16 May 2015, 01:14 pm
Fresh Cruiser
 
Join Date: May 2015
Location: WISCONSIN
Posts: 4
Default need a little help

I have an 03 gt that keeps kicking a check engine light with a p0344 code and goes in to limp mode. I have replaced the cam position sensor and the cam magnet (dealership parts). It ran fine for a few weeks and then back to the check engine light and limp mode. Not sure what would be the next thing to do. Side note: timing belt and water pump where replace 5 months ago and this problem started after that.
Reply With Quote
  #2 (permalink)  
Old 16 May 2015, 02:53 pm
Obsessed Cruiser
 
Join Date: Aug 2014
Location: Thousand Oaks, CA
Posts: 7,300
Default Re: need a little help

I would suggest checking the CPS & CKS wiring harnesses as having a potential problem especially the wiring near the drive axle getting worn,and causing a 'fault' situation. Its possible when the timing belt was replaced that the wires were moved around and with the age of the wires it possible they are brittle and have bare spots on them. This would be the first thing I would check. Check the wires with an ohm meter and wiggle the wires to make sure they are okay.

Was the timing belt double checked to make sure the timing is correct and that it is not off by one tooth?

Last edited by ptcruisersteve; 16 May 2015 at 02:56 pm.
Reply With Quote
  #3 (permalink)  
Old 16 May 2015, 02:58 pm
Obsessed Cruiser
 
Join Date: Sep 2001
Posts: 27,744
Default Re: need a little help

I had the wiring harness to the Camshaft sensor, which runs around the back of the engine, break loose from the little plastic clips and it let the harness drop far enough to hit the spinning half shaft and burn the wires. Take a good look at the harness (and the connection to the sensor) for any signs of wear and tear.

Had to be towed from I95 in South Carolina to the nearest Chrysler dealer where the mechanic found the burnt wires while he was about to change the sensor.

Reply With Quote
  #4 (permalink)  
Old 16 May 2015, 04:11 pm
Fresh Cruiser
 
Join Date: May 2015
Location: WISCONSIN
Posts: 4
Default Re: need a little help

All the wiring is in good shape and when the timing belt was put in I am not sure if it was double checked but the shop I took it to had a great reputation of going over their work with great detail. Thanks for the help.
Reply With Quote
  #5 (permalink)  
Old 16 May 2015, 05:06 pm
Obsessed Cruiser
 
Join Date: Aug 2014
Location: Thousand Oaks, CA
Posts: 7,300
Default Re: need a little help

Possible causes of P0344

Faulty Camshaft Position Sensor
Camshaft Position Sensor harness is open or shorted
Camshaft Position Sensor circuit poor electrical connection
Faulty starter motor
Starting system circuit
Weak battery


I would suggest checking the voltage on your battery with the engine running. Make sure you are getting approx. 14 to 14.5 volts.
Also make sure your battery is good. Have a battery load test done if you are not sure.
Reply With Quote
  #6 (permalink)  
Old 16 May 2015, 10:25 pm
Senior Cruiser
 
Join Date: Jan 2014
Location: SW PA
Posts: 1,336
Default Re: need a little help

Quote:
Originally Posted by Swilson_82 View Post
All the wiring is in good shape and when the timing belt was put in I am not sure if it was double checked but the shop I took it to had a great reputation of going over their work with great detail. Thanks for the help.
I also get the P0344 code but there is no noticeable performance change, It went out when the weather got cooler last fall. And when the weather warmed up this spring the light came back on. I just tried a gas with a higher octane and the light went off and has been off for a few days....
__________________
Addicted to Mopar You can tell how old I am..
65 Dodge Coronet 6 cyl 2dr Post
66 Ply Satellite with 273 engine swap to 69 340 4spd
70 340 4spd Dart Swinger "Those were the days my friend"
73 Charger SE
Had a few Vetts on the way 69, 85
Several Neons some flips
01 Sebring flip
Cruiser's 01, 220K Gone to a new home
Cruiser 03 133K Gone to a new home
Cruiser 06 110K Project Gone to new Home
Cruiser 05 Ltd 120,809 bought with broken belt Oct2015
May 16 Resurrected to once again roam the streets.

20 Miles South Of Pittsburgh
Reply With Quote
  #7 (permalink)  
Old 16 May 2015, 10:27 pm
Fresh Cruiser
 
Join Date: May 2015
Location: WISCONSIN
Posts: 4
Default Re: need a little help

Battery is good wiring is good. Changed crank sensor and everything seams to be running great now. I will let you all know if that fixed the problem. If it don't, I think it will be going to the shop and getting a complete engine overhaul.
Reply With Quote
  #8 (permalink)  
Old 16 May 2015, 10:53 pm
Obsessed Cruiser
 
Join Date: Aug 2014
Location: Thousand Oaks, CA
Posts: 7,300
Default Re: need a little help

Quote:
Originally Posted by Swilson_82 View Post
Battery is good wiring is good. Changed crank sensor and everything seams to be running great now. I will let you all know if that fixed the problem. If it don't, I think it will be going to the shop and getting a complete engine overhaul.

Do you mean that you will be rechecking the timing belt?
Reply With Quote
  #9 (permalink)  
Old 16 May 2015, 11:13 pm
Fresh Cruiser
 
Join Date: May 2015
Location: WISCONSIN
Posts: 4
Default Re: need a little help

Timing belt will be one of the first things that is checked. Because if it is off by a tooth some one other then me is going to be paying for the work.
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -5. The time now is 02:36 am.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors