PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > 2.4L Turbo Forums > General Turbo Discussions

PT Cruiser Forum

Advertisements
stuttering and popping under load

 
Like Tree1Likes
  • 1 Post By shelbygt660

Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 24 May 2015, 07:20 pm
Young Cruiser
 
Join Date: Nov 2013
Location: Echo bay, Ontario
Posts: 95
Default stuttering and popping under load

Got a 2003 pt gt 2.4 turbo auto stick that when climbing hills or when the engine is under load will buck and sometimes even make popping noises like popcorn under the hood. It's like it's stuttering but if I got wot it goes away. Boost is around .5 psi iirc
__________________
Silver Bullet - 2001 PT Cruiser Limited, 5-Speed, 2.4 N/A, No mods yet just fixing her up slowly
Reply With Quote
  #2 (permalink)  
Old 25 May 2015, 09:02 am
Senior Cruiser
 
Join Date: Jun 2014
Posts: 1,611
Default Re: stuttering and popping under load

Is the check engine light on? Did you check to see if there are any codes? That should be the first step.

Is there smoke coming out of the exhaust when it is popping? I recently bought an 03 GT with a blown turbo. It was leaking oil into the intake and into the intercooler. So much that when at part throttle, it would start popping and stuttering like your car with huge plumes of smoke coming out of the exhaust.

Anyway check your codes and then check to make sure your turbo is ok.

Also, the stock spark plug wires are known to be junk so get another set. Anything is better than stock. You will notice your engine will run smoother instantly. It might even help with the popping; if the problem is spark related.
Reply With Quote
  #3 (permalink)  
Old 25 May 2015, 09:15 am
Busted_PT's Avatar
Obsessed Cruiser
 
Join Date: Jan 2012
Location: Beckley, W.V.
Posts: 13,883
Default Re: stuttering and popping under load

While I have to disagree with the stock wires are junk. Seen plenty at 100k I Would suggest you check the plugs. Depending on the codes you get.
__________________

03 Dream stock___________________________ 04 Touring turbo lite stock_________ 02 Touring stock_____________________ The "Three Amigos"
__________________________________________________ __________________________________________________ ___________Performance, Body and Service, OEM

This Is my project page.
http://www.ptcruiserlinks.com/forum/...oject-1-a.html

This is a great read from one of our own! Badglas
badglas.blogspot.com
Reply With Quote
  #4 (permalink)  
Old 25 May 2015, 09:29 am
Senior Cruiser
 
Join Date: Jun 2014
Posts: 1,611
Default Re: stuttering and popping under load

Just because they have high miles, doesn't mean they are good. The ones I removed had 210,000 Km. They still 'worked', just not well. There are lots of posts on this forum attesting to the poor quality of the stock wires.
Reply With Quote
  #5 (permalink)  
Old 25 May 2015, 10:24 am
Busted_PT's Avatar
Obsessed Cruiser
 
Join Date: Jan 2012
Location: Beckley, W.V.
Posts: 13,883
Default Re: stuttering and popping under load

Quote:
Originally Posted by myckee View Post
Just because they have high miles, doesn't mean they are good. The ones I removed had 210,000 Km. They still 'worked', just not well. There are lots of posts on this forum attesting to the poor quality of the stock wires.
Same postings on the auto gt tranny and many other forum myths. If they are firing all the plugs they can't do much else. Not saing their's is good but plugs way more likely of the two.
__________________

03 Dream stock___________________________ 04 Touring turbo lite stock_________ 02 Touring stock_____________________ The "Three Amigos"
__________________________________________________ __________________________________________________ ___________Performance, Body and Service, OEM

This Is my project page.
http://www.ptcruiserlinks.com/forum/...oject-1-a.html

This is a great read from one of our own! Badglas
badglas.blogspot.com
Reply With Quote
  #6 (permalink)  
Old 25 May 2015, 11:32 am
Senior Cruiser
 
Join Date: Jun 2014
Posts: 1,611
Default Re: stuttering and popping under load

Quote:
Originally Posted by Busted_PT View Post
Same postings on the auto gt tranny and many other forum myths. If they are firing all the plugs they can't do much else. Not saing their's is good but plugs way more likely of the two.
Well that is not true. When the wires break down the resistance increases and while you are generating a spark at the plug; it is very weak. They can also arc through the sheathing instead of delivering the current to the plug.

Of course we can individually choose to believe what we want on the internet. For me, it is also not a myth when you have a rough running engine and then only install only new wires, and have a noticeably smoother engine. It could be the 'placebo effect', but when countless forum posters experience it, as I have, it is likely to be true.

In the original poster's case we don't have enough info yet. It could be spark break down, pointing to plugs, and or wires, or something else. We will see I guess.
Reply With Quote
  #7 (permalink)  
Old 25 May 2015, 11:59 am
Busted_PT's Avatar
Obsessed Cruiser
 
Join Date: Jan 2012
Location: Beckley, W.V.
Posts: 13,883
Default Re: stuttering and popping under load

Quote:
Originally Posted by myckee View Post
Well that is not true. When the wires break down the resistance increases and while you are generating a spark at the plug; it is very weak. They can also arc through the sheathing instead of delivering the current to the plug.

Of course we can individually choose to believe what we want on the internet. For me, it is also not a myth when you have a rough running engine and then only install only new wires, and have a noticeably smoother engine. It could be the 'placebo effect', but when countless forum posters experience it, as I have, it is likely to be true.

In the original poster's case we don't have enough info yet. It could be spark break down, pointing to plugs, and or wires, or something else. We will see I guess.
I figured as much Mike. They still believe the plastic intake HP myth and can feel it as many have stated or reported as some put it. But that has been busted. Factory wires were as good as any. They do have a replacement life as with all. Oh I haven't had any idle issues with these yet. One set was 174K. I was amazed. Ya, they were over do. But still How bad a product could they have been. Still smooth on a set of good plugs. No problems under load. Ran perfect.

As for the last statement I can agree totaly.
__________________

03 Dream stock___________________________ 04 Touring turbo lite stock_________ 02 Touring stock_____________________ The "Three Amigos"
__________________________________________________ __________________________________________________ ___________Performance, Body and Service, OEM

This Is my project page.
http://www.ptcruiserlinks.com/forum/...oject-1-a.html

This is a great read from one of our own! Badglas
badglas.blogspot.com
Reply With Quote
  #8 (permalink)  
Old 25 May 2015, 05:17 pm
Young Cruiser
 
Join Date: Nov 2013
Location: Echo bay, Ontario
Posts: 95
Default Re: stuttering and popping under load

No codes other then the annoying powersteering pressure to low. Just got the car a month ago. Timing belts needs to be done but need to find a set I can afford first. I have taken the throttle body off and cleaned it out. Made no differenCe. There is a stumble at idle. No blue smoke. Not burning any oil either.
__________________
Silver Bullet - 2001 PT Cruiser Limited, 5-Speed, 2.4 N/A, No mods yet just fixing her up slowly
Reply With Quote
  #9 (permalink)  
Old 26 May 2015, 11:37 am
Handy_Cruiser's Avatar
Obsessed Cruiser
 
Join Date: Oct 2013
Location: Arkansas
Posts: 10,263
Default Re: stuttering and popping under load

Quote:
Originally Posted by shelbygt660 View Post
No codes other then the annoying powersteering pressure to low. Just got the car a month ago. Timing belts needs to be done but need to find a set I can afford first. I have taken the throttle body off and cleaned it out. Made no differenCe. There is a stumble at idle. No blue smoke. Not burning any oil either.
If it was me, I'd do the plugs and wires first. They are cheap, easy and likely need to be done anyway.

Next, I'd check vacuum lines. It's possible you are getting a really lean condition when the engine is under load.

If no joy, I would do the cam sensor. My cam sensor recently went out and I experienced just about he same affect you are describing. Yes, a bad cam sensor should throw a trouble code. But if you have a trouble light on all the time anyway, there's a chance the sensor does sometimes throw the code, but it clears before you go home and read it. The same might be true for a misfire code as well. If you have access to a salvage yard, you might try a used sensor first just to see if it makes a difference. But first, try reading your codes right after the symptoms occur.

In the past, I've seen a bad injector do this and I had a bad PCM do this on a a 1995 Dodge Ram. But there are few if any reports of this happening on PT Cruiser on this forum.

It might be helpful if you could record a video of the popping with your cell phone and then post it on YouTube so we can see what the symptoms are for ourselves.
__________________
Reply With Quote
  #10 (permalink)  
Old 27 May 2015, 04:39 pm
Young Cruiser
 
Join Date: Nov 2013
Location: Echo bay, Ontario
Posts: 95
Default Re: stuttering and popping under load

Replaced the wires with a new set that I had on my 01 pt cruiser limited till the head went. Works fine now thanks
myckee likes this.
__________________
Silver Bullet - 2001 PT Cruiser Limited, 5-Speed, 2.4 N/A, No mods yet just fixing her up slowly
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
stuttering and coughing 2.4 2001 ??? briancane Tech & Performance Forum 2 24 Mar 2014 09:41 pm
Pinking and stuttering Jassy General PT Cruiser Discussions 12 05 Oct 2013 08:45 pm
Stuttering 2003 icerobinmomCruiser Tech & Performance Forum 5 29 Jun 2012 08:48 am
CEL, Stuttering, Temperature fluctuation jamie82278 Tech & Performance Forum 1 05 Mar 2012 09:56 pm
Stuttering Turbo? uplanddave Turbo Performance 5 22 Apr 2011 07:54 pm


All times are GMT -5. The time now is 03:10 am.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors