PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > 2.4L Turbo Forums > General Turbo Discussions

PT Cruiser Forum

Advertisements
Missing fan relay

 
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 26 Aug 2017, 03:01 pm
Young Cruiser
 
Join Date: Aug 2014
Location: Mesa, AZ
Posts: 59
Default Missing fan relay

Hey turbo owners:
The small fan relay is missing in my PDC. Is this normal? My fan is operating normally, even tho a P0480 code is present.
Another thing: Is the water temp warning light supposed to come on when ignition is on? Mine does not. The gauge seems fine.
TIA for your replies.
__________________
2003 GT Turbo AT
Reply With Quote
  #2 (permalink)  
Old 26 Aug 2017, 03:21 pm
Veteran Cruiser
 
Join Date: Aug 2015
Location: Lake Wales, FL
Posts: 3,645
Default Re: Missing fan relay

Dude, I HAD an 03 GT and never noticed a missing relay, but didn't really ever think to look and see. If one was missing, I never noticed it. As for the temp light, NO, it doesn't come on when you turn on the key. At least mine didn't either.
__________________


I prefer dangerous freedom over peaceful slavery. Thomas Jefferson
Charlie
Reply With Quote
  #3 (permalink)  
Old 26 Aug 2017, 05:32 pm
Young Cruiser
 
Join Date: Aug 2014
Location: Mesa, AZ
Posts: 59
Default Re: Missing fan relay

Thanks Charlie.
After driving a couple trips today, the CEL went out.
__________________
2003 GT Turbo AT
Reply With Quote
  #4 (permalink)  
Old 26 Aug 2017, 09:13 pm
LionPT's Avatar
Veteran Cruiser
 
Join Date: May 2014
Location: Central Florida
Posts: 3,905
Default Re: Missing fan relay

The 2003 GT has a veritable fan speed, it doesn't have a low or high like the other PT's.
__________________

2006 Touring Edition in Cool Vanilla...aka/Ghost
Nexus 5X, Nexus 4, Nexus 7 (2013)
Reply With Quote
  #5 (permalink)  
Old 26 Aug 2017, 11:39 pm
Obsessed Cruiser
 
Join Date: Aug 2014
Location: Thousand Oaks, CA
Posts: 6,241
Default Re: Missing fan relay

The brushes in your variable speed radiator might be just barely touching or you might want to check your wires and wire connectors going to the radiator fan if the code P0490 comes back.
__________________
If at First You Don't Succeed - Try, Try Again
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
PT missing Csmith General PT Cruiser Discussions 6 08 May 2016 08:13 am
hi/low relay KingBeach Tech & Performance Forum 7 21 Nov 2015 07:38 pm
What am I missing? Jacob Tech & Performance Forum 0 04 Aug 2011 10:12 am
The missing key careyk General PT Cruiser Discussions 3 09 Apr 2009 03:33 pm
MISSING AGAIN/HELP kromans Turbo Performance 8 24 Jan 2005 11:59 am


All times are GMT -5. The time now is 06:22 am.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors