PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > 2.4L Turbo Forums > General Turbo Discussions

PT Cruiser Forum

Advertisements
Oil in the air box

 
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 13 Jul 2004, 06:47 pm
Fresh Cruiser
 
Join Date: Jul 2004
Location: .
Posts: 26
Default Oil in the air box

[:I]
I have an 2003 GT Cruiser and today I put in a K&N drop in filter in it and I noticed a small amout of motor oil inside on the bottom of the air box. The car only has 1200 miles on it and oil level is okay. Is this normal? Has anyone else encountered this? Any ideas what would cause this? Any help would be greatly appreciated. TIA
Reply With Quote
  #2 (permalink)  
Old 13 Jul 2004, 06:57 pm
Regular Cruiser
 
Join Date: Mar 2004
Location: New Lenox, IL.
Posts: 127
Default

Unfortunately, it is normal.
Reply With Quote
  #3 (permalink)  
Old 13 Jul 2004, 07:03 pm
Senior Cruiser
 
Join Date: Feb 2003
Location: .
Posts: 1,872
Default

Here's a little reading for you
http://www.ptcruiserlinks.com/forum/...oil,in,air,box
There's more also you just have to search (upper right of page to the right of "logout".
By the way, welcome to the forum.


Reply With Quote
  #4 (permalink)  
Old 13 Jul 2004, 07:45 pm
Fresh Cruiser
 
Join Date: Jul 2004
Location: .
Posts: 26
Default

Wow thank you very much for the quick responses. What a great site. . If this is a normal process, how much oil will accumulate? Should this be cleaned out on a regular basis? Since this is my first turbo vehicle, I guess that oil blow by is part of the way this engine works...
Reply With Quote
  #5 (permalink)  
Old 14 Jul 2004, 03:17 am
Dedicated Cruiser
 
Join Date: Jan 2003
Location: Washington State, USA.
Posts: 2,525
Default

I usually clean the oil out of my stock airbox every 3000-5000 miles, usually following an oil change. Since I began using Mobil 1 5W-30 I change my oil every 5000 miles/6months.
Reply With Quote
  #6 (permalink)  
Old 14 Jul 2004, 10:36 am
Fresh Cruiser
 
Join Date: Apr 2004
Location: Guadalajara, Jalisco, Mexico.
Posts: 24
Default

Hi!!!!
I have a PT GT 2003 and I saw the same thing, don´t worry is normal!!! I´m from Mexico!!!!
PT GT 2003 Stage 1
__________________
PT GT 2003 ATX
MODS:
Stage1, 2.5\" exhaust system with magnaflow, K&N FIPK2, MP BOV KIT.
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -5. The time now is 11:47 am.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2022, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors