PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > 2.4L Turbo Forums > General Turbo Discussions

PT Cruiser Forum

Advertisements
Transmission Problem??

 
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 13 Aug 2019, 03:52 pm
muzicmax's Avatar
Cool Cruiser
 
Join Date: Mar 2008
Location: Great White North
Posts: 310
Exclamation Transmission Problem??

Hey guys seems I am having trouble (Again) LOL
Anyways I think I am having a tranny problem now on my 03 Pt GT Automatic... My Transmission was replaced with a Tranny straight from Chrysler 500 Km ago.
I was driving like normal was coming to a stop sign so I let off the gas and applied the brakes. When I was ready to go again. I stepped on the gas and it just revved up and wasn't going anywhere. It was in drive as usual. I was stuck and couldn't move forward or backwards the shifter moved to all of the gears but just wouldn't move the Pt. Park worked and neutral worked but nothing else Drive,reverse,low. It shifted fine through all the gears...but just wouldn't go anywhere. One of my friends said it might be a solenoid somewhere and those wouldn't be covered under the tranny warranty. So I searched the net but couldn't find anyone with the same problem.
Any help would be appreciated. I love this forum! Someone always helps me LOL and I have had a lot of problems fixed here
Thanks Guys!
__________________
Reply With Quote
  #2 (permalink)  
Old 13 Aug 2019, 07:21 pm
Cool Cruiser
 
Join Date: May 2016
Posts: 273
Default Re: Transmission Problem??

Gotta ask...have you checked the tranny fluid level?
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Transmission problem 03pc Tech & Performance Forum 2 29 Nov 2014 12:53 am
03 Transmission Problem mike1999 Tech & Performance Forum 18 26 May 2014 01:13 pm
Transmission problem? PTFORME Tech & Performance Forum 4 12 Aug 2010 04:55 pm
Transmission problem Geordie Tech & Performance Forum 4 05 Jul 2010 06:01 pm
Transmission problem Syl General PT Cruiser Discussions 4 20 Sep 2008 09:50 pm


All times are GMT -5. The time now is 06:38 am.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors