PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > 2.4L Turbo Forums > General Turbo Discussions

PT Cruiser Forum

Advertisements
Rough Idle!

 
Like Tree10Likes

Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 20 Oct 2019, 10:37 pm
rockandroller's Avatar
Obsessed Cruiser
 
Join Date: Feb 2013
Location: Western Canada! (Okanagan)
Posts: 8,608
Question Rough Idle!

Hmmm...

car was running fine, but when I took it in for oil change last week I had them put on new plugs and wires. Plugs were the 'new-style' iridium kind.

Drove it couple hundred miles on highway and it seemed fine. Did get a P0304 (misfire) code during the trip, but that reset OK. First ever misfire code, on this car...

Now ( past few days) I notice that it is running rough at idle. ( never noticed that before). I'm wondering it it could be due to the plugs?? Maybe I should go back to Champion copper??

Also, out on the highway last evening it threw a couple of new codes; one for power-steering sensor, and the other for oil pressure sensor. I have been getting 'spurious' oil pressure lightings for months now, on and off... often right after a car wash, so I suspect wiring harness issues. However, never an actual CODE for oil pressure sensor before! So maybe it's time to change out that oil pressure sensor ( and have the wiring looked at??)
P0522 Engine Oil Pressure Sensor/Switch Circuit Low Voltage
P0551 Power Steering Pressure Sensor Circuit Range/Performance

I reset, and haven't seen the codes since. (Drove around quite a bit today) Idle still does feel a little rough!

Just wondering if I should have them change out the plugs at the same time... what's the general sentiment on "plugs-vs-rough-idle??
__________________
2004 'Turbo Lite'

Last edited by rockandroller; 20 Oct 2019 at 10:52 pm.
Reply With Quote
  #2 (permalink)  
Old 21 Oct 2019, 07:52 am
Obsessed Cruiser
 
Join Date: Aug 2015
Location: Lake Wales, FL
Posts: 5,011
Default Re: Rough Idle!

Lots of arguments have developed over the whole spark plug recommendations and issues. Mopar has used Champion plugs for years. Every Mopar I ever owned up until about 2010 came with Champions. That's what I recommend using. OEM style plugs. I don't follow the trends and just stick to what I know works best. I ran my GT on Champions gapped at .042. As for the OPS and power steering, I don't know. I would go ahead and change both if they're throwing codes. But first, I'd check the wiring to both.
rockandroller likes this.
__________________


Aspire to inspire before you expire.
Reply With Quote
  #3 (permalink)  
Old 21 Oct 2019, 10:56 am
Fanatic Cruiser
 
Join Date: May 2016
Posts: 676
Default Re: Rough Idle!

If they didn't replace the intake gaskets, I'd suspect an intake leak for the rough idle.
Fk5 and Macgyverman1123 like this.
Reply With Quote
  #4 (permalink)  
Old 21 Oct 2019, 11:23 am
Fk5 Fk5 is offline
Senior Cruiser
 
Join Date: Jul 2011
Location: Colesville, MD
Posts: 1,883
Default Re: Rough Idle!

Quote:
Originally Posted by Grasshopper77 View Post
If they didn't replace the intake gaskets, I'd suspect an intake leak for the rough idle.
That was my first thought, which I was why I liked this post. I do not actually "like" intake gasket leaks. I thought this was an NA, but see now that I am in the turbo forum. The aluminium manifold turbos are notorious for blowing the gasket at #4. Check the manifold is torqued correctly.

Since you just had work done, the most likely culprits are the plenum gasket, plug wire, or plug. Check everything is seated correctly. On mine it turned out to be the lower gasket (intake to head) being blown out and blocking the injector port. That happened to at least one other poster - but it isn't likely here since the problem showed up right after the plug change and they probably removed the upper gasket for that.
__________________
2003 GT 5 speed
162,000 miles

Last edited by Fk5; 22 Oct 2019 at 08:54 am.
Reply With Quote
  #5 (permalink)  
Old 21 Oct 2019, 01:09 pm
rockandroller's Avatar
Obsessed Cruiser
 
Join Date: Feb 2013
Location: Western Canada! (Okanagan)
Posts: 8,608
Question Re: Rough Idle!

Thanks for the hints!

All this talk of gaskets seems odd, though... I have changed the plugs on this once myself (PIA, it was) and there was no need to remove the intake. Just extracted the plugs and replaced them (with help of some fuel line tubing, to get them back in place...) Do you think my mechanic would likely go to the trouble of pulling the intake manifold??
__________________
2004 'Turbo Lite'
Reply With Quote
  #6 (permalink)  
Old 21 Oct 2019, 01:49 pm
Fk5 Fk5 is offline
Senior Cruiser
 
Join Date: Jul 2011
Location: Colesville, MD
Posts: 1,883
Default Re: Rough Idle!

Quote:
Originally Posted by rockandroller View Post
Thanks for the hints!

All this talk of gaskets seems odd, though... I have changed the plugs on this once myself (PIA, it was) and there was no need to remove the intake. Just extracted the plugs and replaced them (with help of some fuel line tubing, to get them back in place...) Do you think my mechanic would likely go to the trouble of pulling the intake manifold??
I think "the book" calls for it.
__________________
2003 GT 5 speed
162,000 miles
Reply With Quote
  #7 (permalink)  
Old 21 Oct 2019, 08:35 pm
_PTGT03's Avatar
Fanatic Cruiser
 
Join Date: Oct 2015
Location: Abbotsford, British Columbia.
Posts: 787
Default Re: Rough Idle!

just install the oem style champion plugs for best results
LionPT and chuzz like this.
__________________
2003 GT M/T in Onyx Green Pearl on Michelin Pilot Sport AS 3 Plus Tires 205/50ZR17. Dark Slate Gray Interior. OEM cargo net, parcel shelf, slush mats and trunk protector, mud flaps, mopar subwoofer. Platinum edition pedals, Neon SX 2.0 steering wheel with black+grey wrapped leather cover. Generic lowering springs, KYB gas shocks, Valeo solid flywheel conversion and clutch kit. Urethane insert engine mounts. Energy suspension full body urethane bushing kit. Chrysler premium front speakers, Jenson 6x9 rears. Boston Audio 4x55W amp. Panasonic head unit with xtenzi bluetooth. 300W AC power inverter. Escort 360max and Escort Shifter ZR4, dual front+rear dash camera. stage 1 blow off valve and syked tune computer . Boost and oil pressure gauges with Turbo-Timer. Needswings 3" exhaust elbow, Electric valve actuated Y-pipe with catalytic converter. To do: coilovers, 2step controller, quaife diff, Air-Fuel Meter
Reply With Quote
  #8 (permalink)  
Old 22 Oct 2019, 08:12 am
Obsessed Cruiser
 
Join Date: Aug 2014
Location: Thousand Oaks, CA
Posts: 7,516
Default Re: Rough Idle!

Keep posting the diagnostics codes. Usually you get clues from the codes.
rockandroller likes this.
__________________
If at First You Don't Succeed - Try, Try Again
Reply With Quote
  #9 (permalink)  
Old 18 Jun 2020, 11:23 pm
rockandroller's Avatar
Obsessed Cruiser
 
Join Date: Feb 2013
Location: Western Canada! (Okanagan)
Posts: 8,608
Question Re: Rough Idle!

Hmmm. no codes, and the whole engine has practically been rebuilt but still the rough idle. Mechanic is perplexed, it 100% does not have any vacuum leaks - got new PCV, new manifold gasket, manifold has been "smoked" to check it...

And he seriously doubts it is a plug/wires issue, even though it only showed up after the plugs and wires were done (at my request, when it probably didn't need it!) at the last oil change

I wonder what is the "idle control valve"? ( was reading about it in some other idle threads...)

for context , last week it got a thorough going over for a few days:

Complete front brakes (rotors, pads, calipers, etc)
Timing Belt/water pump/ tensioner
Cam and crank seals
all three motor mounts
Radiator
rad hoses
power steering hoses
starter
crank sensor
some sensor wiring and connectors
some ground wires
pcv valve
intake and valve cover gaskets
misc shop supplies...

(but the rough idle persists)
__________________
2004 'Turbo Lite'

Last edited by rockandroller; 18 Jun 2020 at 11:25 pm.
Reply With Quote
  #10 (permalink)  
Old 19 Jun 2020, 12:03 am
Macgyverman1123's Avatar
Cool Cruiser
 
Join Date: Nov 2017
Location: Raleigh, N.C.
Posts: 303
Default Re: Rough Idle!

Pssst: Change your trans mount too. That, plus the other three will make your car feel brand new, take it from me
rockandroller likes this.
__________________
-John P.
Go Canes! #TakeWarning
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Stalls at idle. Sometimes. And rough idle scatgo1 Tech & Performance Forum 6 27 Nov 2014 11:04 am
Rough Idle-Replacing the IAC Idle Air Controller engineerrock Tech & Performance Forum 9 07 Jun 2014 07:24 pm
'07 PT - Rough Idle, rough acceleration, and shuts off if it idles for too long La_Bruja Tech & Performance Forum 3 09 Aug 2013 07:50 am
Rough idle with A/C -my fix argos587 Tech & Performance Forum 4 10 Oct 2011 11:13 am
Rough Idle, Rough @60, check engine light NEW Dystroy Tech & Performance Forum 8 12 Jan 2009 09:07 pm


All times are GMT -5. The time now is 10:21 am.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors