PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > General Forums > Interior Accessories Forum

PT Cruiser Forum

Advertisements
revelations shifter problem

 
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 03 Mar 2004, 12:28 am
Young Cruiser
 
Join Date: Feb 2004
Location: Boston, MA, USA.
Posts: 88
Default revelations shifter problem

i bought and installed the revel shifter (http://www.revelenterprises.com/pt_cruiser_ptknob03.htm)for my 2004 automatic Pt, problem is the button rattles in the socket!!! anyone know a quick fix? the sound is maddening!
Reply With Quote
  #2 (permalink)  
Old 03 Mar 2004, 12:34 am
Dedicated Cruiser
 
Join Date: Jan 2003
Location: Washington State, USA.
Posts: 2,525
Default

This seems to be a general problem with the product as others on this board have reported the same issue. I don't know if there is a fix but I'm sure if there is someone will post the information you need. Good luck.
Reply With Quote
  #3 (permalink)  
Old 03 Mar 2004, 12:45 am
Young Cruiser
 
Join Date: Feb 2004
Location: Boston, MA, USA.
Posts: 88
Default

i was thinking a little bit of teflon tape or electracal tape around the lower end ofthe button - but i am more afraid of it jamming or destroying the finish. has anyone had a problem with their other products?
__________________
Reply With Quote
  #4 (permalink)  
Old 03 Mar 2004, 02:58 am
Regular Cruiser
 
Join Date: Nov 2003
Location: edmonds, wa, USA.
Posts: 175
Default

i have bought a number of products from revel enterprises. have been very impressed with the quality of the items that they sell. everything that i have purchased has been top notch. i am planning to buy more from them in the future. also, great people to deal with--pleasant and fair. give them a buzz and let them know what is happening with their product. i am sure they would be very anxious to help you in your situation.

call 'em up, give them the opportunity to make it right.
03 GT
Reply With Quote
  #5 (permalink)  
Old 03 Mar 2004, 04:13 am
Fanatic Cruiser
 
Join Date: Dec 2002
Location: Livingston, TX, USA.
Posts: 764
Default

I agree with Redrum. I have had excellent dealings with Revel Enterprises. I have that same shift knob on my 03 GT and it has always worked like a champ.

Give them a call.
__________________

2003 Almond GT AutoStick, body colored rear splash guards and hood struts, chrome gear shift, AC & vent knobs, billet steering wheel spokes and pedals, AMX1397 Turbo-Intake Pipe.
Reply With Quote
  #6 (permalink)  
Old 08 Mar 2004, 04:26 pm
Young Cruiser
 
Join Date: Feb 2004
Location: Boston, MA, USA.
Posts: 88
Default

still waiting for their answer - however - is the button suppose to be so loose that it can be picked right up out of the handle with two fingers? i place the car in park and relized that the button slides right out - there is nothing to hold it in place!
__________________
Reply With Quote
  #7 (permalink)  
Old 08 Mar 2004, 09:39 pm
LAF LAF is offline
Cool Cruiser
 
Join Date: Aug 2003
Location: Harrisburg, PA, USA.
Posts: 295
Default

Legion that is the way mine is. It is fine. Sure it is rattling, not something else?
__________________
The recipe for perpetual ignorance is: be satisfied with your opinions and content with your knowledge.
Elbert Hubbard (1856 - 1915)

2003 Electric Blue GT-30,000 Miles on the clock
Stage 1, Greddy Profec II B. Turbo Chargers Wastegate set to 13#. Forge Motors BOV (Blue of course). Brand AMX Intake/AirCooler Pipes/K&N Cone with Snorkel to Fender well, MSD Coil, Live Wires(Blue of course), Factory rear sway bar, KYB struts and shocks, BTG strut tower brace, Suspension Techniques 1.3\" F/R lowering springs, ATP 3 down pipe with high flow cat, BTG axle back exhaust, Rear Spoiler. Russel Brake Lines/Hawk Brake Pads/Power Slot Cyro Rotors on a four corners

Support Your Right to Arm Bears
Reply With Quote
  #8 (permalink)  
Old 08 Mar 2004, 11:42 pm
Young Cruiser
 
Join Date: Feb 2004
Location: Boston, MA, USA.
Posts: 88
Default

i think i found the problem - the instructions mention a tension clip inside the button - there is no clip . . .
__________________
Reply With Quote
  #9 (permalink)  
Old 09 Mar 2004, 11:37 am
Hooligan's Avatar
Obsessed Cruiser
 
Join Date: Aug 2003
Posts: 6,023
Default

Call Revel and inform them that the clip was missing. I'm sure that they will send you the missing clip.
Reply With Quote
  #10 (permalink)  
Old 09 Mar 2004, 05:55 pm
Young Cruiser
 
Join Date: Feb 2004
Location: Boston, MA, USA.
Posts: 88
Default

actually - they are really cool - my new button with clip was sent out two days ago when i first had the problem with the button rattling - and sent them the first email. what a cool bunch! BTW their phone service is top notch!
__________________
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
I think I'm having a power steering problem! lumofny Tech & Performance Forum 5 18 Jan 2005 01:12 pm
Unknown RPM surge problem (manual) Ctown Tech & Performance Forum 4 26 Dec 2004 08:48 pm
Mopar Short-Throw Shifter Installed+Picture purplept Turbo Performance 62 21 Sep 2004 10:05 pm
Shifter and cable problems 2003 PT lonehorse Tech & Performance Forum 1 05 May 2004 02:55 pm
Turbo Autostick Shifter knob dfunkdj Exterior & Interior Styling 14 26 Apr 2004 09:35 pm


All times are GMT -5. The time now is 03:31 pm.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors