PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > General Forums > Members PT Project

PT Cruiser Forum

Advertisements
Something Very Different

 
Like Tree17Likes

Reply
 
LinkBack Thread Tools Display Modes
  #11 (permalink)  
Old 07 May 2017, 02:29 am
Regular Cruiser
 
Join Date: Sep 2016
Posts: 120
Default Re: Something Very Different

The reason I'm removing these things is partly because I think I have damaged my power steering by removing the hoses that connected to it, and the A/C I depressurized the whole system by accident and probably destroyed that as well, and I don't want to spend extra money fixing those things if I don't really need it.
Reply With Quote
  #12 (permalink)  
Old 10 Jul 2017, 12:10 pm
rob302's Avatar
Dedicated Cruiser
 
Join Date: Jul 2016
Location: Darien, IL | Forest Park, IL
Posts: 2,515
Default Re: Something Very Different



any updates on this??
Reply With Quote
  #13 (permalink)  
Old 10 Jul 2017, 02:46 pm
Gkon's Avatar
Senior Cruiser
 
Join Date: Jun 2015
Location: Queens, NY
Posts: 1,630
Default Re: Something Very Different

I'm digging it!
__________________
2002 PT Cruiser Limited, 2.4L, Automatic Transmission, Metallic Silver Paint
Reply With Quote
  #14 (permalink)  
Old 10 Jul 2017, 04:22 pm
Turbodude06's Avatar
Regular Cruiser
 
Join Date: Sep 2007
Location: Georgia
Posts: 150
Default Re: Something Very Different

This is my kinda build!!! Keep it up!!
Gkon likes this.
__________________


2004 PT GT 5-Speed! Project "THE RIDDLER"!!!
http://www.ptcruiserlinks.com/forum/...t-5-speed.html
Reply With Quote
  #15 (permalink)  
Old 10 Jul 2017, 11:43 pm
Regular Cruiser
 
Join Date: Sep 2016
Posts: 120
Default Re: Something Very Different

I'm sorry everybody, I got a job about a month and a half ago and i've been busy working on it and making money. Big update!

FMIC (Pain in the butt because Im using normal PT bumper)

LOVE.jpg

GT Wheels plasti-dip black.

k.jpg

I also got the wiring harness, still need a lot more. I need a transmission (either a Getrag 288 or a NVT350), ECU (preferably High Output), CV Axles, motor mounts, fluids, and lowering springs and front struts. I also have to replace some of the seals/gaskets on the engine and do my timing.
VsandFords and rob302 like this.
Reply With Quote
  #16 (permalink)  
Old 11 Jul 2017, 09:56 am
svtnos's Avatar
Regular Cruiser
 
Join Date: Nov 2016
Location: Almont MI
Posts: 138
Default Re: Something Very Different

so is this a turbo car or na??
__________________
2003 PT Cruiser limited edition
Reply With Quote
  #17 (permalink)  
Old 13 Jul 2017, 03:40 pm
Regular Cruiser
 
Join Date: Sep 2016
Posts: 120
Default Re: Something Very Different

It was an 01 N/A automatic and I'm swapping it to a turbo manual.

To get it low I used autozone helper springs. The spring rate on those were perfect for this.

IMG_6887.jpg
Reply With Quote
  #18 (permalink)  
Old 26 Sep 2017, 02:16 am
Regular Cruiser
 
Join Date: Sep 2016
Posts: 120
Default Re: Something Very Different

She's nearly done. Only problem now is that she won't start. No spark coming from the coils for some reason. Probably a bad crank position sensor. But no check engine light code for that. What other things could be stopping spark? She was driving around a week ago. Also need to get beefier axles and a better clutch. Stock used neon clutch is holding up surprisingly well. So far it has a mopar blow off plate, stage 1 injectors, and soon will have an AGP aftermarket wastegate. Many many more planned mods.


IMG_8281.jpg


Needs new wheels. Badly. Also want to paint my car white instead of taupe frost. That paired with black GT or Prowler front wheels would look amazing.
Handy_Cruiser likes this.
Reply With Quote
  #19 (permalink)  
Old 26 Sep 2017, 09:19 am
rob302's Avatar
Dedicated Cruiser
 
Join Date: Jul 2016
Location: Darien, IL | Forest Park, IL
Posts: 2,515
Default Re: Something Very Different

Quote:
Originally Posted by kcabe1 View Post
problem now is that she won't start. No spark coming from the coils for some reason. Probably a bad crank position sensor. But no check engine light code for that. What other things could be stopping spark? She was driving around a week ago..
i would think that your wiring and tinkering are the no-spark issue and would be best if you looked over what you've done since it last ran. IMO there's no reason a crank sensor would just decide to fail while parked. these are the hardest problems to advise a fix for. only you really know what you've touched in this case, what you've soldered, taped, tugged on, etc.
__________________
.

Last edited by rob302; 26 Sep 2017 at 09:21 am.
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -5. The time now is 10:02 am.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors