PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > Members List

PT Cruiser Forum

Advertisements
PTSantaCruz's Profile

 

PTSantaCruz PTSantaCruz is offline

Young Cruiser

Visitor Messages

Showing Visitor Messages 1 to 1 of 1
  1. Kayybayy5206
    19 Jul 2017 10:46 pm - permalink
    Kayybayy5206
    I have a 2006 pt cruiser. I recently was driving it and all a sudden the check engine came on it started bucking and I couldn't do past 20 MPR with my RPM going to 3 and 4. Well the codes said I put it in safety mode so I unhooked the battery cables and the rehooked them. It happened again. This time it read my can shaft sensor. So I changed that. Well the same thing happened again , so I unhooked my battery cables and now its okay. But in a couple days if not sooner the same thing will occur. Any ideas on what it could be. I changed my cam shaft sensor like it said bit it still happening. Could it be my 02 sensor?

About Me

  • About PTSantaCruz
    Biography
    I need to be in water to survive, Surfing,Diving, Swimming,Soaking.
    Location
    In a Dream never waking up
    Interests
    Right now PT Cruisers
    Occupation
    Handy Person at life
  • Signature
    Life is a Gas and we need to keep fueled up!

Statistics

Total Posts
Visitor Messages
General Information
  • Last Activity: 15 Jul 2017 11:19 am
  • Join Date: 06 Jan 2013
  • Referrals: 0

Friends

Showing Friends 1 to 1 of 1

All times are GMT -5. The time now is 03:49 am.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors