PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > Members List

PT Cruiser Forum

Advertisements
ptcruisersteve's Profile

 

ptcruisersteve ptcruisersteve is offline

Obsessed Cruiser

Visitor Messages

Showing Visitor Messages 1 to 6 of 6
  1. den458
    25 Mar 2020 01:03 pm - permalink
    den458
    Would you please look at my new post "2006 PT not getting fuel" ?
    Thanks in advance !
  2. Al2eKen
    24 Mar 2019 10:48 pm - permalink
    Al2eKen
    PTCruiserSteve,
    2002 PT Cruiser. Blue ground wire inside left front wheel well. What the devil is it supposed to be connected to? The wire on mine is grounded, but the other end is hanging free!??
    Problems with radiator fan not working. Thanks in advance!
    al2eken
  3. Shelby5041
    03 Nov 2017 09:16 am - permalink
    Shelby5041
    Hi steve here are some results from today


    I did some testing...high speed fan circuit

    I have 12v to pin 30 all time
    I have 12v to pin 85 ignition on
    I have continuity from pin 87 to radiator fan connector female end

    I know relay is good i swapped with horn and horn worked

    Any ideas?
  4. wolfeman461
    03 Jun 2017 09:26 pm - permalink
    wolfeman461
    Hoping that you might be able to help me please. I have no ground at the fuel pump connector plug at the top of the tank. Car will only run if I supply a ground to the ground wire there. I checked the body plug connection underneath the car below the tank. It looks clean inside with no corrosion. Then I completely reworked all of the body grounds at the left inner fender and all is good there. Sill will not run unless I supply a jumper ground at the pump connector to make the fuel pump run. I don't know where else to look for the bad faulty ground supply to the fuel pump? Can you help? Thank You.
  5. Knaller17
    19 Dec 2016 05:24 pm - permalink
    Knaller17
    ptcruisersteve,

    Thanks for the diagram of the charging system. The green must definitely go on top of the red !!! Thanks ptcruisersteve.
  6. Diyer
    29 Oct 2015 09:21 pm - permalink
    Diyer
    I am a diy'r.... I changed the camshaft sensor and there's still no spark what could it be plz any input is appreciated

About Me

  • About ptcruisersteve
    Biography
    Like working on cars
    Location
    Thousand Oaks, CA
    Interests
    Traveling
    Occupation
    Engineer
  • Signature
    If at First You Don't Succeed - Try, Try Again

Statistics

Total Posts
Visitor Messages
General Information
  • Last Activity: Yesterday 12:27 am
  • Join Date: 10 Aug 2014
  • Referrals: 1

Friends

Showing Friends 1 to 10 of 10

Likes Given

1527 Likes
  1. ptcruisersteve
  2. ptcruisersteve
    ptcruisersteve liked post by MJKnight On thread : 05 PT Turbo wide open misfire
  3. ptcruisersteve
    ptcruisersteve liked post by Busted_PT On thread : 05 PT Turbo wide open misfire
  4. ptcruisersteve
    ptcruisersteve liked post by Mealticket On thread : Anybody replaced airbag module?
  5. ptcruisersteve
  6. ptcruisersteve
    ptcruisersteve liked post by circus On thread : Goofy oil light
  7. ptcruisersteve
  8. ptcruisersteve
    ptcruisersteve liked post by LionPT On thread : Motor swap
    No...2001 has an EGR, some sensors in different places. Computer would receive error messages.
    Liked On: 30 Jan 2021, 07:42 pm
    Posted On: 30 Jan 2021, 06:09 pm
  9. ptcruisersteve
  10. ptcruisersteve
    ptcruisersteve liked post by PTloser32805 On thread : Crank sensor wiring again
  11. ptcruisersteve
  12. ptcruisersteve
    ptcruisersteve liked post by dougs On thread : Can I swap engine from different year?
    additional information: https://www.enginebuildermag.com/2007/03/rebuilding-the-chrysler-2-4l/
    Liked On: 08 Jan 2021, 03:49 pm
    Posted On: 08 Jan 2021, 12:05 pm
  13. ptcruisersteve
    ptcruisersteve liked post by LionPT On thread : Can I swap engine from different year?
  14. ptcruisersteve
    ptcruisersteve liked post by Handy_Cruiser On thread : Can I swap engine from different year?
  15. ptcruisersteve
    ptcruisersteve liked post by pdbrains On thread : Does the odometer advance when being flat towed?

All times are GMT -5. The time now is 06:12 am.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2021, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors