PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > Members List

PT Cruiser Forum

Advertisements
GrantGaines's Profile

 

GrantGaines GrantGaines is offline

Fresh Cruiser

Visitor Messages

Showing Visitor Messages 1 to 1 of 1
  1. GrantGaines
    09 Mar 2015 11:26 am - permalink
    GrantGaines
    Okay. So I am new to forums and had no idea how they work. So if I am not posting right just let me know. But okay. I own an 05 pt cruiser gt with 130,000 miles. Single straight piped from the catalytic back. The problem has been going on for about three months now. At idle it will drop down to around 700rpm and sound like it will die and then will surge to just above 1000. I had it floored one time last week in 4th and it would not go above 60mph. It also backfires when I try to downshift and hit my powerband. This last summer it got new plugs, wires, and coil pack. Since this problem started I have replaced the camshaft sensor, checked timing, checks all vacuum lines, EGR valve, and no codes pop up. The other day I pulled the spark plug wire from cilynder 1 and it was idling better. Tht same day I put a quart of oil in and the cel went away and was a lot better, but then it came back like 20 minutes later. I have started to give up so any help woul be appreciated.

Statistics

Total Posts
Albums
Visitor Messages
General Information
  • Last Activity: 24 Jun 2017 08:03 am
  • Join Date: 04 Mar 2015
  • Referrals: 0

All times are GMT -5. The time now is 11:28 pm.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors