PT Cruiser Forum  

Go Back   PT Cruiser Forum > Members List

PT Cruiser Forum

NitroPT's Profile


NitroPT NitroPT is offline

Obsessed Cruiser

Visitor Messages

Showing Visitor Messages 11 to 20 of 50
  1. Danny7627
    15 Oct 2016 06:33 pm - permalink
    Hi Lynn,
    Just a quick update. I replaced the plugs (champion copper +), manifold intake gaskets (Plastic) ( Fel-Pro MS93219) valve cover gasket and still was pushing a misfire code. After studying the fuel injectors, I resolved that replacing them was beyond my skill set.

    Long story short, I purchased all 4 injectors and had my mechanic do the install. Labor $180.00. Code gone and the car runs great again.
  2. Danny7627
    09 Sep 2016 09:31 am - permalink
    Hey Lynn, I was wondering if you can clarify a part number for me. I am looking to replace the intake manifold upper/lower gaskets on 08 turbo-lite. I am getting conflicting part numbers from Felpro. Could you please tell me which one is correct for the turbo engine. Fel-Pro MS 96198 or MS-93219. I have the plastic manifold...confused lol
    Thanks dan
  3. Soulman
    23 Feb 2016 08:13 pm - permalink
    Hello my question has nothing to do with your thread although i totally enjoy it. I have a 2003 PT GT turbo auto and i might be in the market to replace the motor. Ive found a perfect 2006 (G) LKQ motor with 92'000 that i can get and wanted to know if they are compatible and will swap out no problem. Of course before having the motor installed i will have the timing belt,water pump and idler pulleys replaced,Thanks in advance Larry
  4. MJB_LBC
    22 Feb 2016 01:16 pm - permalink
    Hello Nitro, here is a link to my post, some of the members thought it would be a good idea to contact you directly. Wondering if I need a new ECU in order to get smogged in CA
  5. Pluce
    30 Oct 2015 09:44 am - permalink
    Hello NitroPT,
    New to the Forum...My name is Paul and I got 03 GT with a stage 1 kit.
    It will not do the Catalyst code clear, showing 1 Inc. left. Just put in a new turbo and mechanic said to "drive it until the Inc. clears"...well I got 500 miles since the turbo and I am wondering what to do to pass CA smog. 02 sensor upstream was replaced after turbo job, but not downstream. No engine lights on...just that last Inc. Can anyone help?...Downstream 02? Reset?
    Big Thanks in Advance!

    From Busted PT... Forget all. You said stage 1. That's your answer. Stage 1 disables the down stream sensor. Talk to NitroPT. But I think you have to go back to stock GT PCM. he is in Ca. too.

    Can you can call me at 559-676-0007 in central CA or PM, or email!
  6. chuzz
    26 Sep 2015 11:38 am - permalink
    Hey, Lynn here's a youtube link for the latest video.
  7. NitroPT
    25 Aug 2015 11:27 am - permalink
  8. ToniB
    08 Jul 2015 12:49 pm - permalink
    I'm sorry but I'm new to this site and I'm having issues with my car. How do I post in the forum?
  9. NitroPT
    20 Jun 2015 01:27 pm - permalink
    PM sent
  10. CruisingCalifornia
    20 Jun 2015 01:20 pm - permalink
    Hello NitroPT
    Thanks for the welcome.Can you help with a problem with my 06 PT turbo?
    I've noticed numerous complaints on overheating. Well my also runs hot at idle
    I've replaced the relays and bought a new fan assembly but the fan still won't come
    on. What else can I check? Any help will be appreciated.

About Me

  • About NitroPT
    USA kalyfornia
    Trains,planes and automobiles
    keeping wife happy
  • Signature

    Dalai Lama
    "Share you knowledge. It's the best way to achieve immortality."


Total Posts
Visitor Messages
General Information
  • Last Activity: Today 04:57 pm
  • Join Date: 24 Jun 2012
  • Referrals: 3


Showing Friends 1 to 10 of 84

All times are GMT -5. The time now is 07:44 pm.

Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.