PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > Regional Forums > Northwest PT Forum

PT Cruiser Forum

Advertisements
First Post

 
Closed Thread
 
LinkBack Thread Tools Display Modes
  #21 (permalink)  
Old 01 Jan 2004, 04:10 pm
Cool Cruiser
 
Join Date: Jun 2003
Location: .
Posts: 224
Default

Hello everyone from the NW, and Happy New Year too all.. Kevin here from Beaverton Or.. 2002 Touring Model.. Taupe Frost Metallic Brown.. Riding on Air..
  #22 (permalink)  
Old 01 Jan 2004, 04:30 pm
Dedicated Cruiser
 
Join Date: Jan 2003
Location: Washington State, USA.
Posts: 2,525
Default

Welcome to the forum, kevinl1058. Happy New Year to you and all Northwest fellow cruisers. [^]
  #23 (permalink)  
Old 01 Jan 2004, 07:54 pm
Regular Cruiser
 
Join Date: May 2002
Location: Hillsboro, Oregon, USA.
Posts: 157
Send a message via AIM to ZZRain
Default

Hello Kevin !! PT looks great my friend !! How did Cliff do on the paint job ? Hope to see you more this year !!! Happy New Year 2004 !!
__________________
  #24 (permalink)  
Old 02 Jan 2004, 04:49 pm
Cool Cruiser
 
Join Date: Jun 2003
Location: .
Posts: 224
Default

Hey Rick, Happy New Year
They did an good job, I have to take it back next Sat the 10th to get the final cut and buff done.. also found a run that he'll have to take care of.. So after that work is done I'll being saying great job
  #25 (permalink)  
Old 28 Feb 2004, 03:49 pm
Fresh Cruiser
 
Join Date: Feb 2004
Location: Seattle, WA, USA.
Posts: 13
Default

I couldn't resist putting my two cents (sense?) worth in. Hi everyone, Michael here from Puget Sound Cruisers. I'm not quite sure I get the point of this forum, but who cares . . . HOWDY!
__________________

<font color=\"red\">Sleighboy\'s 2003 GT</font id=\"red\"> - More pics: http://ptcw.truckmoxie.com/mygallery.ten?id=3569

<i>\"My life has been the poem I would have writ, But I could not both live and utter it.\"</i> Thoreau

<font color=\"blue\">Puget Sound Cruisers:</font id=\"blue\"> www.pugetsoundcruisers.org - <font color=\"red\">Santa\'s site:</font id=\"red\"> www.HoHoHoCo.com
  #26 (permalink)  
Old 29 Feb 2004, 05:03 pm
Dedicated Cruiser
 
Join Date: Jan 2003
Location: Washington State, USA.
Posts: 2,525
Default

Quote:
quote:Originally posted by Sleighboy

...I'm not quite sure I get the point of this forum, but who cares . . . HOWDY!
HOWDY back to you, Mike. The regional forums are intended to give one a "local perspective" of the PT events/activities/forum members in various parts of the country. BTW, there are also several others on this board who are members of the Puget Sound Cruisers. [8D]

Happy CruzN [^] in your "GT TURBO SLEIGH"... [8)]


  #27 (permalink)  
Old 26 Nov 2014, 07:18 pm
Fresh Cruiser
 
Join Date: Nov 2014
Posts: 1
Question Re: First Post

I have a 2004 PT with only 75,000 miles, and I want to cry because my coolant started "bleeding out" a short time ago. I added to the reservoir and watched for loss on the concrete but there was maybe just a bit. Probably from when I overfilled it. I thought a small amount of stop leak would find the small leak and fix it. The very next day my check engine light came on and it started misfiring. This is looking more and more to me like a head gasket since the coolant still seems to keep disappearing. I KNOW this is a VERY expensive repair and I could probably do it but it would take two weeks that I don't have to spare the vehicle. Can someone tell me I am wrong and suggest another repair?

I am taking a chiding from my wife because I told her when we bought it that the PT would outlast the avenger and her avenger is at 175K without a problem.

Dodge lover
Artey Z
arteyz@outlook.com
  #28 (permalink)  
Old 26 Nov 2014, 08:01 pm
Busted_PT's Avatar
Obsessed Cruiser
 
Join Date: Jan 2012
Location: Beckley, W.V.
Posts: 13,904
Default Re: First Post

Quote:
Originally Posted by Arteyz View Post
I have a 2004 PT with only 75,000 miles, and I want to cry because my coolant started "bleeding out" a short time ago. I added to the reservoir and watched for loss on the concrete but there was maybe just a bit. Probably from when I overfilled it. I thought a small amount of stop leak would find the small leak and fix it. The very next day my check engine light came on and it started misfiring. This is looking more and more to me like a head gasket since the coolant still seems to keep disappearing. I KNOW this is a VERY expensive repair and I could probably do it but it would take two weeks that I don't have to spare the vehicle. Can someone tell me I am wrong and suggest another repair?

I am taking a chiding from my wife because I told her when we bought it that the PT would outlast the avenger and her avenger is at 175K without a problem.

Dodge lover
Artey Z
arteyz@outlook.com
Your going to need to start a thread of your own. This one went dead in 04. We will need all the details plus the code for the engine lite you mentioned. Introduce yourself in the new members thread and tell us some about you and your PT.
__________________

03 Dream stock___________________________ 04 Touring turbo lite stock_________ 02 Touring stock_____________________ The "Three Amigos"
__________________________________________________ __________________________________________________ ___________Performance, Body and Service, OEM

This Is my project page.
http://www.ptcruiserlinks.com/forum/...oject-1-a.html

This is a great read from one of our own! Badglas
badglas.blogspot.com
  #29 (permalink)  
Old 26 Nov 2014, 09:11 pm
Obsessed Cruiser
 
Join Date: Sep 2001
Posts: 27,758
Default Re: First Post

Closed Thread


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
post a PIC? 1lowufo Feedback and Support 6 08 Jul 2007 11:58 am
Trying to post pics Ed Lim Testing 7 30 Jul 2004 04:16 pm
Got a yellow post card PTCumming Stage Turbo Kits 14 29 Apr 2004 06:58 pm
Test Post DC II 439 Testing 1 26 Mar 2003 12:20 pm
"Touring" edition/ please post turbomangt General PT Cruiser Discussions 1 13 Feb 2003 05:48 pm


All times are GMT -5. The time now is 02:14 pm.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2021, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors