PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > General Forums > PT Cruiser Convertible Forum

PT Cruiser Forum

Advertisements
Help!!!

 
Like Tree2Likes

Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 22 Aug 2014, 05:44 pm
Fresh Cruiser
 
Join Date: Aug 2014
Location: ohio
Posts: 6
Default Help!!!

My Pt recently started randomly going into limp mode. Diagnoses showed 7 different codes, one which was the TCM. Taking it upon myself, I assumed Tcm is to blame for the other codes. I changed the TCM with a used one check engine went off all of maybe 5 minutes and bow is back in limp mode! Is there a way to tell if the wiring harness is bad? I have another one but don't wanna cut on it until I know for sure. And does anyone have a diagram of exactly what those wires do that go to the TCM? Thank you in advance if you reply.
Reply With Quote
  #2 (permalink)  
Old 22 Aug 2014, 06:12 pm
KA9VQF's Avatar
Cool Cruiser
 
Join Date: Jul 2014
Location: Savanna Illinois
Posts: 460
Default Re: Help!!!

Believe it or not it would help a lot if you could list the codes.

There are a whole bunch of things that the TCM controls and monitors. The various sensors and controllers report to the TCM and it generates the codes to be displayed on the code scanner for the various things that may be going wrong.

Without the codes anyone would just be guessing what might actually be wrong with your buggy.
boonie2 likes this.
Reply With Quote
  #3 (permalink)  
Old 22 Aug 2014, 06:26 pm
Fresh Cruiser
 
Join Date: Aug 2014
Location: ohio
Posts: 6
Default Re: Help!!!

Sorry I forgot to mention the codes........first was the tcm code 0700, next it says it's code 07 31and it says the gear ratio error in first gear. That the input rpm doesn't match the output rpm. Next is 0715 input speed sensor changed suddenly probable cause poor electrical connection. Also code p 1782 2to4 pressure switch circuit. No explanation for that. Plus there were a few mis fires on cylinder 1.
Reply With Quote
  #4 (permalink)  
Old 22 Aug 2014, 06:31 pm
cruserdad1976's Avatar
Obsessed Cruiser
 
Join Date: Sep 2009
Location: st james mo
Posts: 8,217
Default Re: Help!!!

i dont think you can just swap Tcm's dont they have to be flasjed to your car?????
Reply With Quote
  #5 (permalink)  
Old 22 Aug 2014, 06:35 pm
Fresh Cruiser
 
Join Date: Aug 2014
Location: ohio
Posts: 6
Default Re: Help!!!

I've had conflicting stories on flashing. I've heard yes you have to and no you don't. This tcm came from an existing pt same yr etc. I called A1 transmission they said its a plug and play that it don't need flashed. So I dunno.
Reply With Quote
  #6 (permalink)  
Old 22 Aug 2014, 06:40 pm
cruserdad1976's Avatar
Obsessed Cruiser
 
Join Date: Sep 2009
Location: st james mo
Posts: 8,217
Default Re: Help!!!

I dont knwo either some say when you drain your tranny it has to relearn but i dont think mine ever did so its all a mistery to me I just know some have said thats what they did--i do thinik it setts you millage and stuff to your car
Reply With Quote
  #7 (permalink)  
Old 22 Aug 2014, 06:45 pm
Fresh Cruiser
 
Join Date: Aug 2014
Location: ohio
Posts: 6
Default Re: Help!!!

I dunno either, actually I didn't even know that set my mileage lol.so you told me a New one. I do know that it's random and before the light kicked back on this last time it was shifting really hard into second gear.
Reply With Quote
  #8 (permalink)  
Old 22 Aug 2014, 07:42 pm
Busted_PT's Avatar
Obsessed Cruiser
 
Join Date: Jan 2012
Location: Beckley, W.V.
Posts: 13,891
Default Re: Help!!!

Quote:
Originally Posted by liltimmy View Post
Sorry I forgot to mention the codes........first was the tcm code 0700, next it says it's code 07 31and it says the gear ratio error in first gear. That the input rpm doesn't match the output rpm. Next is 0715 input speed sensor changed suddenly probable cause poor electrical connection. Also code p 1782 2to4 pressure switch circuit. No explanation for that. Plus there were a few mis fires on cylinder 1.
Check the speed sensors. May need to replace there are two sensors.
__________________

03 Dream stock___________________________ 04 Touring turbo lite stock_________ 02 Touring stock_____________________ The "Three Amigos"
__________________________________________________ __________________________________________________ ___________Performance, Body and Service, OEM

This Is my project page.
http://www.ptcruiserlinks.com/forum/...oject-1-a.html

This is a great read from one of our own! Badglas
badglas.blogspot.com
Reply With Quote
  #9 (permalink)  
Old 22 Aug 2014, 08:00 pm
Fresh Cruiser
 
Join Date: Aug 2014
Location: ohio
Posts: 6
Default Re: Help!!!

Thank you I will check them next. I just know that if the tcm is bad it will cause all the other sensors to read false. I know the wiring harness inside the wires are black frosted like something burnt. I just don't wanna start cutting the wires until I what wire is what because there are different wires the same color.
Reply With Quote
  #10 (permalink)  
Old 25 Aug 2014, 05:26 pm
Cool Cruiser
 
Join Date: Jun 2009
Posts: 342
Default Re: Help!!!

one of the speed sensors is not reading right, it can cause a bunch of codes,
espesicly if you swap the tcm,,
Speed sensors,
ohh and make sure your battery gound is good and clean,
liltimmy likes this.
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -5. The time now is 02:55 pm.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors