PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > General Forums > PT Cruiser Convertible Forum

PT Cruiser Forum

Advertisements
Washed the engine...now car won't start

 
Like Tree2Likes
  • 1 Post By kpl1228
  • 1 Post By Handy_Cruiser

Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 18 May 2015, 06:52 pm
Fresh Cruiser
 
Join Date: Dec 2012
Posts: 34
Default Washed the engine...now car won't start

Was at the self-serve car wash, and put it on "engine cleaner."
Guess i shouldn't have.
I was careful not to spray directly on electrical components, and I rinsed it thoroughly afterward. And it started right up and I drove it for an hour home in warm weather. Even stopped once at the store on the way home and it started again immediately.
But this morning, it wouldn't turn over, though it seemed to have lots of battery juice to try. Left the hood up all day for it to get sun and dry out in my driveway. Tried it two or three times when i got home today, and now it just clicks like it's a bad starter.
Is that what it is? I hope that's all. Battery's about 5 years old BTW. The newer OEM starter's about a year and half old that I replaced myself. Original alternator and wiring though.
Handy_Cruiser likes this.
__________________
2005 PT Cruiser Convertible, base model/nonturbo, 105K miles (second engine), 165K miles on the vehicle
New Mexico

Last edited by kpl1228; 18 May 2015 at 07:02 pm.
Reply With Quote
  #2 (permalink)  
Old 18 May 2015, 07:36 pm
Regular Cruiser
 
Join Date: Aug 2013
Location: Az
Posts: 169
Default Re: Washed the engine...now car won't start

Easey to replace battery five years is putting it at its end of life
Reply With Quote
  #3 (permalink)  
Old 19 May 2015, 09:35 am
Handy_Cruiser's Avatar
Obsessed Cruiser
 
Join Date: Oct 2013
Location: Arkansas
Posts: 10,410
Default Re: Washed the engine...now car won't start

Remove the battery. Take it to some place like Autozone where they will charge it for free. Then have them load test it. While the battery is charging, clean all the battery connections really well. Also, remove the cover on the fuse/relay box under the hood and let it dry out if it needs too. You might use compressed air to blow it out if it is wet inside.

If your battery tests good, reinstall and try it. There's a good chance your engine will start then.
__________________
Reply With Quote
  #4 (permalink)  
Old 19 May 2015, 09:53 am
Obsessed Cruiser
 
Join Date: Aug 2014
Location: Thousand Oaks, CA
Posts: 7,332
Default Re: Washed the engine...now car won't start

Does your interior lights, headlights, tail lights, and radio work?
You might want to check all your ground wires including the ones on the inside drivers fender. Make sure they are making good contact.
Reply With Quote
  #5 (permalink)  
Old 19 May 2015, 09:16 pm
mopar1cjh's Avatar
Cool Cruiser
 
Join Date: Oct 2008
Location: Minot, ND
Posts: 279
Default Re: Washed the engine...now car won't start

Sounds like a battery to me, or a connection. It will click when the battery goes dead.
__________________
MOPAR OR NO CAR!
2005 CL Vanilla Touring Edition Convertible 2.4L Turbo Auto
K & N Drop In, MSD 8.5 MM Wires, Hood Scoops, MOPAR Rear Spoiler, Aeroforce Interceptor Dual Scan Gauge, MOPAR Stage 1 Upgrade, AMX Intake Pipe, 225/50/16 Cooper Zeon RS3-A Tires on MB 16 X 7 Alpina Rims with MOPAR logo, Power Slot Rotors, Hawk HPS Pads, Air Box Oil Catch Can, GTS Head Light Covers, Cover Craft Front End Mask. "Coming Soon" AMX Intercooler Pipes, B Woody Mounts, Strut Bar, MOPAR Ground Effects Kit, Gold Line 2" Lowering Springs, KYB G2 Struts & Shocks, GT Instrument Cluster, Auto Stick Conversion
My Other Rides:
1971 Plymouth Roadrunner 340 Auto Sassy Grass Green Numbers Matching with Air Grabber
2003 Dodge Dakota Quad Cab 4X4 4.7L Auto Flame Red Stage 1 Jet Performance Chip, K & N
2004 Jeep Grand Cherokee Freedom Edition 4X4 4.0L Auto Inferno Red
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
washed rings? clffkirts Tech & Performance Forum 7 05 Jun 2015 08:25 pm
Engine will not start decoyboy Tech & Performance Forum 6 15 Mar 2012 09:02 pm
Engine start button careyk General PT Cruiser Discussions 13 26 Aug 2008 08:45 pm
Washed the inside of the taillights too! zzzhuh General PT Cruiser Discussions 10 28 Jan 2006 05:56 pm
I just washed my car...forgive me cruisergeo The Detail Shop 6 19 Feb 2004 01:51 pm


All times are GMT -5. The time now is 04:39 am.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors