PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > Search Forums

PT Cruiser Forum

Advertisements
Search Results

 
Showing results 1 to 25 of 500
Search took 0.04 seconds.
Search: Posts Made By: ptcruisersteve
Forum: General PT Cruiser Discussions Today, 05:11 pm
Replies: 8
Views: 119
Posted By ptcruisersteve
Re: Stalling and Creaking Noises

I see you have a 2008 with turbo. One member had his Pt Cruiser with turbo stalling with no codes and was told it had something to do with overboost. Mechanic thought it might be the waste gate...
Forum: General PT Cruiser Discussions Yesterday, 10:32 pm
Replies: 8
Views: 119
Posted By ptcruisersteve
Re: Stalling and Creaking Noises

Does your Pt Cruiser have the turbo?
Forum: Tech & Performance Forum 12 Feb 2019, 02:07 am
Replies: 23
Views: 495
Posted By ptcruisersteve
Re: no start

All the spark plugs fouled at the same time not triggering misfire codes?

In my opinion there is missing information that the dealer is not disclosing.
Forum: Tech & Performance Forum 11 Feb 2019, 08:55 pm
Replies: 23
Views: 495
Posted By ptcruisersteve
Re: no start

Carl48
I got the same feedback when I took one of my Pt Cruisers in to the dealer under warranty. I had to go back to the dealer for several days before they gave up, asked the tech that worked...
Forum: General PT Cruiser Discussions 09 Feb 2019, 01:13 am
Replies: 12
Views: 283
Posted By ptcruisersteve
Re: Random Electrical Glitches

I would suggest checking the 7 ground wires attached to the drivers inner side fender. Sometimes they corrode and you can't see it until you take the 7 ground wires apart.

If the ground wires...
Forum: Tech & Performance Forum 06 Feb 2019, 10:42 pm
Replies: 23
Views: 495
Posted By ptcruisersteve
Re: no start

Carl48
Were you able to find out what was causing the issue?
Forum: Tech & Performance Forum 03 Feb 2019, 10:23 pm
Replies: 23
Views: 495
Posted By ptcruisersteve
Re: no start

I would suggest checking all the ground wires especially the 7 ground wires going to the driver's side inner fender (2) of them goes to the PCM. The group of ground wires have been know to corrode...
Forum: Tech & Performance Forum 02 Feb 2019, 09:53 pm
Replies: 23
Views: 495
Posted By ptcruisersteve
Re: no start

What year is your Pt Cruiser?

If you have the second generation Pt Cruiser with the TIPM it is possible that your TCM is not getting enough voltage triggering your P0700 code.

Have you tried...
Forum: Tech & Performance Forum 02 Feb 2019, 06:23 pm
Replies: 23
Views: 495
Posted By ptcruisersteve
Re: no start

I would suggest a battery load test. Batteries can go bad anytime. Make sure battery cables and connections are good.

If you have a voltmeter check to see what the voltage is when starting it.
Forum: General PT Cruiser Discussions 28 Jan 2019, 03:31 am
Replies: 4
Views: 211
Posted By ptcruisersteve
Re: Camshaft Seal at sensor

P0340 - No Camshaft Position Sensor Circuit Failure Conditions:

Possible Causes:

1. Camshaft Position Sensor connector is damaged, open or it is shorted
2. Camshaft Position Sensor signal...
Forum: Tech & Performance Forum 26 Jan 2019, 02:27 am
Replies: 11
Views: 252
Posted By ptcruisersteve
Re: bad fuel?

Hi Cat22
Are you sure your 2nd Mopar Camshaft Sensor was bad? I have 116K on my 2nd Mopar camshaft sensor. I would suggest you check the wiring or the contacts going to your camshaft sensor...
Forum: General Turbo Discussions 22 Jan 2019, 12:50 pm
Replies: 5
Views: 298
Posted By ptcruisersteve
Re: won't crank when hot 2003 turbo

Without further details good luck with solving your problem. If you want some ideas you are going to have to let us know if you have 12 volts going to the starter to begin with.
Forum: Interior Accessories Forum 17 Jan 2019, 02:09 am
Replies: 11
Views: 288
Posted By ptcruisersteve
Re: Weird Seat Belt Issue This Afternoon

That seems to happen when the Pt Cruisers gets over 10 years old. It wouldn't surprise me if Chrysler manufacture designed it that way so people would out and buy a new Chrysler. As NitroPT mentioned...
Forum: Tech & Performance Forum 13 Jan 2019, 11:58 pm
Replies: 16
Views: 344
Posted By ptcruisersteve
Re: quick question regarding valve cover gasket

I am very fortunate that I have never had to take my vehicles to the dealer or a mechanic shop unless it is under warranty which is very rare.

I wish there had been a mandatory mechanic shop...
Forum: Tech & Performance Forum 13 Jan 2019, 05:50 pm
Replies: 9
Views: 184
Posted By ptcruisersteve
Re: Car died on Highway - code 1391

All the spark plugs needs to be removed before you can get an accurate reading on the engine compression. Make sure the throttle is wide open and your battery is fully charged.

It also wouldn't...
Forum: Tech & Performance Forum 13 Jan 2019, 03:36 pm
Replies: 15
Views: 493
Posted By ptcruisersteve
Re: emergency!

Do you full your gas tank with premium gas?
Forum: Tech & Performance Forum 13 Jan 2019, 01:36 pm
Replies: 21
Views: 356
Posted By ptcruisersteve
Re: How much......?

Have you considered doing the key dance to find out what the engine trouble code is if you don't have an OBDII Scan Tool? You could go to most auto parts stores where they will give you the code...
Forum: Tech & Performance Forum 13 Jan 2019, 01:07 pm
Replies: 12
Views: 314
Posted By ptcruisersteve
Re: What causes limp mode?

It would indicate that the transmission range sensor might be working properly if the back reverse lights come on when you put it in reverse and the problem might be something else. Post what you...
Forum: Tech & Performance Forum 13 Jan 2019, 01:00 pm
Replies: 15
Views: 493
Posted By ptcruisersteve
Re: emergency!

You might want to check the wiring and contact going to the fuel injector for cylinder 3. If that is okay some members have solved the problem by using some Techron fuel injection cleaner that is...
Forum: Tech & Performance Forum 12 Jan 2019, 02:41 pm
Replies: 12
Views: 314
Posted By ptcruisersteve
Re: What causes limp mode?

I met where you get out of the Pt Cruiser and see if the reverse lights are on on the back of the Pt Cruiser.
Forum: Tech & Performance Forum 12 Jan 2019, 02:30 pm
Replies: 9
Views: 184
Posted By ptcruisersteve
Re: Car died on Highway - code 1391

Make sure the clip holding up the crankshaft wire harness did not break allowing the wire harness to run on the half shaft shorting out wires. This has been happening to other members on the 2001 PT...
Forum: Tech & Performance Forum 11 Jan 2019, 06:05 pm
Replies: 15
Views: 493
Posted By ptcruisersteve
Re: emergency!

If you get the engine running check to see if you are getting around 14 volts with it running.

If the charging system is good then have a battery load test done. Good luck.
Forum: Tech & Performance Forum 11 Jan 2019, 10:21 am
Replies: 12
Views: 314
Posted By ptcruisersteve
Re: What causes limp mode?

When all the PRNDL lights up on the dash does the reverse lights still light up if you put it in reverse?
Forum: Wheels, Tires, Suspension 10 Jan 2019, 09:10 pm
Replies: 13
Views: 289
Posted By ptcruisersteve
Re: Anyone ever get a tire warrantied?

I never get the warranty. My tires always rot out before they go bad. Because of members on this forum I now buy my tires that are only 6 months old or less. Hope my tires last longer than 70,000...
Forum: Tech & Performance Forum 10 Jan 2019, 07:16 pm
Replies: 12
Views: 314
Posted By ptcruisersteve
Re: What causes limp mode?

How soon after replacing the timing belt did the limp mode start?
Showing results 1 to 25 of 500

 
Forum Jump

All times are GMT -5. The time now is 09:54 pm.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors