PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > General Forums > Sound and Security Forum

PT Cruiser Forum

Advertisements
Horn not working, Fuses not blown... 2008 pt cruiser LX

 
Like Tree1Likes

Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 24 Jun 2010, 02:48 pm
Fresh Cruiser
 
Join Date: Dec 2008
Location: Texas,
Posts: 46
Default Horn not working, Fuses not blown... 2008 pt cruiser LX

Okay, so my horn isnt working now.
I checked the fuses, nothing is blown.
when i put key in, horn doesnt work, key out, still doesnt work
with car turned on etc.

panic button on key.. i turn it on, only lights flash no horn.
when unlocking/locking door no beep sound.

im having a tough time finding the relay for the horn.
theres nothing in the manual for the relay for horn.....
im pissed off, cus without horn i cant pass safety inspection.
does anyone know what i can do?
or where relay is? thanks!!
Reply With Quote
  #2 (permalink)  
Old 24 Jun 2010, 03:32 pm
chigger_ns's Avatar
Cool Cruiser
 
Join Date: May 2010
Posts: 278
Default Re: Horn not working, Fuses not blown... 2008 pt cruiser LX

Check to see if the horn itself is getting power when you press the button.
If you have power there when its pressed then you need a new horn.
If you dont have power see if the relay is getting power.{find it first}
__________________
2001 PT 5 speed Touring Edition
Eibach Pro Springs, Energy Suspension HyperFlex Master Kit bushings, 17" RTX Euro wheels, K&N drop in air filter, MotoMaster flat plate AGM battery, KYB GR2 shocks and struts, Booger standard shifter bushings, Ooogah horn.
Reply With Quote
  #3 (permalink)  
Old 24 Jun 2010, 05:29 pm
Fresh Cruiser
 
Join Date: Dec 2008
Location: Texas,
Posts: 46
Default Re: Horn not working, Fuses not blown... 2008 pt cruiser LX

I can't find it.
Reply With Quote
  #4 (permalink)  
Old 04 Jul 2010, 01:28 pm
Fresh Cruiser
 
Join Date: Dec 2008
Location: Texas,
Posts: 46
Default Re: Horn not working, Fuses not blown... 2008 pt cruiser LX

okay, i printed out a sheet for 06 07 and 08 pt cruiser to find the relay/fuse

but it doesnt match or make sense.

is there another fuse box ?
Reply With Quote
  #5 (permalink)  
Old 04 Jul 2010, 01:43 pm
Obsessed Cruiser
 
Join Date: Sep 2001
Posts: 27,744
Default Re: Horn not working, Fuses not blown... 2008 pt cruiser LX

There doesn't seem to be a separate horn fuse in the PDC (Power Distribution Center - which took the place of the 2 fuse boxes in the 00-05 models).


Your problem might just be in the horn electrical connector (in the steering wheel - see pic) or the horn itself which is under the inner fender in the passenger side wheel well.

__________________
Rules of the forum have been updated as of *07/07/2019* Please read them over.

- All decisions by the Moderator are semi-permanent, can and may be changed at his discretion but definitely will be the final word. Any action performed by the Administrator or Moderators are not to be discussed on the forum.
Reply With Quote
  #6 (permalink)  
Old 06 Jul 2010, 08:46 am
quicksilverdon's Avatar
Obsessed Cruiser
 
Join Date: Nov 2003
Location: Felton, Delaware
Posts: 20,501
Default Re: Horn not working, Fuses not blown... 2008 pt cruiser LX

Quote:
Originally Posted by chigger_ns View Post
Check to see if the horn itself is getting power when you press the button.
If you have power there when its pressed then you need a new horn.
If you dont have power see if the relay is getting power.{find it first}
Sums it up. And, if relay isn't getting power, then it's the switch in the steering wheel....
__________________
"Anti-intellectualism has been a constant thread winding its way through our political and cultural life,
nurtured by the false notion that democracy means that 'my ignorance is just as good as your knowledge."
Isaac Asimov"

'05 Limited Turbo Lite, (Silver, of course)4-wheel ABS, Sunroof, Spoiler. Mods: E&G Classic grill, K&N FIPK, BTG duals, rear lowered 1.5", LED washer lights, $20 catch can, Aoogah horn, Weatherflectors, Sunroof Deflector, Fuzzy Dice, rear logo flames, rear pinstripe graphic, Gen3 Taillights, rear sway bar, hood struts, Strut bar.
Traded in '02 Silver Touring Edition w/87,000 miles
Reply With Quote
  #7 (permalink)  
Old 22 Jan 2012, 09:15 am
Fresh Cruiser
 
Join Date: Jan 2012
Location: Beachwood, NJ
Posts: 1
Default Re: Horn not working, Fuses not blown... 2008 pt cruiser LX

I too am having a similiar problem, my horn and security in my 2007 pt cruiser, have stopped working as well. If I follow your diagram above will I set off the air bags? How do I go around this setback?
Reply With Quote
  #8 (permalink)  
Old 22 Jan 2012, 09:48 am
Obsessed Cruiser
 
Join Date: Sep 2001
Posts: 27,744
Default Re: Horn not working, Fuses not blown... 2008 pt cruiser LX

To take off the air bag module like in the picture above you need to work from the back side of the steering column with a pair of 90 degree snap-ring pliers to spread apart the spring clips that retain the module.

According to the instructions it says to always disable the airbag system but doesn't say how to do that.
__________________
Rules of the forum have been updated as of *07/07/2019* Please read them over.

- All decisions by the Moderator are semi-permanent, can and may be changed at his discretion but definitely will be the final word. Any action performed by the Administrator or Moderators are not to be discussed on the forum.
Reply With Quote
  #9 (permalink)  
Old 02 Jul 2015, 10:47 pm
Fresh Cruiser
 
Join Date: Jul 2015
Posts: 3
Default Re: Horn not working, Fuses not blown... 2008 pt cruiser LX

Have a 2008 PT the horn comes on out of the blue. I give the fuse box a smack and it stops. I think it is a relay in the fuse box but I don't know which one. Any thoughts. I'm new to forums and don't know how to post a new post. (yes I have been living under a rock and don't know how.
Reply With Quote
  #10 (permalink)  
Old 02 Jul 2015, 11:02 pm
Fresh Cruiser
 
Join Date: Jul 2015
Posts: 3
Default Re: Horn not working, Fuses not blown... 2008 pt cruiser LX

Just opened the door with the key and the horn went off. Again Smacked the fuse box and it went off.
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Ciggy lighter & Power outlet not working -all fuses fine. swisstony10 Tech & Performance Forum 19 09 May 2016 02:59 pm
'02 DC, 71k miles, Radio and horn stopped working Bulwapo Sound and Security Forum 10 18 Apr 2014 08:42 pm
Clock and horn quit working Frink General PT Cruiser Discussions 16 02 Dec 2012 06:01 pm
on a 2007 pt cruiser is there more than one location for fuses and relays? 07ptcruzin Tech & Performance Forum 2 16 Jun 2009 06:49 am
2008 PT Cruiser beelsamin Canada PT Forum 0 22 Dec 2007 03:43 pm


All times are GMT -5. The time now is 04:59 am.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors