PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > General Forums > Sound and Security Forum

PT Cruiser Forum

Advertisements
electrical demons?

 
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 15 Feb 2011, 09:59 am
Fresh Cruiser
 
Join Date: Dec 2010
Posts: 17
Send a message via Skype™ to blackbosoPT
Default electrical demons?

ok guys I've got a 2001 pt. Installed a new aftermarket Head unit,sub,amp. have sub and amp disconnected currently(started having issue with battery as soon as I installed). I've installed hundreds of stereos,subs,amps in my day. Now the battery died right away(suspect me having stereo on with out car on) so i replaced battery. wife takes the car last night...calls me says its acting funny...

1. upon start up it revs to around 2.5-3k rpm sits for a few seconds then drops to normal

2. Dome lights come on with headlights? Tried the switch...it will turn off the dome/map lights BUT only at the cost of turning off my dash lights too?

3.power locks and such all still work. so confused?

any ideas at all where i should start? I'm thinking I didnt get the negative cable tight enough or something but would this cause this? or is there an underlying issue
Reply With Quote
  #2 (permalink)  
Old 15 Feb 2011, 10:47 am
Obsessed Cruiser
 
Join Date: Sep 2001
Posts: 27,744
Default Re: electrical demons?

For No#1, it sounds like your IAC needs cleaning or replacing. It's the Idle Air Controller, attached to the throttle body. It can be taken off pretty easy and cleaned or just replace the whole part.



For No#2, If the dome lights won't go off without turning off the dash lights, you mat have a problem with the multifunction switch. That last "click" on the turn switch is supposed to work the dome lights only. Do you have that "click" and if so, what happens when you use it?
__________________
Rules of the forum have been updated as of *07/07/2019* Please read them over.

- All decisions by the Moderator are semi-permanent, can and may be changed at his discretion but definitely will be the final word. Any action performed by the Administrator or Moderators are not to be discussed on the forum.
Reply With Quote
  #3 (permalink)  
Old 15 Feb 2011, 01:49 pm
Fresh Cruiser
 
Join Date: Dec 2010
Posts: 17
Send a message via Skype™ to blackbosoPT
Default Re: electrical demons?

funny thing is I just went out to check this because last night unless I had everything in the off position(dash lights dimmer) the dome light/map lights would stay on....now it works as it should? check with headlights on/off checked switch many times...works fine now...haha

as for the IAC...that was my first suspect but wanted to see if it was related to the other electrical issues. I will pull it out and give it a thorough cleaning today.

Thank you very much
Reply With Quote
  #4 (permalink)  
Old 16 Feb 2011, 07:21 pm
Fresh Cruiser
 
Join Date: Dec 2010
Posts: 17
Send a message via Skype™ to blackbosoPT
Default Re: electrical demons?

replaced the IAC and runs like a top. thank you very much. havent had the map/dome light issue again....
Reply With Quote
  #5 (permalink)  
Old 16 Feb 2011, 08:02 pm
Obsessed Cruiser
 
Join Date: Sep 2001
Posts: 27,744
Default Re: electrical demons?

Great! good luck.
__________________
Rules of the forum have been updated as of *07/07/2019* Please read them over.

- All decisions by the Moderator are semi-permanent, can and may be changed at his discretion but definitely will be the final word. Any action performed by the Administrator or Moderators are not to be discussed on the forum.
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
electrical lyndammjmct Tech & Performance Forum 6 06 Feb 2011 03:06 pm
electrical problem. burning electrical plug cruiserjim269 General PT Cruiser Discussions 17 03 Dec 2010 03:38 pm
need electrical help thundercat2 Tech & Performance Forum 0 27 Sep 2008 08:02 am
Electrical Problem rcolving Tech & Performance Forum 3 18 Mar 2002 08:24 pm


All times are GMT -5. The time now is 05:51 am.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors