PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > General Forums > Sound and Security Forum

PT Cruiser Forum

Advertisements
Ugrade to an RB1 GPS/NAV Radio?

 
Like Tree12Likes

Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 26 Aug 2017, 01:32 pm
Young Cruiser
 
Join Date: Mar 2015
Location: Liberty MO
Posts: 61
Default Ugrade to an RB1 GPS/NAV Radio?

I picked up a used RB1 head unit from the local pick-n-pull yesterday. Unit came from a 2005 and I want to install in my 2003.

When connected, I have a high-pitch tone coming through the rear channels.

Is this the amplifier or do I need to visit the dealer to have the radio recognize a different vehicle?
Handy_Cruiser likes this.
Reply With Quote
  #2 (permalink)  
Old 26 Aug 2017, 01:40 pm
Handy_Cruiser's Avatar
Obsessed Cruiser
 
Join Date: Oct 2013
Location: Arkansas
Posts: 8,485
Default Re: Ugrade to an RB1 GPS/NAV Radio?

There's no programming required for the US-market oval-faced stereos, the RB1 uses no special amp and it works fine with the amp in an OEM PT subwoofer. I suspect interference over the PCI lead, poor grounding or a problem with the head unit itself.

First, cut the purple PCI wire. Your 2003 PCM is likely not programed to adequately communicate with the RB1. Plus, all it does in a PT is tell the RB1 which brand logo to show during boot up. And default is Chrysler anyway so the PCI wire is not needed. I found that it can screw up certain functions in the RB1 and in some aux adapters as well.




If that doesn't do it, try grounding the Chassis of the stereo unit. I found that one of the leads used on other oval-face stereos for ground is used for accessory data communication on the RB1. Run a wire from a screw on the stereo body out under the hood and temporarily attach it to the negative post on the battery. If this fixes the issue, you can find a more elegant place to provide the bonding.
rckstein and dougs like this.
__________________

Last edited by Handy_Cruiser; 26 Aug 2017 at 01:50 pm.
Reply With Quote
  #3 (permalink)  
Old 26 Aug 2017, 02:05 pm
Young Cruiser
 
Join Date: Mar 2015
Location: Liberty MO
Posts: 61
Default Re: Ugrade to an RB1 GPS/NAV Radio?

I'll give that a try. Thanks.
Reply With Quote
  #4 (permalink)  
Old 26 Aug 2017, 02:55 pm
Young Cruiser
 
Join Date: Mar 2015
Location: Liberty MO
Posts: 61
Default Re: Ugrade to an RB1 GPS/NAV Radio?

That's worked perfectly.

Sweet deal for $11.50 plus tax on half-price pick-n-pull day.

Now to find a map disc.

Thanks again.
Reply With Quote
  #5 (permalink)  
Old 02 Sep 2017, 08:40 pm
Young Cruiser
 
Join Date: Mar 2015
Location: Liberty MO
Posts: 61
Default Re: Ugrade to an RB1 GPS/NAV Radio?

Hey Handy,

Quick observation. Got a NAV (bad) disc today and it allowed me to reach previously unavailable diagnostic menu options. After resetting the unit, the default on the display reads JEEP.

Think if I reconnect the cut lead for a moment I can get the Chrysler wing back?

Thanks in advance.

Bob in Liberty MO
wingman55 likes this.
Reply With Quote
  #6 (permalink)  
Old 03 Sep 2017, 12:38 am
Handy_Cruiser's Avatar
Obsessed Cruiser
 
Join Date: Oct 2013
Location: Arkansas
Posts: 8,485
Default Re: Ugrade to an RB1 GPS/NAV Radio?

Quote:
Originally Posted by RCSnyder View Post
Hey Handy,

Quick observation. Got a NAV (bad) disc today and it allowed me to reach previously unavailable diagnostic menu options. After resetting the unit, the default on the display reads JEEP.

Think if I reconnect the cut lead for a moment I can get the Chrysler wing back?

Thanks in advance.

Bob in Liberty MO

Those disc often contain a system update for the stereo. Yours was likely intended for a Jeep. You could try the PCI wire to see if that works. If not, it will likely take a newer disc with an update specific to Chrysler. That would be my guess anyway. Please let us know if the PCI wire does the job and if the logo stays or not.
__________________
Reply With Quote
  #7 (permalink)  
Old 03 Sep 2017, 12:48 pm
dougs's Avatar
Cool Cruiser
 
Join Date: Aug 2013
Location: los angeles, california
Posts: 307
Default Re: Ugrade to an RB1 GPS/NAV Radio?

Hi,
Question: (Not entirely related to the above): On the Second Gen dash, to remove the center stack plastic front panel, I see there are two Phillips head screws, one in each of the round vents. Are these magnetized? Otherwise, how do you reinsert the screws thru the vent louvers and try to find the hole in near-dark conditions? Thanks!
Handy_Cruiser likes this.
__________________
Black base 2006 NA, dented front bumper, scratched rear bumper. 2008 Touring, one of 385 red Turbos built in 2008. Limited grill, body-colored mirrors, grab handle deleted, dual-tone horn, shorty antenna.
Reply With Quote
  #8 (permalink)  
Old 03 Sep 2017, 01:10 pm
Handy_Cruiser's Avatar
Obsessed Cruiser
 
Join Date: Oct 2013
Location: Arkansas
Posts: 8,485
Default Re: Ugrade to an RB1 GPS/NAV Radio?

Quote:
Originally Posted by dougs View Post
Hi,
Question: (Not entirely related to the above): On the Second Gen dash, to remove the center stack plastic front panel, I see there are two Phillips head screws, one in each of the round vents. Are these magnetized? Otherwise, how do you reinsert the screws thru the vent louvers and try to find the hole in near-dark conditions? Thanks!
They are not magnetic. I've used both a magnetic screwdriver or a regular screwdriver with long needle nose pliers to grab the screws. A good magnetic screwdriver seems to work best.
rckstein and dougs like this.
__________________
Reply With Quote
  #9 (permalink)  
Old 03 Sep 2017, 03:22 pm
dougs's Avatar
Cool Cruiser
 
Join Date: Aug 2013
Location: los angeles, california
Posts: 307
Default Re: Ugrade to an RB1 GPS/NAV Radio?

Quote:
Originally Posted by Handy_Cruiser View Post
They are not magnetic. I've used both a magnetic screwdriver or a regular screwdriver with long needle nose pliers to grab the screws. A good magnetic screwdriver seems to work best.
Thanks! I'll give it a try...
__________________
Black base 2006 NA, dented front bumper, scratched rear bumper. 2008 Touring, one of 385 red Turbos built in 2008. Limited grill, body-colored mirrors, grab handle deleted, dual-tone horn, shorty antenna.
Reply With Quote
  #10 (permalink)  
Old 03 Sep 2017, 03:32 pm
rckstein's Avatar
Obsessed Cruiser
 
Join Date: Dec 2010
Location: Euless, TX
Posts: 12,002
Default Re: Ugrade to an RB1 GPS/NAV Radio?

Quote:
Originally Posted by dougs View Post
Hi,
Question: (Not entirely related to the above): On the Second Gen dash, to remove the center stack plastic front panel, I see there are two Phillips head screws, one in each of the round vents. Are these magnetized? Otherwise, how do you reinsert the screws thru the vent louvers and try to find the hole in near-dark conditions? Thanks!
The key is you don't have to completely remove them to remove the center bezel, they can stay in the bezel (see below pic). They just need to be unscrewed enough to clear the screw insert in the dash. Once you do it a couple of times, you will then know how much to unscrew them and they will remain with the bezel.

dougs and Handy_Cruiser like this.
__________________

'06 Touring Edition NA Automatic
150k Miles / Electric Blue Pearl
USMC '82 - '93

Last edited by rckstein; 03 Sep 2017 at 05:45 pm.
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
fm radio broadcaster/ transmitter for stock radio garyd75 Sound and Security Forum 3 15 Mar 2017 02:24 pm
Why would vent selector change the radio station? (aftermarket radio) Spaz Sound and Security Forum 11 08 May 2016 02:10 am
2007 chrysler base cd radio to chrysler sirus radio swap? peterspt Sound and Security Forum 0 09 Aug 2014 02:14 am
Installed New Radio, Interior Lights wont wont, Radio Doesnt receive "Constant" Power Mc5Cent Interior Accessories Forum 0 08 May 2013 07:12 pm


All times are GMT -5. The time now is 10:13 am.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors