PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > 2.4L Turbo Forums > Stage Turbo Kits

PT Cruiser Forum

Advertisements
BOV install Problem/Question

 
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 17 Sep 2003, 12:09 am
Fresh Cruiser
 
Join Date: May 2003
Location: .
Posts: 38
Default BOV install Problem/Question

I just finished installing the Mopar BOV on my 5 speed and i am unsure if it is working properly and if i left a part off.

1. I found an O-ring near the windshield wipers where i placed all my tools but i don't think i placed any parts in that area. Is an O-ring part of the BOV system? My pcm was replaced earlier in the day so it could be from that.

2.i am unsure if the BOV is working properly. I DO NOT have stage 1 installed. i can hear the BOV activate(loud pshhh) every time i shift. i can also hear the BOV open(very short and mild pshhh) when i let off the gas but no boost pressure is indicated on my boost gauge.

Any input will be appreciated
thanks
Reply With Quote
  #2 (permalink)  
Old 17 Sep 2003, 09:28 am
Cool Cruiser
 
Join Date: Mar 2003
Location: .
Posts: 270
Default

The BOV consisted of the BOV, a gasket, 3 bolts and the accompanying washers. At least, there was no O-Ring in my kit. I scanned the instructions and they are -> http://home.comcast.net/~dtibs/mprbov/

You can see there is no mention of an O-ring.

Hope this helps.
__________________
2003 PT Turbo Deep Cranberry \'R\' Package Stock + AutoStick
Came off assembly line 1/14/03 (Tuesday) between 2200 and 2300.
Reply With Quote
  #3 (permalink)  
Old 17 Sep 2003, 09:29 am
Cool Cruiser
 
Join Date: Mar 2003
Location: .
Posts: 270
Default

Forgot to mention, your BOV is working correctly.
__________________
2003 PT Turbo Deep Cranberry \'R\' Package Stock + AutoStick
Came off assembly line 1/14/03 (Tuesday) between 2200 and 2300.
Reply With Quote
  #4 (permalink)  
Old 17 Sep 2003, 11:22 am
Fresh Cruiser
 
Join Date: May 2003
Location: .
Posts: 38
Default

Thanks DT, I wasn't sure if the o-ring fell off the the inner surface of the stock surge valve.
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
How to install lowering springs? Rymanrph Wheels, Tires, Suspension 4 01 Feb 2010 01:30 pm
Anyone install Borla Dual exhaust? crazie.eddie General PT Cruiser Discussions 16 10 Oct 2004 09:21 pm
Dealer price for BOV install? CarolinaBlue_GT Turbo Performance 26 05 Jan 2004 02:58 pm
BOV Install RODRUN Stage Turbo Kits 7 12 Oct 2003 11:27 am
Install of Water Temp Gauge jramosGT Turbo Performance 6 18 Apr 2003 03:35 am


All times are GMT -5. The time now is 01:33 am.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors