PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > 2.4L Turbo Forums > Stage Turbo Kits

PT Cruiser Forum

Advertisements
stage 1 install problem

 
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 19 Jun 2005, 03:38 pm
Fresh Cruiser
 
Join Date: May 2003
Location: .
Posts: 38
Default stage 1 install problem

I began installing stage 1 today and have a problem. After removing the PCM and the mounting bracket from the pcm, i attempted to install the bracket on the new pcm. the screws would not start and on closer inspection i discovered the new pcm was not tapped to receive the screws. Has anyone else had this problem? i will call T Thrift tommorrow at haynes to see if they can help me with this problem. For now i am dead in the water.
Can i install the injectors and run them with the stock pcm without any damage?
Reply With Quote
  #2 (permalink)  
Old 19 Jun 2005, 03:51 pm
Veteran Cruiser
 
Join Date: Mar 2003
Location: Oregon.
Posts: 3,521
Default

Quote:
quote:Originally posted by gooberff

I began installing stage 1 today and have a problem. After removing the PCM and the mounting bracket from the pcm, i attempted to install the bracket on the new pcm. the screws would not start and on closer inspection i discovered the new pcm was not tapped to receive the screws. Has anyone else had this problem? i will call T Thrift tommorrow at haynes to see if they can help me with this problem. For now i am dead in the water.
Can i install the injectors and run them with the stock pcm without any damage?
I've heard this before. Can you tap them yourself?
You must have an '03 and yes you can install the injectors. Those are the same injectors that are in the '04-'05.
__________________
\'05 Stone White SRT4

\'04 Graphite PT Automatic
Reply With Quote
  #3 (permalink)  
Old 19 Jun 2005, 04:16 pm
Fresh Cruiser
 
Join Date: May 2003
Location: .
Posts: 38
Default

I thought about tapping it myself but i was concerned about the oil and shavings getting into the pcm. it looks like i can remove the aluminum rear section to tap it seperately but i didn't want to take the pcm apart and damage circuitry inside. if anyone has had their pcm apart let me know if the aluminum back cover is free of any circuitry.
Reply With Quote
  #4 (permalink)  
Old 19 Jun 2005, 08:49 pm
Senior Cruiser
 
Join Date: Jan 2003
Location: Huntington Beach, CA, USA.
Posts: 1,799
Default

The mounting scews are self tapping. The mounts are external. Go ahead and bolt it up. That is how it works.
__________________
'03 Inferno Red GT, 5 speed, STAGE 1, Mopar BOV, Plastic Intake, Modified Upper and Lower Airbox, Custom Airbox-to-turbo pipe, Borla dual exhaust, Maddog Short Shifter, Drilled/Slotter Rotors, Ceramic Pads, chrome wheels, chrome door spears, AMP chrome fuel door, PT Cruiser 3rd light diffuser, H&R Springs, Rear Sway Bar added, MGW chrome door lock pulls, Blane's hood struts, Custom license plate mount, some interior dress up stuff...more to come
Reply With Quote
  #5 (permalink)  
Old 19 Jun 2005, 10:14 pm
Fresh Cruiser
 
Join Date: May 2003
Location: .
Posts: 38
Default

well i installed the pcm before seeing the post about self tapping screws. i used 10/24 stainless screws with a lock washer, locktite and double nutted. it doesn't appear anything will rub and wear. What do you think about this install or should i remove and use the self tapping screws.

I took a short test drive and can see gretaer 1st gear power and higher boost pressures while driving in the 13 to 14 psi range.
Reply With Quote
  #6 (permalink)  
Old 20 Jun 2005, 01:42 am
Young Cruiser
 
Join Date: Mar 2005
Location: San Bernardino, Ca, USA.
Posts: 92
Send a message via AIM to TurboCruiser13
Default

Lol, honestly...you could probably duct tape the damn pcm to the firewall it won't make any difference. When I had bought my S1 I heard that some pcms came with tapped holes and some didn't. Well, mine didn't, just like yours. I just used the screws that were previously on the car and stuck em in the holes and cranked down on them till they went in...never had a problem since, and they're extremely tight so I doubt it'll ever fall out lol
Reply With Quote
  #7 (permalink)  
Old 29 Jun 2005, 12:22 am
Fanatic Cruiser
 
Join Date: May 2003
Location: Rhode Island.
Posts: 950
Default

Quote:
quote:Originally posted by TurboCruiser13

Lol, honestly...you could probably duct tape the damn pcm to the firewall it won't make any difference. When I had bought my S1 I heard that some pcms came with tapped holes and some didn't. Well, mine didn't, just like yours. I just used the screws that were previously on the car and stuck em in the holes and cranked down on them till they went in...never had a problem since, and they're extremely tight so I doubt it'll ever fall out lol
What he said. Last I checked the PCM was still bolted on tight
__________________

2003 GT Inferno Red,5-spd,Eibach Springs,Koni Sport Adjustables, Eibach front and rear Sway Bars, Mopar Stage 1,Mopar BOV,Custom 2.5\" Dual Tip Exhaust (Magnaflow),Hurst Short Throw Shifter, Pioneer DEH6500 Headunit, RF Punch 300 and 301 Amps,RF 12\" Sub and MB Quart Reference and Premium Speakers,Ronal RT 17x7.5\'s with Michelin Pilot Sport 225/45ZR17s, Koni Adjustible shocks, Keystone single scoop, GT Airraid Intake, Mopar Ground Effects
Homepage:
http://www.cardomain.com/id/ptgtredman

http://blueman.ptenthusiasts.net/index.html
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Install price for stage 1....crazy. Mr.Barton Stage Turbo Kits 14 17 Dec 2005 07:30 pm
Transmission Problem - Stage I mich_132003 Stage Turbo Kits 22 11 Dec 2003 02:00 pm
Another Dealer who will install stage I Larry Stage Turbo Kits 5 18 Nov 2003 03:23 am
Stage 1 in, but still have WOT problem. TurboDanny Stage Turbo Kits 15 24 Oct 2003 04:48 pm
Macster's Stage 1 Install macster Stage Turbo Kits 9 23 Aug 2003 11:46 pm


All times are GMT -5. The time now is 09:06 pm.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2021, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors