PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > General Forums > Tech & Performance Forum

PT Cruiser Forum

Advertisements
Problem with Horn Button

 
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 03 Dec 2005, 12:43 am
Fresh Cruiser
 
Join Date: Dec 2005
Location: Carlisle, PA.
Posts: 5
Default Problem with Horn Button

We just bought an 2006 inferno red, Limited Edition, Turbo PT Cruiser abouta month ago. Both my husband and I have a "near miss" when someone had pulled out in front of us and neither of us could find the correct spot to hit on the horn button so it would blow. We've played around with it but it appears there's just a very small area (below the Chrysler symbol) that actually blows the horn. We've checked out slightly older PT's and their horn buttons work much better. We also took it back to the dealership and had it checked by the service department. They told us that it appears to be working correctly. That it apparently has to do with the way the airbag is installed.

Anyone have any experience with this problem?


Thanks
Reply With Quote
  #2 (permalink)  
Old 14 Feb 2006, 02:40 am
Fresh Cruiser
 
Join Date: Feb 2006
Location: .
Posts: 4
Default

I just bought a 2006 silver limted PT Cruiser turbo for my mom. Similar problem, only worse. Her horn only works occasionally. Dealer had it for over a week, returned it in similar condition (barely working). Now back at the dealer for round two. I tried another car, and the horn was loud and clear, no matter where you pressed on the center of the steering wheel. It sounds to me like the dealer has not fixed your problem either.
Reply With Quote
  #3 (permalink)  
Old 14 Feb 2006, 11:58 am
Fresh Cruiser
 
Join Date: Oct 2005
Location: Carolina, P.R..
Posts: 8
Default

I also have a 2006 ltd edition and the horn is exactly in the same place like yours below the Chrysler symbol.
By the way any of you guys feel a wobble in the aceleration during during your drive off that then disapear and feel a stronger when you step in the gas in hard accelaration and then goes away as you go ito a higher speed and is not in the steer is like in the front body
Reply With Quote
  #4 (permalink)  
Old 15 Feb 2006, 10:00 pm
Obsessed Cruiser
 
Join Date: Dec 2002
Posts: 6,787
Default

stay on the dealership till the problems fixed !!
Reply With Quote
  #5 (permalink)  
Old 16 Feb 2006, 01:03 am
SRG SRG is offline
Cool Cruiser
 
Join Date: Aug 2002
Location: .
Posts: 320
Default

Since this seems to be popping up more and more with the 06's, maybe the new owners should notify NHTSA, being this is an obvious safety issue?

SRG
Reply With Quote
  #6 (permalink)  
Old 17 Feb 2006, 11:31 pm
Fresh Cruiser
 
Join Date: Feb 2006
Location: .
Posts: 4
Default

Got the PT back today. It looks like they fixed the horn this time. Hit anywhere on the padded section and it honks. No more find the magic spot. According to the dealer, the problem was in the ground wires leading to the contacts at the base of the horn spring assembly. They also told me that three other new 2006 owners had the same problem. I think the problem drove them a little crazy,expecially when it did not work after the first attempted fix (replacing the entire airbag assembly). Needless to say I was a little bit unhappy when they sent the car home and the horn still did not work! But they find a fix, and I give them credit for it. It is pretty clear the Chrysler needs to address a problem at their factory.

Bottom line: there is a fix to the problem!
Reply With Quote
  #7 (permalink)  
Old 18 Feb 2006, 06:40 pm
Obsessed Cruiser
 
Join Date: Dec 2002
Posts: 6,787
Default

congrats!![^]
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Horn button problem??? vetteloverpa General PT Cruiser Discussions 20 24 Sep 2014 03:27 pm
Horn going dead turbomangt General Turbo Discussions 5 20 Jun 2009 04:35 pm
2006 Horn Fixed Hooligan Interior Accessories Forum 4 17 Feb 2007 08:54 pm
Aoogah horn quicksilverdon Tech & Performance Forum 12 23 Aug 2004 05:19 pm
2nd horn addition for '03 GT JohnM General PT Cruiser Discussions 13 31 Jul 2003 10:50 pm


All times are GMT -5. The time now is 11:26 am.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors