PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > General Forums > Tech & Performance Forum

PT Cruiser Forum

Advertisements
Engine Reving?

 
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 16 Dec 2005, 03:16 pm
Fresh Cruiser
 
Join Date: Oct 2004
Location: J-Ville, Florida, USA.
Posts: 5
Send a message via AIM to vertigo
Default Engine Reving?

I've had a problem that i fortunately haven't seen in a few months - but am concerned about none-the-less.

When I would put in the clutch to coast (slowing for a traffic light) the engine would rev on it's own, hitting no more than 4k RPM. it wouldn't go up and stay, but bob back and forth between idleing and hitting around 3-3.5k RPM.

I've had my pt since Feb. 02 and haven't changed the battery - which is a prime suspect in a mushy start problem i'm having - (especially since i don't drive every day) - but i don't see how that could be a problem for the idling.

any ideas?
Reply With Quote
  #2 (permalink)  
Old 16 Dec 2005, 04:40 pm
Cool Cruiser
 
Join Date: Nov 2005
Location: Dallas, Tx., USA.
Posts: 227
Default

Sounds like the cable to your throtle body may need to be adjusted. May need to be tightened up a little bit. Or it could be sliping. If it's under warranty you should just bring it in to your dealership. I doubt it has anything to do with your battery.
Reply With Quote
  #3 (permalink)  
Old 16 Dec 2005, 04:55 pm
Fresh Cruiser
 
Join Date: Oct 2004
Location: J-Ville, Florida, USA.
Posts: 5
Send a message via AIM to vertigo
Default

I don't understand how the throttle could be slipping. It would have to pull on the throttle to make it rev.

I didn't think it had to do with the battery, per se, but maybe the alternator was having to work overtime to keep the electrical system up due to the battery being crap? i dunno. Just a thought, be it unlikely.

oh - and It's not under warantee anymore i don't think.
__________________
xxX||VERTIGO||Xxx
crap APC intake (temporary), Flowmaster exaust.
Fosgate HU, Fogate mids, highs.
COMING SOON:
Profile AP2000 pushing 4 Infinity Reference 12\'s,
2 Profile AP400\'s pushing mids, highs.
Reply With Quote
  #4 (permalink)  
Old 16 Dec 2005, 07:17 pm
Obsessed Cruiser
 
Join Date: Dec 2002
Posts: 6,787
Default

idle sensor ?? just a thought [:I]
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Engine problem BORICUA Tech & Performance Forum 50 23 Jun 2012 03:40 pm
"Mysterious" turbo engine noise...??? Gary04GT Turbo Performance 76 21 Aug 2006 08:28 am
Review: $2200 for a NA replacement engine PT Ctown General PT Cruiser Discussions 8 24 Jul 2006 01:08 pm
Turbo Engine Replacement Bigphil3232 General Turbo Discussions 9 17 Nov 2004 05:43 am
TSB 1802903: Engine Misfire PTskilla General Turbo Discussions 0 18 Aug 2003 12:13 am


All times are GMT -5. The time now is 01:46 am.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors