PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > General Forums > Tech & Performance Forum

PT Cruiser Forum

Advertisements
Possible Battery Problem ?

 
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 02 Jul 2007, 07:05 am
Johns Steel Blue's Avatar
Fanatic Cruiser
 
Join Date: Jun 2005
Location: Midlothian, Va.
Posts: 567
Question Possible Battery Problem ?

Ok. Three times in the past 7-10 days I have went to start my Cruiser and I get that definite drag, or even no responses at first, that you tend to associate with a failing battery. To date, it has finally started after a couple tries. I took it to Autozone yesterday and they put a load test on the battery and it appeared to test fine. Now I am not sure if replacing the battery will resolve the problem. The battery is the original and I have had the car for 4 years 3 months. I tested for error codes and came back clean. Any input would be appreciated.
__________________
John








People say I have a drinking problem. I Drink... I Get Drunk... I Fall Down... No problem! ! !
Reply With Quote
  #2 (permalink)  
Old 02 Jul 2007, 07:37 am
Hooligan's Avatar
Obsessed Cruiser
 
Join Date: Aug 2003
Posts: 6,023
Default Re: Possible Battery Problem ?

John, I think it is time to change the battery. When you get a hesitation like that even tho the battery checks out, it has just about maxed out. 4 1/2 years original is a long time. Autozone may be willing to put one in to see if it helps.
Good Luck
__________________

2008 Silver Steel Metallic, Touring, NA, Sirius; Chromed door handles; lower grille; fog light surrounds; chrome front & rear bumpers strips; Airaid air filter; Bassani duals; Modesty Cover; Autolite AP5263 Platinum Plugs (.040); Crane Plug Wires; NAPA Ceramic pads; Blane hood struts; PTeazer Gas, Brake & Foot Rest Pedals, '05 Rear Step Pad, Stainless Door Sills, Llumar tint, "A" Piller chrome; APC Strut Bar
Reply With Quote
  #3 (permalink)  
Old 02 Jul 2007, 08:31 am
quicksilverdon's Avatar
Obsessed Cruiser
 
Join Date: Nov 2003
Location: Felton, Delaware
Posts: 20,501
Default Re: Possible Battery Problem ?

I suspect that in driving it to the Autozone you charged it enought that it appeared fine. 4 1/2 years is all you're going to get....
__________________
"Anti-intellectualism has been a constant thread winding its way through our political and cultural life,
nurtured by the false notion that democracy means that 'my ignorance is just as good as your knowledge."
Isaac Asimov"

'05 Limited Turbo Lite, (Silver, of course)4-wheel ABS, Sunroof, Spoiler. Mods: E&G Classic grill, K&N FIPK, BTG duals, rear lowered 1.5", LED washer lights, $20 catch can, Aoogah horn, Weatherflectors, Sunroof Deflector, Fuzzy Dice, rear logo flames, rear pinstripe graphic, Gen3 Taillights, rear sway bar, hood struts, Strut bar.
Traded in '02 Silver Touring Edition w/87,000 miles
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
PT Crusier battery dies after 5 days of no use. PT OWNER General Turbo Discussions 22 28 Jan 2009 11:51 am
Battery Corrosion SteelBlueGT General Turbo Discussions 9 19 May 2005 06:47 pm
I think I'm having a power steering problem! lumofny Tech & Performance Forum 5 18 Jan 2005 01:12 pm
Unknown RPM surge problem (manual) Ctown Tech & Performance Forum 4 26 Dec 2004 08:48 pm
Battery Failure ptbcblues Tech & Performance Forum 7 03 Dec 2003 03:48 pm


All times are GMT -5. The time now is 05:17 pm.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors