PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > General Forums > Tech & Performance Forum

PT Cruiser Forum

Advertisements
Oxygen Sensor??HELP??

 
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 22 Jul 2007, 09:56 am
mjb457's Avatar
Fanatic Cruiser
 
Join Date: Oct 2005
Location: Bucks County,PA. USA
Posts: 955
Default Oxygen Sensor??HELP??

I have 50k miles '03 na Pt anyway when warm car misses very intermittedly,,,kind of seems like it even is running on 3- 3/4 cylinders etc,,than goes away & runs great! Ive disconnected battery & reset computer,added injector cleaner 2x's (all other services done),changed wires,plugs etc,,no codes thrown... mechanic is leaning towards a weak oxygen sensor? One site on mechanical PT issues also seems to lean that way? Any suggestions & how hard & expensive is this?? Thanks MJB
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Anyone running a downpipe? MEXICANPT Turbo Performance 58 08 Mar 2004 06:58 pm
Will this work on a GT?? RobGT Turbo Performance 12 29 Apr 2003 02:42 pm


All times are GMT -5. The time now is 04:35 am.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors