PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > General Forums > Tech & Performance Forum

PT Cruiser Forum

Advertisements
PLUGS HELP:??

 
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 08 Aug 2007, 12:09 pm
mjb457's Avatar
Fanatic Cruiser
 
Join Date: Oct 2005
Location: Bucks County,PA. USA
Posts: 943
Default PLUGS HELP:??

Ok we changed both Plugs & wires,,Champion 7570 double platinums gapped at .40 ,,,new wires,,etc,,,just wondering ..I did have a miss(ALL GONE runs smooth) but now Pt seems sluggish at times,??,,,humidity has ben high lately but was wondering if its the plugs or something else?Should I have stayed with standard champions? We disconnected the battery for 10 mintes,,,PT also has adrop in K& N which was also serviced,,,stock exhaust....Automatic with 50K..any ideas? does it have to learn pep again>> HELP?? thanks Mjb
Reply With Quote
  #2 (permalink)  
Old 08 Aug 2007, 01:22 pm
Obsessed Cruiser
 
Join Date: Sep 2001
Posts: 27,743
Default Re: PLUGS HELP:??

Your plugs are fine, I've had the same set-up for 20K+. Yes, after disconnecting the battery the computer will re-learn your driving habits. If you've been driving slow to save on gas, drive your normal way for awhile to see if it changes. You haven't filled out your profile so I can't tell where your from. Is the high humidity along with high heat? All cars run better (feels faster) in cooler weather.
Reply With Quote
  #3 (permalink)  
Old 08 Aug 2007, 01:36 pm
mjb457's Avatar
Fanatic Cruiser
 
Join Date: Oct 2005
Location: Bucks County,PA. USA
Posts: 943
Default Re: PLUGS HELP:??

Im in eastern Pa,,I went to these plugs after reading your post...again thanks for all any tips,,,, (I did have a Mopar-Dual ) but removed it about 2000miles ago( back in June)because I got tired of noise at highway speeds) actually ran very similiar when removed,,this seems a later afterfact.......
Reply With Quote
  #4 (permalink)  
Old 08 Aug 2007, 01:46 pm
Obsessed Cruiser
 
Join Date: Sep 2001
Posts: 27,743
Default Re: PLUGS HELP:??

Dual exhaust for a non-turbo don't do anything but look good and make more noise. When you said it acted very similar, do you mean sluggish after you removed the duals, like sluggish after your tune-up?
Reply With Quote
  #5 (permalink)  
Old 08 Aug 2007, 01:58 pm
mjb457's Avatar
Fanatic Cruiser
 
Join Date: Oct 2005
Location: Bucks County,PA. USA
Posts: 943
Default Re: PLUGS HELP:??

It ran the same after removing duals-not sluggish-same ...than afterwards a miss developed ( about 2 weeks after duals off..(not related Im sure)...than after reading your posts we determined a plug was bad..after only 16K miles (stock champions)changed plugs at 34K(1st time)----- & NOW has 50K we changed to Platinums- 7570(after reading your recomendation-mechanic was hestitant to do it but did because I insisted) anyway just seems a bit sluggish now... ( I also changed battery -due 0ver 4 years old) Im just giving you a chain of events,,,(I als serviced to K&N drop in at this time also) Im just making sure everthing is Ok ,,,, Making sure plugs arent issue because of mechanics be hesitant,,thanks MJB (I really want to keep car but dont want problems down the road mor than needed.)
Reply With Quote
  #6 (permalink)  
Old 08 Aug 2007, 02:20 pm
Obsessed Cruiser
 
Join Date: Sep 2001
Posts: 27,743
Default Re: PLUGS HELP:??

A member on a lot of the forums and an expert with cars (user name MX-5) helped develop the Double Platinum plugs with Champion. The original number of the plug was #7440 and MX-5 listed the new updated number of the plug as #7570. Chrysler came out with the new plug gap of .040in and a TSB (Tecnical Service Bulletin) was issued to dealers to gap all non-turbo 2.4ltr engines that way.

Last edited by CREWZIN; 08 Aug 2007 at 02:24 pm.
Reply With Quote
  #7 (permalink)  
Old 08 Aug 2007, 02:37 pm
mjb457's Avatar
Fanatic Cruiser
 
Join Date: Oct 2005
Location: Bucks County,PA. USA
Posts: 943
Default Re: PLUGS HELP:??

I believe you,,I really do,,, It was my mechanic who doubted me that made me rethink,(he said he researched all bullitins & couldnt find anywhere the 7570Platinums were listed?&anyway its been about a week.. I quess I just drive it & hope it improves,, you and other guys are great with the tips,,, I was a diesel tech (years ago) so i do understand mechanics,,,,,,,My mechanic is actually a very good consciensous 18 year veteran of MOPAR,,,,,,,,,,,,, he is on Vaca this week....any other suggestions or just drive ..??
Reply With Quote
  #8 (permalink)  
Old 08 Aug 2007, 02:46 pm
Obsessed Cruiser
 
Join Date: Sep 2001
Posts: 27,743
Default Re: PLUGS HELP:??

I'd say drive it a little harder than normal on safe roads (I work for the police so I can't tell you to go out there and drag race a few people) and let the computer know your not an old lady behind the wheel. Also, take it out as early in the morning as possible one day to see if it drives better. if it does, then it's the heat and humidity that are making things sluggish.
Reply With Quote
  #9 (permalink)  
Old 08 Aug 2007, 02:59 pm
mjb457's Avatar
Fanatic Cruiser
 
Join Date: Oct 2005
Location: Bucks County,PA. USA
Posts: 943
Default Re: PLUGS HELP:??

Will do,,,thanks..hoping for many many miles MJB
Reply With Quote
  #10 (permalink)  
Old 11 Aug 2007, 01:33 pm
mjb457's Avatar
Fanatic Cruiser
 
Join Date: Oct 2005
Location: Bucks County,PA. USA
Posts: 943
Default Re: PLUGS HELP:??

OK Its seems fine now,,much peppier,,,, only took a week! Its cooled off here & I think computer is set better to my driving..Also MPG is up to 20mpg in around town driving with AC..lets hope it last!! MJB
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
spark plugs ote69 Turbo Performance 28 11 Jul 2010 09:59 am
3/25/05 UPDATE - DONE! - New Plugs and Wires NGK BumperBob Tech & Performance Forum 14 31 Mar 2005 01:06 am
Spark plugs: newbie question Edwin Astacio Tech & Performance Forum 12 01 Nov 2004 12:21 pm
ZEX Spark Plugs Jerry Tech & Performance Forum 9 27 May 2004 07:32 pm
Spark Plugs kidturbofan Turbo Performance 2 08 Oct 2003 10:40 pm


All times are GMT -5. The time now is 07:15 pm.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors